Broken Lav....Fixes?? at

Go Back   DV Info Net > The Tools of DV and HD Production > All Things Audio

All Things Audio
Everything Audio, from acquisition to postproduction.

Thread Tools Search this Thread
Old November 17th, 2005, 07:46 AM   #1
Regular Crew
Join Date: Jan 2003
Location: Boston, MA
Posts: 116
Broken Lav....Fixes??

hi...I have an AT-803B omni lav...I seem to have a short in the capsule.....movement makes a lot of noise and intermittient loud 60 cycle hum.....any way to fix this?? is it worth fixing?? if not, would it be possible to reuse the power supply?? I know power supplies are anywhere from $129 and up....would it be possible to wire say a T4F connector onto the supply and use it with a Sennheiser MK2-4, for instance?? just hate to toss the whole thing in the trash...
Omens carry only as much weight as we choose to assign them.
Steve Leone is offline   Reply With Quote
Old November 17th, 2005, 11:26 AM   #2
Inner Circle
Join Date: Nov 2004
Location: Baltimore, MD USA
Posts: 2,317
AT has a very good repair policy; always has.

Contact them directly.

Ty Ford
Ty Ford is offline   Reply

DV Info Net refers all where-to-buy and where-to-rent questions exclusively to these trusted full line dealers and rental houses...

Professional Video
(800) 833-4801
Portland, OR

Omega Broadcast
(512) 251-7778
Austin, TX

(973) 335-4460
Mountain Lakes, NJ

Abel Cine Tech
(888) 700-4416
N.Y. NY & L.A. CA

(800) 238-8480
Glendale, CA

Precision Camera
(800) 677-1023
Austin, TX

DV Info Net also encourages you to support local businesses and buy from an authorized dealer in your neighborhood.
  You are here: DV Info Net > The Tools of DV and HD Production > All Things Audio

Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -6. The time now is 01:44 PM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2015 The Digital Video Information Network