A short stabilization demo - Page 2 at DVinfo.net

Go Back   DV Info Net > Cross-Platform Post Production Solutions > Digital Compositing and Effects

Digital Compositing and Effects
After Effects, Shake and everything else.


Reply
 
Thread Tools Search this Thread
Old December 2nd, 2009, 12:03 PM   #16
Trustee
 
Join Date: May 2004
Location: Knoxville, Tennessee
Posts: 1,666
>> denoising is on par with NEAT Video but free

Slightly OT, but which denoiser(s) do you recommend, Perrone? I presently use the VDub version of Neat Video but am always interested in alternatives....
Graham Hickling is offline   Reply With Quote
Old December 2nd, 2009, 12:05 PM   #17
Inner Circle
 
Join Date: Nov 2006
Location: Tallahassee, FL
Posts: 4,100
I typically use the MSU Denoiser. It's slow but extremely effective.
__________________
DVX100, PMW-EX1, Canon 550D, FigRig, Dell Octocore, Avid MC4/5, MB Looks, RedCineX, Matrox MX02 mini, GTech RAID, Edirol R-4, Senn. G2 Evo, Countryman, Moles and Lowels.
Perrone Ford is offline   Reply With Quote
Old December 16th, 2009, 05:38 PM   #18
Inner Circle
 
Join Date: Nov 2006
Location: Tallahassee, FL
Posts: 4,100
Wanted to update this thread a bit...

Since fooling around with the settings, I've now settled on a default of 3000 for the smoothness settings. I've experimented up to 5000 for things I wanted very steady, and I understand some folks have gone up to 15k and above. So experiment and see what works for you.
__________________
DVX100, PMW-EX1, Canon 550D, FigRig, Dell Octocore, Avid MC4/5, MB Looks, RedCineX, Matrox MX02 mini, GTech RAID, Edirol R-4, Senn. G2 Evo, Countryman, Moles and Lowels.
Perrone Ford is offline   Reply With Quote
Old December 20th, 2009, 02:46 PM   #19
Inner Circle
 
Join Date: Jan 2006
Posts: 2,290
Deshaker

I installed the Deshaker plugin then I imported an AVI, set my parameters, made two passes and saved as an AVI. But my finished video still has the white motion tracking dots all over it and the numbers reading out in the lower left of the screen.

What'd I do wrong?
Brian Luce is offline   Reply With Quote
Old December 20th, 2009, 03:08 PM   #20
Inner Circle
 
Join Date: Nov 2006
Location: Tallahassee, FL
Posts: 4,100
Quote:
Originally Posted by Brian Luce View Post
I installed the Deshaker plugin then I imported an AVI, set my parameters, made two passes and saved as an AVI. But my finished video still has the white motion tracking dots all over it and the numbers reading out in the lower left of the screen.

What'd I do wrong?
Ah yes....

When you make the first pass through the video, make sure the filter is set to PASS 1. When it finishes that pass, you have to bring the video back to the beginning (just hit the rewind key at the bottom) and go back into the filter and change it to pass 2. Otherwise it just redoes Pass 1 again.
__________________
DVX100, PMW-EX1, Canon 550D, FigRig, Dell Octocore, Avid MC4/5, MB Looks, RedCineX, Matrox MX02 mini, GTech RAID, Edirol R-4, Senn. G2 Evo, Countryman, Moles and Lowels.
Perrone Ford is offline   Reply With Quote
Old December 20th, 2009, 03:55 PM   #21
Inner Circle
 
Join Date: Jan 2006
Posts: 2,290
Quote:
Originally Posted by Perrone Ford View Post
Ah yes....

When you make the first pass through the video, make sure the filter is set to PASS 1. When it finishes that pass, you have to bring the video back to the beginning (just hit the rewind key at the bottom) and go back into the filter and change it to pass 2. Otherwise it just redoes Pass 1 again.
I click PASS 1 and then click the >0, the motion tracking dots appear and the clip plays to the end. Back to filters, Deshaker, click PASS 2, rewind then another >0 and again it plays with the white tracking dots. Save As AVI, it renders out and the new file appears on the desktop. That file still has the white motion dots when I play it as well as the ticker in the bottom left with zoom, pan Y and rotate info. And NO motion smoothing has occurred.

If I look at Virtualdub, in the B window, the original file says "This frame was not processed in pass 1. And nothing will play. Black screen There's also a yellow box in the right corner of the B window saying "No previous frame to match on".
Brian Luce is offline   Reply With Quote
Old December 20th, 2009, 04:15 PM   #22
Inner Circle
 
Join Date: Nov 2006
Location: Tallahassee, FL
Posts: 4,100
You are definitely doing something wrong... The Second pass should show no white dots in the output screen. So when you click "OK" on pass 2, it should take you back to the filters menu. Does it say (pass 2) at the end of the line for the deshaker filter?
__________________
DVX100, PMW-EX1, Canon 550D, FigRig, Dell Octocore, Avid MC4/5, MB Looks, RedCineX, Matrox MX02 mini, GTech RAID, Edirol R-4, Senn. G2 Evo, Countryman, Moles and Lowels.
Perrone Ford is offline   Reply With Quote
Old December 20th, 2009, 04:45 PM   #23
Inner Circle
 
Join Date: Jan 2006
Posts: 2,290
Quote:
Originally Posted by Perrone Ford View Post
You are definitely doing something wrong... The Second pass should show no white dots in the output screen. So when you click "OK" on pass 2, it should take you back to the filters menu. Does it say (pass 2) at the end of the line for the deshaker filter?
It take me a small dialog box showing input, output, and filter. the boxes are both checked.
1280x720 (rgb32) (?) (24fps) Deshaker v2.4 (pass 1)
1280x730 (rgb32) (?) (24fps) Deshaker v2.4 (pass 2)

Yes, the second one shows 730, not 720,

I click OK and the dialog box disappears. Then I click the <0 and it plays out and the resulting file is a snow storm of motion dots. Red dots too.

SAVE AS results in another snow storm.
Brian Luce is offline   Reply With Quote
Old December 20th, 2009, 05:29 PM   #24
Inner Circle
 
Join Date: Nov 2006
Location: Tallahassee, FL
Posts: 4,100
Quote:
Originally Posted by Brian Luce View Post
It take me a small dialog box showing input, output, and filter. the boxes are both checked.
1280x720 (rgb32) (?) (24fps) Deshaker v2.4 (pass 1)
1280x730 (rgb32) (?) (24fps) Deshaker v2.4 (pass 2)

Yes, the second one shows 730, not 720,

I click OK and the dialog box disappears. Then I click the <0 and it plays out and the resulting file is a snow storm of motion dots. Red dots too.

SAVE AS results in another snow storm.
You're KILLING me smalls!

Wait a second. You have TWO filters there in that dialog box?? There should only be one.
__________________
DVX100, PMW-EX1, Canon 550D, FigRig, Dell Octocore, Avid MC4/5, MB Looks, RedCineX, Matrox MX02 mini, GTech RAID, Edirol R-4, Senn. G2 Evo, Countryman, Moles and Lowels.
Perrone Ford is offline   Reply With Quote
Old December 20th, 2009, 07:30 PM   #25
Inner Circle
 
Join Date: Jan 2006
Posts: 2,290
It shows the first pass and second pass.

I even tried reinstalling vdub. It does make a nice snowstorm, easier than using AE.
Brian Luce is offline   Reply With Quote
Old December 20th, 2009, 08:15 PM   #26
Inner Circle
 
Join Date: Nov 2006
Location: Tallahassee, FL
Posts: 4,100
Put up a screen shot of the filter settings, and the little dialog when get when you click OK on the filter settings.
__________________
DVX100, PMW-EX1, Canon 550D, FigRig, Dell Octocore, Avid MC4/5, MB Looks, RedCineX, Matrox MX02 mini, GTech RAID, Edirol R-4, Senn. G2 Evo, Countryman, Moles and Lowels.
Perrone Ford is offline   Reply With Quote
Old December 21st, 2009, 01:21 AM   #27
Inner Circle
 
Join Date: Jan 2006
Posts: 2,290
Here's some grabs, hope the text isn't too small. Getting really good at the snow storm effect.
Attached Thumbnails
A short stabilization demo-dvinfo1.jpg   A short stabilization demo-dvinfo2.jpg  

A short stabilization demo-dvinfo3.jpg   A short stabilization demo-dvinfo4.jpg  

A short stabilization demo-dvinfo5.jpg   A short stabilization demo-dvinfo6.jpg  

A short stabilization demo-dvinfo7.jpg  
Brian Luce is offline   Reply With Quote
Old December 21st, 2009, 07:50 AM   #28
Inner Circle
 
Join Date: Nov 2006
Location: Tallahassee, FL
Posts: 4,100
You have two copies of the filter running. Delete one of them and your problems will go away.
__________________
DVX100, PMW-EX1, Canon 550D, FigRig, Dell Octocore, Avid MC4/5, MB Looks, RedCineX, Matrox MX02 mini, GTech RAID, Edirol R-4, Senn. G2 Evo, Countryman, Moles and Lowels.
Perrone Ford is offline   Reply With Quote
Old December 21st, 2009, 11:48 AM   #29
Inner Circle
 
Join Date: Jan 2006
Posts: 2,290
Quote:
Originally Posted by Perrone Ford View Post
You have two copies of the filter running. Delete one of them and your problems will go away.
In a couple of the grabs, yes, I had two windows of Vdub open, but I've tried it every which way, and cannot get it to work. I deleted the zip folder DeShaker came in, didn't change anything either, snowstorm on the West Coast.

Question: it's the >0 button that applies the deshaker filter? And you literally make two runs on the file, pass one and pass two? Then save as. Why isn't this working!
Brian Luce is offline   Reply With Quote
Old December 21st, 2009, 12:01 PM   #30
Inner Circle
 
Join Date: Nov 2006
Location: Tallahassee, FL
Posts: 4,100
Brian, listen to me....

Open VDub
Open your unstabilized video
Add a SINGLE COPY OF THE DESHAKER FILTER (you have two of them loaded)
Enter your setting for both pass 1 and pass two IN THE SINGLE COPY of the filter
Click the big pass 1 button at the top, and do the >0
Rewind the video
Open the filter and click on the pass 2 button. Click ok
Click the >0 again

Save the new AVI....

You are not seeing the results you want because you have two separate copies of the filter loaded and the top one is always doing Pass 1.
__________________
DVX100, PMW-EX1, Canon 550D, FigRig, Dell Octocore, Avid MC4/5, MB Looks, RedCineX, Matrox MX02 mini, GTech RAID, Edirol R-4, Senn. G2 Evo, Countryman, Moles and Lowels.
Perrone Ford is offline   Reply
Reply

DV Info Net refers all where-to-buy and where-to-rent questions exclusively to these trusted full line dealers and rental houses...

Professional Video
(800) 833-4801
Portland, OR

B&H Photo Video
(866) 521-7381
New York, NY

Z.G.C.
(973) 335-4460
Mountain Lakes, NJ

Abel Cine Tech
(888) 700-4416
N.Y. NY & L.A. CA

Precision Camera
(800) 677-1023
Austin, TX

DV Info Net also encourages you to support local businesses and buy from an authorized dealer in your neighborhood.
  You are here: DV Info Net > Cross-Platform Post Production Solutions > Digital Compositing and Effects

Thread Tools Search this Thread
Search this Thread:

Advanced Search

 



Google
 

All times are GMT -6. The time now is 08:26 AM.


DV Info Net -- Real Names, Real People, Real Info!
1998-2017 The Digital Video Information Network