What happens when the battery dies while the power is on? at DVinfo.net

Go Back   DV Info Net > JVC ProHD & MPEG2 Camera Systems > JVC GY-HM 600/700/800 Series Camera Systems

JVC GY-HM 600/700/800 Series Camera Systems
GY-HM6xx, HM7xx and HM8xx ProHD camcorders & decks.


Reply
 
Thread Tools Search this Thread
Old June 19th, 2009, 03:59 PM   #1
Major Player
 
Join Date: Feb 2009
Location: Red Deer, Alberta
Posts: 215
What happens when the battery dies while the power is on?

I was on a shoot today with the HM700 and the battery level on the side of the battery said there was 30 min left. A few seconds later my camera shut off, my battery was dead. When it turned back on it said that my SDHC card needed to be reformatted. I decided that maybe, hopefully I didn't lose the last hour of shooting. I got back home and I could view 2 of the 3 movies. The third file says it is .mov but when I click on it it says it isn't a movie. Any one know if I can get the footage from this clip? Unfortunately it is more important then the other 2 clips that made it. When my battery died, I wasn't even recording, which makes me wonder why what happened..happened. Can anyone shine a light on this situation. Thanks
__________________
Calvin Bellows
www.exposureproductions.ca

Last edited by Calvin Bellows; June 19th, 2009 at 09:01 PM.
Calvin Bellows is offline   Reply With Quote
Old June 19th, 2009, 05:55 PM   #2
Major Player
 
Join Date: Dec 2006
Location: New York, NY
Posts: 460
[edited for relevancy - thank you Sean for your quick response - Tim]

Try to "restore" the card in the camera. This can recover media.
__________________
Sean Adair - NYC - www.adairproductions.com
JVC GY-HM-700 with 17x5 lens, MacPro 3.2ghz 8-core, 18gb. (JVC HD200 4 sale soon)
Sean Adair is offline   Reply With Quote
Old June 19th, 2009, 09:02 PM   #3
Major Player
 
Join Date: Feb 2009
Location: Red Deer, Alberta
Posts: 215
Thanks for the idea about restoring in camera. I didn't know that it wouldn't delete everything. I hope it works
__________________
Calvin Bellows
www.exposureproductions.ca
Calvin Bellows is offline   Reply With Quote
Old June 19th, 2009, 10:30 PM   #4
Wrangler
 
Join Date: Aug 2005
Location: Toronto, ON, Canada
Posts: 3,637
From what I can tell the camera records to a cache file first and then wraps the data after you stop the recording and writes the meta files. I've forced disconnects and ejected the card while recording just to see what happens and you end up with an unreadable file.

However... when you put the card back in the camera (or turn it back on) it will tell you that you need to restore the card (not format it!!!!)
The camera simply checks the metadata against the cache and then simply finishes with the wrapping, cleans up the cache and you are all good to go.

It's almost fail-safe (knock on wood! ;)

Since you weren't recording when the battery failed it should be very easy for the camera to restore the file.
__________________
Tim Dashwood
Tim Dashwood is offline   Reply With Quote
Old June 19th, 2009, 10:33 PM   #5
Major Player
 
Join Date: May 2007
Location: NYC
Posts: 203
Is that only true for the HM700 or for the HM100 too?
Matthias Krause is offline   Reply With Quote
Old June 19th, 2009, 10:48 PM   #6
Wrangler
 
Join Date: Aug 2005
Location: Toronto, ON, Canada
Posts: 3,637
As far as I can tell they both work the same way (when set for MOV) but I haven't run the same test on MP4 recording. I'm wrapping up the HM100 tutorials over the next week and will be sure to test this out.
__________________
Tim Dashwood
Tim Dashwood is offline   Reply With Quote
Old June 22nd, 2009, 08:50 AM   #7
Regular Crew
 
Join Date: Jan 2006
Location: Toronto, CANADA
Posts: 65
HM100 ‘Damaged File’ Recovery Issues

Quote:
Originally Posted by Tim Dashwood View Post
From what I can tell the camera records to a cache file first and then wraps the data after you stop the recording and writes the meta files. I've forced disconnects and ejected the card while recording just to see what happens and you end up with an unreadable file.

However... when you put the card back in the camera (or turn it back on) it will tell you that you need to restore the card (not format it!!!!)
The camera simply checks the metadata against the cache and then simply finishes with the wrapping, cleans up the cache and you are all good to go.

It's almost fail-safe (knock on wood! ;)

Since you weren't recording when the battery failed it should be very easy for the camera to restore the file.
Tim (and others),

I just returned from 4 weeks of filming in Africa with my new HM100 (the ‘first’ one actually sold in Canada courtesy of Peter @ HVS, I believe). Overall, the camera performed wonderfully, but while capturing 90+ hours of footage, I was surprised at how often I encountered the need for file restore/recovery while using the camera during normal operations (i.e. Not while changing over batteries or during an unexpected loss of power or switching cards during a long stretch of continuous filming, etc.).

During typical short bursts of filming (without the “continuous clip” feature engaged since that seemed to almost always require some kind of recovery operation) the warning message “file damaged… run data recovery… OK” must have appeared about 50 times when I powered the camera back on and tried to start recording again. When it did, I would press OK each time and it appeared to successfully recover all the files properly and allow them to be readable as I reviewed them on my MacBook Pro at the end of the day before copying them to external HDs. But perhaps I forgot to ‘knock on wood’ near the end of my trip.

During the last few days of filming, apparently the file recovery program didn’t work properly on several occasions. And I don’t recall taking the time to check/view every file on that SD card before backing them up to my HD’s and then erasing those files from the card. When I arrived home, I tried to view those files but they wouldn’t open and were unrecognized as .mov files despite being there on my HD amidst other files from the same card that worked just fine.

I am hoping/dreaming that JVC or someone might know of a way to repair and recover these files after they have been removed from the camera and the SD card. Last week, Peter and Mike @ HVS and I tried recopying the files back onto a blank SD card and seeing if the HM100 could still repair them but it didn’t work. Your explanation of how the camera records to a cache first makes sense and but I imagine that the cache is overwritten at some point once you’ve continued filming and capturing footage on other SD cards (note: I rotated through 15 Transcend cards during my trip and although I deleted the files from that SD card, I have NOT yet recorded anything over them yet). Is that how the cache system works?

Any insight or ideas on how I might still recover these damaged or incomplete files?

Thanks,

Michael
Michael Lafleur is offline   Reply With Quote
Old June 23rd, 2009, 10:48 AM   #8
Regular Crew
 
Join Date: Apr 2009
Location: London, UK.
Posts: 53
Michael,

Is there any chance this could be due to heat, humidity or dust etc? Maybe direct sunlight for a while or high humidity or constant rattling when driving over bad roads?

Could you describe your filming, traveling and storage conditions?

(About to drive overland across Africa with a HM100 for a year or so.... ;)
John McDonald is offline   Reply With Quote
Old June 23rd, 2009, 09:51 PM   #9
Regular Crew
 
Join Date: Jan 2006
Location: Toronto, CANADA
Posts: 65
Quote:
Originally Posted by John McDonald View Post
Michael,

Is there any chance this could be due to heat, humidity or dust etc? Maybe direct sunlight for a while or high humidity or constant rattling when driving over bad roads?

Could you describe your filming, traveling and storage conditions?

(About to drive overland across Africa with a HM100 for a year or so.... ;)
John,

Thanks for the suggestions but all of those possibilities are highly unlikely since within the same SDHC card, some .mov files turned out fine and others are inexplicably unreadable. Furthermore, the same thing happened randomly on 3 different cards, with some files readable and just fine while others seem to have not repaired themselves before I removed the card from the camera. I can only assume that the data recovery utility built in to the camera didn’t work for some reason.

I was able to continue recording successfully with other cards, including re-recording over one that contained an unreadable/unrepaired file. So I am quite sure the problem was not with the Transcend cards but some kind of an anomaly within the camera’s cache and data recovering process.

Your Africa trip sounds very exciting and I found the HM100 perfectly suited for capturing great images in a wide variety of settings. Other than that weird recording glitch, I shot 90+ hours of fantastic footage, mostly in run and gun style and often using full auto to allow me to follow subjects from indoors to outdoors, inside vehicles and huts, sunrises and sunsets, etc. without having to worry about resetting WB or fumbling with the inconveniently placed iris control. The image stabilization was quite impressive while roaring down the Shire river and driving on extremely rough roads. It also did a fantastic job in low-light (IMO compared to my HD-100) and while you have to keep an eye on autofocus, it generally did quite well pulling solid focus on its own. It did falter, however, when there was strong backlight behind the subject so I usually kept focus assist on to let me know when I needed to engage manual mode.

I’m still unsure if I can still recover erased files from SD cards that have NOT been recorded over yet. Can anyone share their experiences and/or suggestions for this?

Thanks,

Michael
Michael Lafleur is offline   Reply With Quote
Old June 24th, 2009, 12:45 PM   #10
Major Player
 
Join Date: Feb 2009
Location: Red Deer, Alberta
Posts: 215
Restoring works

Thanks to everyones help I restored the card and the files that wouldn't read before. I wasn't sure if restoring and reformatting did the same thing. When can we see all of this amazing Africa footage?
__________________
Calvin Bellows
www.exposureproductions.ca
Calvin Bellows is offline   Reply With Quote
Old June 25th, 2009, 03:57 PM   #11
Major Player
 
Join Date: Sep 2007
Location: Bellingham, WA
Posts: 457
Michael, what cards did you use on your trip?
Robert Rogoz is offline   Reply With Quote
Old June 25th, 2009, 06:05 PM   #12
Regular Crew
 
Join Date: Jan 2006
Location: Toronto, CANADA
Posts: 65
Quote:
Originally Posted by Robert Rogoz View Post
Michael, what cards did you use on your trip?
Hi Robert,

I used the ones that Tim Dashwood and JVC have been recommending - the 16 GB Transcend Class 6 cards. I took 16 of them with me and one became unusable (my fault - water damage) and rotated through the remaining 15 every couple of days.

Any ideas on recovering erased files that then could possibly be restored and repair with the on camera software utility? Again, I have not used them or recorded over them yet, just erased the files from the cards and emptied the trash on my MacBook Pro.
Michael Lafleur is offline   Reply With Quote
Old June 25th, 2009, 09:35 PM   #13
Trustee
 
Join Date: Jun 2006
Location: Burbank
Posts: 1,811
Quote:
Originally Posted by Michael Lafleur View Post
Hi Robert,

Any ideas on recovering erased files that then could possibly be restored and repair with the on camera software utility?
There are file recovery programs for SDHC cards, so I wouldn't give it hope. Here is one such program, but it is for photos:
http://www.cardrecovery.com/sd-recov...coverylist.asp

I see no reason the files can't be recovered if they are there. Transcend may have an answer, as card companies sometimes have recovery programs for there cards.

Once recovered, the files may or may not be readable immediately. I have been able to recover DNG files from SDHC cards, but some were readable and some were corrupted, and I never found a way to repair the corrupted ones.

A trick to recover jpg files is to quick format the card, then use a recover program. Something like this should work for the HM100 files on the SDHC cards.

My point is that there should be a solution out, but the camera is too new for the solution to be tested and/or widely known.
Jack Walker is offline   Reply With Quote
Old June 26th, 2009, 10:07 AM   #14
Major Player
 
Join Date: Sep 2007
Location: Bellingham, WA
Posts: 457
Michale, I would contact Transcend. From my dealings in the past JVC is on a very low end of customer service, even though it looks like an issue on their end.
BTW please keep us posted on the progress. Maybe when the solution is present it should become "sticky" on this bb.
Robert Rogoz is offline   Reply With Quote
Old July 13th, 2009, 01:40 PM   #15
Major Player
 
Join Date: Sep 2007
Location: Bellingham, WA
Posts: 457
Quote:
Originally Posted by Michael Lafleur View Post
Tim (and others),

I just returned from 4 weeks of filming in Africa with my new HM100 (the ‘first’ one actually sold in Canada courtesy of Peter @ HVS, I believe). Overall, the camera performed wonderfully, but while capturing 90+ hours of footage, I was surprised at how often I encountered the need for file restore/recovery while using the camera during normal operations (i.e. Not while changing over batteries or during an unexpected loss of power or switching cards during a long stretch of continuous filming, etc.).

During typical short bursts of filming (without the “continuous clip” feature engaged since that seemed to almost always require some kind of recovery operation) the warning message “file damaged… run data recovery… OK” must have appeared about 50 times when I powered the camera back on and tried to start recording again. When it did, I would press OK each time and it appeared to successfully recover all the files properly and allow them to be readable as I reviewed them on my MacBook Pro at the end of the day before copying them to external HDs. But perhaps I forgot to ‘knock on wood’ near the end of my trip.

During the last few days of filming, apparently the file recovery program didn’t work properly on several occasions. And I don’t recall taking the time to check/view every file on that SD card before backing them up to my HD’s and then erasing those files from the card. When I arrived home, I tried to view those files but they wouldn’t open and were unrecognized as .mov files despite being there on my HD amidst other files from the same card that worked just fine.

I am hoping/dreaming that JVC or someone might know of a way to repair and recover these files after they have been removed from the camera and the SD card. Last week, Peter and Mike @ HVS and I tried recopying the files back onto a blank SD card and seeing if the HM100 could still repair them but it didn’t work. Your explanation of how the camera records to a cache first makes sense and but I imagine that the cache is overwritten at some point once you’ve continued filming and capturing footage on other SD cards (note: I rotated through 15 Transcend cards during my trip and although I deleted the files from that SD card, I have NOT yet recorded anything over them yet). Is that how the cache system works?

Any insight or ideas on how I might still recover these damaged or incomplete files?

Thanks,

Michael
Here is a quote from a different link about MxR cards: "I was just going to mention that. When I first got my cards, I said "Lets run some tests since it's the new cards that are failing" (so I've read here). I inserted cards (Both Hoodman and Transcends), formatted, and then hit "record", then stop, then hit record right away to lay down some clips. Lo and behold, the dreaded "Media needs restoring"! Crap I thought I have bad cards! Wrong! I was not giving them time enough to finish writing after I hit stop. They seem to take a little longer than my SONY SxS cards on the tail end to finish writting. You have to ALWAYS make sure the red light is green before recording again. In the field, it usually takes the 4 or 5 seconds to reframe and record more, but when doing these "card tests", I bet some are doing the same thing I did. (Or maybe it's just impatient me!)

I almost returned 4 cards before realizing what was happening!

Since I figured this out, they have ALL performed flawlessly."

Here is the link: http://www.dvinfo.net/conf/sony-xdca...c-cards-7.html
I think it might be the same issue, not giving enough time to write data to the card between stop and start recording. If it is JVC will have to get the ball rolling with firmware update, so this issue can be resolved. MxR adapters are a backdoor solution, however the SDHC is the only media this camera can record and the potential to loose a shot is simply too great.
Looks like in this case the time between stop recording and powering down the cam was too short.
Robert Rogoz is offline   Reply
Reply

DV Info Net refers all where-to-buy and where-to-rent questions exclusively to these trusted full line dealers and rental houses...

Professional Video
(800) 833-4801
Portland, OR

B&H Photo Video
(866) 521-7381
New York, NY

Z.G.C.
(973) 335-4460
Mountain Lakes, NJ

Abel Cine Tech
(888) 700-4416
N.Y. NY & L.A. CA

Precision Camera
(800) 677-1023
Austin, TX

DV Info Net also encourages you to support local businesses and buy from an authorized dealer in your neighborhood.
  You are here: DV Info Net > JVC ProHD & MPEG2 Camera Systems > JVC GY-HM 600/700/800 Series Camera Systems

Thread Tools Search this Thread
Search this Thread:

Advanced Search

 



Google
 

All times are GMT -6. The time now is 02:58 AM.


DV Info Net -- Real Names, Real People, Real Info!
1998-2017 The Digital Video Information Network