Clip Browser Crashing at DVinfo.net

Go Back   DV Info Net > Sony XAVC / XDCAM / NXCAM / AVCHD / HDV / DV Camera Systems > Sony XDCAM EX Pro Handhelds

Sony XDCAM EX Pro Handhelds
Sony PMW-300, PXW-X200, PXW-X180 (back to EX3 & EX1) recording to SxS flash memory.


Reply
 
Thread Tools Search this Thread
Old January 19th, 2010, 01:29 PM   #1
New Boot
 
Join Date: Apr 2009
Location: San Diego, CA
Posts: 15
Clip Browser Crashing

Hopefully this is the right forum. Whenever I have a SD card mounted on my mac, Clip Browser crashes on launch. I've tried trashing preferences, repairing permissions, and reinstalling the program. If I copy the card to a hard drive (and unmount the SD card) Clip Browser works perfectly and I can access the files just fine. Any ideas?

A little more information...

MacOS 10.6.2
Clip Browser 2.06.00 (155.188)

Part of the crash log...

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Application Specific Information:
*** Terminating app due to uncaught exception 'NSRangeException', reason: '*** -[NSCFString substringToIndex:]: Range or index out of bounds'
Sean Popke is offline   Reply With Quote
Old January 23rd, 2010, 12:13 AM   #2
New Boot
 
Join Date: Apr 2009
Location: San Diego, CA
Posts: 15
Anyone else having this problem?
Sean Popke is offline   Reply With Quote
Old January 23rd, 2010, 04:09 AM   #3
Trustee
 
Join Date: Sep 2004
Location: Chislehurst, London
Posts: 1,724
It doesn't seem like anyone else has this problem, it could be a USB problem in your OS. Have you tried an external card reader?
__________________
Eyes are a deaf manís ears. Ears are a blind manís eyes
Vincent Oliver is offline   Reply With Quote
Old January 23rd, 2010, 09:17 AM   #4
Sponsor: Westside AV
 
Join Date: Dec 2008
Location: Mount Washington Valley, NH, USA
Posts: 1,365
How are you mounting the cards?

I have no problems with using my Express34 slot with the M+R adapter.

I have had problems with some Express 34 CF readers, they will crash the Mac.

I have not had any problems so far with USB card readers.

I too am on 10.6.2.

Sometimes you have to just go with what works. So many drivers from so many different sources.
Olof Ekbergh is offline   Reply With Quote
Old January 23rd, 2010, 09:44 AM   #5
New Boot
 
Join Date: Apr 2009
Location: San Diego, CA
Posts: 15
It looks like Clip Browser doesn't like my SanDisk card reader. If there's a card mounted through it, then Clip Browser instantly crashes on startup. It used to work just fine, so I'm going to revert to an older version of Clip Browser and see if that makes a difference.

I tried a eFilm reader and it worked just fine, so I'm not sure if it's a problem with the card reader or a bug in the program. I tried the SanDisk reader on a different computer and Clip Browser also crashed, so it's not just that one computer.

What SD card readers are people using?
Sean Popke is offline   Reply With Quote
Old January 23rd, 2010, 11:30 AM   #6
Trustee
 
Join Date: Sep 2004
Location: Chislehurst, London
Posts: 1,724
Have you tried launching ClipBrowser first and then putting in a card, or are you launching CB with a card ready to go?

I have a cheap card reader which was purchased for £14 from Jessops. I do have some older readers but these do not read SDHC cards. You should ensure that your reader will read SDHC, otherwise it won't work.
__________________
Eyes are a deaf manís ears. Ears are a blind manís eyes
Vincent Oliver is offline   Reply With Quote
Old January 24th, 2010, 12:18 PM   #7
Inner Circle
 
Join Date: Feb 2004
Location: Brooklyn, NY, USA
Posts: 3,778
Same thing is happening to me
Version 2.06.00 (155.188)
MacPro Early 2008 OS 10.6.2
ClipBrowser crashes when I have my Sandisk card reader attached to any USB port. Remove the reader and ClipBrowser opens without issue.
Craig Seeman is offline   Reply With Quote
Old January 24th, 2010, 12:30 PM   #8
Inner Circle
 
Join Date: Feb 2004
Location: Brooklyn, NY, USA
Posts: 3,778
Under a new user it still crashes so it is System related.
Given Sandisk reader has no installed drivers my guess is ClipBrowser in conflicting with some Apple OS USB related component.
The Sandisk reader by itself doesn't cause the crash. A card must be installed.
That would mean it has to do with something about how ClipBrowser is scanning "active" devices.
Craig Seeman is offline   Reply With Quote
Old January 24th, 2010, 12:43 PM   #9
Inner Circle
 
Join Date: Feb 2004
Location: Brooklyn, NY, USA
Posts: 3,778
It's specific to the model of the reader!
My old
Sandisk ImageMate 12 in 1 Reader
Model Number SDDR-89 V4
Works fine. NO CRASH!
Amazon.com: SanDisk ImageMate 12-in-1 USB 2.0 Flash Memory Card Reader SDDR-89-A15: Electronics

My new Sandisk ImageMate All-in-One
Model Number SDDR-189-A20
Causes the crash when media is installed.
CompactFlashģ Card Reader - Transfer Data Fast and Easy | SanDisk

How very strange given that there are no drivers installed with the device. Apparently something in hardware about the new reader interacts with USB port and ClipBrowser that causes the crash.

Last edited by Craig Seeman; January 24th, 2010 at 01:46 PM.
Craig Seeman is offline   Reply With Quote
Old January 24th, 2010, 01:03 PM   #10
Inner Circle
 
Join Date: Feb 2004
Location: Brooklyn, NY, USA
Posts: 3,778
Sean do post the model number of the Sandisk reader you're having the issue with or confirm that it looks the same as my newer reader (vs the older reader).

The only thing I can think of is that Sandisk did something to an i/o type controller in the newer reader that's causing the issue.

I'm sure I've used this reader before but I think it may have been with the previous version of ClipBrowser otherwise something in a recent Apple software update is involved or at least part of the riddle.
Craig Seeman is offline   Reply With Quote
Old January 24th, 2010, 09:20 PM   #11
New Boot
 
Join Date: Apr 2009
Location: San Diego, CA
Posts: 15
My reader is the SDDR-199-A20. ( SanDisk | ImageMate Multi-Card USB 2.0 | SDDR-199-A20 | B&H ) Both card readers probably share the same controller hardware, which is probably why they both crash the software. I have a feeling it's a bug in the clip browser software that's causing the crash. You're right that it worked fine in previous versions of clip browser.
Sean Popke is offline   Reply
Reply

DV Info Net refers all where-to-buy and where-to-rent questions exclusively to these trusted full line dealers and rental houses...

Professional Video
(800) 833-4801
Portland, OR

B&H Photo Video
(866) 521-7381
New York, NY

Z.G.C.
(973) 335-4460
Mountain Lakes, NJ

Abel Cine Tech
(888) 700-4416
N.Y. NY & L.A. CA

Precision Camera
(800) 677-1023
Austin, TX

DV Info Net also encourages you to support local businesses and buy from an authorized dealer in your neighborhood.
  You are here: DV Info Net > Sony XAVC / XDCAM / NXCAM / AVCHD / HDV / DV Camera Systems > Sony XDCAM EX Pro Handhelds

Thread Tools Search this Thread
Search this Thread:

Advanced Search

 



Google
 

All times are GMT -6. The time now is 09:49 PM.


DV Info Net -- Real Names, Real People, Real Info!
1998-2017 The Digital Video Information Network