LTE Advanced and streaming issues at DVinfo.net

Go Back   DV Info Net > Most Recent Additions... > Streaming A View

Streaming A View
Hardware, software, technique and workflow for live video streaming.


Reply
 
Thread Tools Search this Thread
Old April 29th, 2017, 06:46 PM   #1
Trustee
 
Join Date: Jan 2013
Location: San Diego, Califonia
Posts: 1,226
LTE Advanced and streaming issues

So we have this new LTE Advanced stuff, with CARRIER AGGREGATION, and I think it may be presenting a problem with MPEG-TS and Zixi streaming. I am having a very hard time getting a stable non glitching and momentary freezing when streaming with a 30Mbps (upload speed actual) Samsung S7 LTE Advanced 4G signal. It seems no matter how good my upload speed is, and in this case, my engineering department has a 100 foot Verizon tower foot 10 feet outside the door, we have glitchy MPEG-TS and Zixi streams. The problem did not go away even after a new dedicated 200Mbps internet line was installed, which is used only by our Teradek decoder.

When I switched the SIM card into my old 2013 Moto X, which has only regular or AWS LTE at one time, we get a usable 3Mbps stream, even using 1280x720 at 60p. The only difference I can see is that the newer phone is utilizing carrier aggregation. Since LTE Advanced is the next deployment of pretty much everything, could this become a greater issue to more people trying to live stream over LTE? Anyone know any research on this new LTE Advanced with streaming?

Paul
Paul Anderegg is offline   Reply With Quote
Old April 29th, 2017, 07:50 PM   #2
Inner Circle
 
Join Date: Jul 2009
Location: Perth, Western Australia
Posts: 8,133
Re: LTE Advanced and streaming issues

Hi Paul

I'm using Netgear's new Nighthawk M1 4G router which has 4 channel carrier aggregation with no issues at all as long as we don't use wifi between the encoder and router. The video is flaky with the device a room width away BUT only on the wifi connection ...connect the encoder to the router via cable and it's awesome! I can do a 5mbps stream on 4GX without even a hint of any issues but it didn't seem to want to stream out SD for me if I connected via wifi

I assume you guys are cable connecting with your set up?
Chris Harding is offline   Reply With Quote
Old April 29th, 2017, 08:11 PM   #3
Trustee
 
Join Date: Jan 2013
Location: San Diego, Califonia
Posts: 1,226
Re: LTE Advanced and streaming issues

The decoder is hard wired to the 200Mbps dedicated line. In the field we are HotSpotting using WiFi...basically holding the HotSpot device against the WiFi dongle will not even improve performance when hitting over 30Mbps upload connection. Carrier aggregation over WiFi is nowhere near what we are dealing with on cell towers. The main priority for the cell providers is throrouput, not jitter and such. Imagine trying to bond two separate WiFi routers, on different bands, built 5 years apart, and that would be LTE Advanced.

Another strange factoid...3.0Mbps streams seem to hold up better than 1.5Mbps streams for UDP...maybe it has something to do with more data being sprayed out contains more error corrective bits or something?

Paul
Paul Anderegg is offline   Reply With Quote
Old April 29th, 2017, 09:06 PM   #4
Inner Circle
 
Join Date: Jul 2009
Location: Perth, Western Australia
Posts: 8,133
Re: LTE Advanced and streaming issues

Hi Paul

On my router I can have the encoder and router less than 2' apart and it still is flaky on a connection as low at 1.5mbps but without moving either device and just changing the connection with a short ethernet cable I can jump to an HD 5mbps + and get absolutely perfect streaming .... No idea why but it seems these new devices don't run very well as a hotspot ...maybe that why they come with an ethernet socket???

I cannot explain it but like you my older hotspot which has to be wifi works fine even if the modem is sitting in another room. Sounds like the new technology has forsaken wifi but what I do know is it's not worth using even if the hotspot is physically touching the encoder ...so I cable connect now automatically!
Chris Harding is offline   Reply With Quote
Old April 29th, 2017, 09:57 PM   #5
Trustee
 
Join Date: Jan 2013
Location: San Diego, Califonia
Posts: 1,226
Re: LTE Advanced and streaming issues

Every "step" in an internet chain, can add additional hiccups. WiFi in general has baked in error correction overhead, where the signal checks itself and requests resends for lost packets. The more adjacent channel interference in the spectrum, the more resends are necessary to maintain the connection speed. The problem is, with LongGOP "fire and forget" one way data streams, if you loose a tiny bit of low bitrate LongGOP bits, those missing bits will do a little cascade of smear or freeze up the entire stream momentarily, because lost bit A was part of the compression math making up that area of the future frames for bits B C and D. Things like FEC 2020 (forward error correction) baked into newer forms of MPEG-TS streaming are meant to deal with these little missing bit issues, but carrier aggregation is almost like dumb bonding, where the two halves of a zipper merge but they are misaligned.

Paul
Paul Anderegg is offline   Reply With Quote
Old April 30th, 2017, 12:19 AM   #6
Inner Circle
 
Join Date: Feb 2009
Location: Brisbane, Australia
Posts: 2,158
Re: LTE Advanced and streaming issues

And the different carrier networks have differing lengths of network path for the data to travel through before being combined. Not good in a time sensitive data delivery scenario.

Andrew
Andrew Smith is offline   Reply With Quote
Old May 3rd, 2017, 11:50 PM   #7
Trustee
 
Join Date: Jan 2013
Location: San Diego, Califonia
Posts: 1,226
Re: LTE Advanced and streaming issues

So upon further testing, it would appear that this was a camera firmware issue and not an LTE Advanced issue.

The camera initially used for testing was a JVC HM650, in UDP MPEG-TS mode. New test was with a JVC HM850 in UDP MPEG-TS mode...BUT, the firmware on the 800 series enables SMPTE 2022 FEC error correction, so the stream looks fine. If I toggle that off on the 850, the picture degrades to 650 type problems. With SMPTE 2022, 720 at 60p 5Mbps is clear and stable on a 20Mbps upload speed LTE connection. :-D

JVC has a solution...throw your HM650 away and buy an HM660, same camera, but "now with SMPTE 2022". :-|

Paul
Paul Anderegg is offline   Reply
Reply

DV Info Net refers all where-to-buy and where-to-rent questions exclusively to these trusted full line dealers and rental houses...

Professional Video
(800) 833-4801
Portland, OR

B&H Photo Video
(866) 521-7381
New York, NY

Z.G.C.
(973) 335-4460
Mountain Lakes, NJ

Abel Cine Tech
(888) 700-4416
N.Y. NY & L.A. CA

Precision Camera
(800) 677-1023
Austin, TX

DV Info Net also encourages you to support local businesses and buy from an authorized dealer in your neighborhood.
  You are here: DV Info Net > Most Recent Additions... > Streaming A View

Thread Tools Search this Thread
Search this Thread:

Advanced Search

 



Google
 

All times are GMT -6. The time now is 12:51 PM.


DV Info Net -- Real Names, Real People, Real Info!
1998-2017 The Digital Video Information Network