DV Info Net

DV Info Net (http://www.dvinfo.net/forum/)
-   What Happens in Vegas... (http://www.dvinfo.net/forum/what-happens-vegas/)
-   -   Interlacing artifacts or whatever they're called (http://www.dvinfo.net/forum/what-happens-vegas/507091-interlacing-artifacts-whatever-theyre-called.html)

Jeff Harper April 19th, 2012 10:39 AM

Interlacing artifacts or whatever they're called
 
Using Vegas 11, latest version, I render my 1080i footage for bluray, looks amazing.

I render it to DVD, and the interlacing is horrible. Really bad. I tried rendering progressive and it's exactly the same. There is something wrong here.

On top of that, similar to my last project, I get a "Vegas Pro Has Stopped Working" thingy, but it appears to keep rendering.

The interlacing is SO bad I cannot imagine sending it out to a client, but it has to go soon.

I think the only thing I can do in the future is to convert the footage to progressive using Cineform, but what a nightmare that is. File sized are stupid big, and I don't really have time, I'm so behind. Besides, I shouldn't have to.

Jeff Harper April 19th, 2012 10:48 AM

Re: Interlacing artifacts or whatever they're called
 
The shutdown noticed didn't pop up on my tenth attempt at rendering, but the interlacing is the same. Whenever there is motion in the scene, it's there.

Jeff Harper April 19th, 2012 11:11 AM

Samples
 
1 Attachment(s)
Here are some screenshots taken while rendering. The photos do not show how bad it really is, but it gives an idea of what it looks like.

As I watch it play it's much worse than the photos show.

Jeff Harper April 19th, 2012 11:37 AM

Re: Interlacing artifacts or whatever they're called
 
1 Attachment(s)
Here's a good shot of the issue.

Ray Turcotte April 19th, 2012 12:23 PM

Re: Interlacing artifacts or whatever they're called
 
As a test you could try turning of gpu rendering under >preferences>video , restart vegas and render a small loop region. While I have not experienced your problem, I have found that Nvidea/GPU rendering can have strange results or "Vegas has stopped working" crashes. But the same project would render perfect with CPU rendering. If the test render is good then you can render out your project in full. If the test render is not good then something is odd with the project/render settings.

Jeff Harper April 19th, 2012 12:27 PM

Re: Interlacing artifacts or whatever they're called
 
Thanks Ray.

mpeg 2 for dvd doesn't utilize gpu rendering, I don't think anyway. I turned it off anyway for the last render, didn't help, it was exactly the same.

FWIW, the field order, upper, was set correctly to match the orignal footage properties.

Ray Turcotte April 19th, 2012 12:51 PM

Re: Interlacing artifacts or whatever they're called
 
Ok good to know

I'm guessing here but

Is the bit rate high enough for fast moving frames? Maybe the encoder is reducing quality to stay within the project bit rate settings

Jeff Harper April 19th, 2012 12:58 PM

Re: Interlacing artifacts or whatever they're called
 
It does happen to be set lower than default, but I've used this setting dozens of times with no issues. I originally had it set to default and it was pretty much bad then too, about the same.

I'm deinterlacing the footage using Cineform, and I'll have to swap out the files in the project.

Jeff Harper April 19th, 2012 01:47 PM

Re: Interlacing artifacts or whatever they're called
 
Ray, I changed the settings to the default bit rate, and set properties to best, and the issue is largely gone.

So you were correct, thank you.

I am so hating interlaced footage these days.

Gerald Webb April 19th, 2012 03:51 PM

Re: Interlacing artifacts or whatever they're called
 
Thats great you got it sorted Jeff.
For anyone in the future who needs a fast way around this....

You edit your interlaced project for Bluray output, you also want a fast way ( this is not the highest quality way, but it is fast ) DVD version of the same project.
Change project settings to
Field order= None
Deinterlace method= Interpolate Fields.
Save as a new name ie. xxxxxxx Wedding for nesting
Open a new project with your DVD template settings PAL or NTSC
Check the Adjust source media to better match render settings (to lose any letter or pillar boxing).
Drag in your saved .veg
done.

Vegas appears to have a horrible time resizing interlaced footage, and whats worse, sometimes it goes ok, and sometimes you get what Jeff had in the pic above.
The above method removes the interlacing in the larger project, before scaling.
The other alternative would be to render 50/60p, down convert, then re interlace.

Jeff Harper April 19th, 2012 04:47 PM

Re: Interlacing artifacts or whatever they're called
 
Thanks Gerald. I've read around the web that upper field order can be particularly problematic for Vegas, which is what I have.

Jeff Harper April 19th, 2012 07:25 PM

Re: Interlacing artifacts or whatever they're called
 
In the end I still had to cut out footage to shorten the project enough to make 3 hours fit on a dual layer disc. I found the lowest bit rate that still looked good. With interlaced footage I now understand you cannot lower the bit rate as much as you can with progressive footage.

Thanks for your help guys.

Gene Gajewski April 19th, 2012 11:01 PM

Re: Interlacing artifacts or whatever they're called
 
I recognized the problem the moment I saw the jpg. As the other poster mentioned, there is something queer with how Vegas resizes images. My guess would be that it only resizes deinterlaced images - meaning that interlaced material is resized by frames rather than fields which lead to strange looking 'teeth'. This would be something you have little control over - other than to select blended or interpolated deinterlacing, which is necessary even if you are outputting to interlaced form. One option that helps at time is to select the 'reduce interlace flicker' option for the media also.

For thes above reasons, I use the Virtualdub program for resizing material since it canl handle fields individually. It's a bit of a pain to do - and I wouldn't recommend anyone do it with anything other than a lossless codec such as Lagarith to avoid generational errors. I prefer to resize material before editing, because to do it after editing means you need to output the edited material, resize, and then output again in final form. However, if you need to generate final form material in different sizes, you must wait until editing is complete.

Solutions are out there, they're just not obvious or particularly simple.

Eric Olson April 19th, 2012 11:37 PM

Re: Interlacing artifacts or whatever they're called
 
Quote:

Originally Posted by Gene Gajewski (Post 1728432)
Solutions are out there, they're just not obvious or particularly simple.

While not obvious, all you need to to do is set deinterlacing mode to interpolate frames to properly resize interlaced HD video to interlaced SD video in Vegas. In particular, if you have the deinterlacing mode set to none in the preferences then Vegas makes a mess of the scaling as depicted in the screenshot above.

Gene Gajewski April 20th, 2012 01:59 AM

Re: Interlacing artifacts or whatever they're called
 
Yes of course, there's the interpolate. But it is *important* to point out that both 'blend' and 'interpolate' are compromises with consequences. There is no holy grail for converting interlaced footage to progressive. There are *definite* costs in terms of clarity with these methods, which is why if the internal method of Vegas is to resize by frame - you've made those compromises and have a right to be aware of them.

Of course, if you are pleased with the results, than there''s no reason not to stick with what works. If not, as I said...


All times are GMT -6. The time now is 07:11 AM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2018 The Digital Video Information Network