flipped .avi video jagged playback at DVinfo.net

Go Back   DV Info Net > Windows / PC Post Production Solutions > What Happens in Vegas...

What Happens in Vegas...
...stays in Vegas! This PC-based editing app is a safe bet with these tips.


Reply
 
Thread Tools Search this Thread
Old March 11th, 2006, 01:27 PM   #1
New Boot
 
Join Date: Sep 2005
Location: Hyderabad. India
Posts: 20
flipped .avi video jagged playback

i just captured footage from the camera shot with a 35mm adapter. so the image is upside down. i then rendered this (upside down) to a .avi. played it in wmplayer and watched the clip upside down,everything works fine. now i applied the different flip techniques like
1. change the rotation to 180 deg event pan/crop
or
2.event pan/crop right click and flip vertical/horizontal
or
3.adams flip plugin.
the problem is that after i render the clip(corrected/flipped) to a .avi, and play it in wmplayer, the playback is jaggy and stuttery. its neither interlace lines nor stair stepping. its like the video plays with a continuous left-right vibration. is there anything iam missing in the settings ?
btw, the footage is PAL.

thanks
krishna.
M. Krishna Babu is offline   Reply With Quote
Old March 11th, 2006, 02:08 PM   #2
New Boot
 
Join Date: Sep 2005
Location: Hyderabad. India
Posts: 20
well,
i heard vegas goofsup the field order and its a bug that has a workaround.
i found out that using deinterlace methods like blend or intepolate reduces the vibration i was refering to. the video is now flipped upright and plays back smoothly.

krishna.
M. Krishna Babu is offline   Reply With Quote
Old March 12th, 2006, 12:14 AM   #3
Hawaiian Shirt Mogul
 
Join Date: Nov 2001
Location: northern cailfornia
Posts: 1,261
try rendering out 20 sec test using BEST ..also you might right click on the video clips ( in TL) -properties and click force resample ...
Don Donatello is offline   Reply With Quote
Old March 12th, 2006, 11:58 PM   #4
Major Player
 
Join Date: Jun 2005
Location: Johannesburg, South Africa
Posts: 200
Hi,

Quote:
i heard vegas goofsup the field order and its a bug that has a workaround.
Just as a matter of interest where did you hear this from?

I also have issues with Vegas' field order that I am trying to get to the bottom of.

Regards,

Dale.
Dale Paterson is offline   Reply With Quote
Old March 13th, 2006, 12:06 AM   #5
 
Join Date: Jan 2004
Location: Stockton, UT
Posts: 5,648
I too, would like to know what credible source this came from.
Do a search here, or on any other forum for field order issues, and you won't find many, which leads me to believe this is just someone claiming to have some knowledge which doesn't really exist.
__________________
Douglas Spotted Eagle/Spot
Author, producer, composer
Certified Sony Vegas Trainer
http://www.vasst.com
Douglas Spotted Eagle is offline   Reply With Quote
Old March 13th, 2006, 05:43 AM   #6
Major Player
 
Join Date: Jun 2005
Location: Johannesburg, South Africa
Posts: 200
Thanks to DSE I have broadened my knowledge somewhat when it comes to interlacing and field order and at this point I would agree that Vegas is probably not to blame for field order issues.

HOWEVER, Douglas, I find it interesting to note that (Mr) Babu also had to change the 'Deinterlace method' from 'None' to something else to get rid of his problem (although he does not say whether it was PAL DV of HDV footage).

I'm prepared to take a bet that it was HDV! Any takers!

Regards,

Dale.
Dale Paterson is offline   Reply With Quote
Old March 13th, 2006, 08:37 AM   #7
 
Join Date: Jan 2004
Location: Stockton, UT
Posts: 5,648
1. If you shoot HDV and import it to Vegas, it is upper field first. Always.
2. Edit as HDV in Vegas, it still is upper field. Always.
3. If you are outputting to HDV, it stays upper field, always.
4. If you output to SD, the timeline is upper field, you should select the NTSC or PAL template for MPEG, set the quality of the render to BEST, and render from there. Vegas will correctly provide the algorithm to flip the field order from upper to lower in the render process. At no time should the timeline be anything but upper field.

Next, Mr. Babu is flipping the pan/crop tool, PLUS using Adam Woodworth's Pan/crop tool. It's quite possible, ne likely, he's hand pan/cropped a segment, in which case, it's VERY easy to invert fields. That's not a Vegas issue, that's a user-caused conflict.

Also be sure you ALWAYS have Quantize to Frames enabled, this will avoid cutting on a half frame, which could also be responsible for some flicker.
__________________
Douglas Spotted Eagle/Spot
Author, producer, composer
Certified Sony Vegas Trainer
http://www.vasst.com
Douglas Spotted Eagle is offline   Reply With Quote
Old March 13th, 2006, 02:17 PM   #8
New Boot
 
Join Date: Sep 2005
Location: Hyderabad. India
Posts: 20
guys,
thanks for all the replies. well,
Quote:
Just as a matter of interest where did you hear this from?
http://www.sonymediasoftware.com/for...ssageID=404042
i was searching the forums for a solution and saw this message.
i dont know whether its the filed order or some thing but my video seems to stutter in playback when rendered to a .avi file even if i apply either of the pan/crop vertical or horizontal flip.
Quote:
'Deinterlace method' from 'None' to something else to get rid of his problem
well, doing this has smoothened the playback but has made the video a bit softer.
dale: my footage is PAL DV. it was recorded on a single CCD sony TRV33.

The other interesting thing to note is that i used premier pro1.5 and in the 'transform' effect flipped the clip vertical and rendered it to a PAL DV .avi file. belive me, the vibrating effect is still there but not as evident as in vegas.
i first blamed on the source footage, but whereever the problem is , it looks very good when the original upsidedown footage is rendered but why is this stutter when its flipped.

thanks
krishna
M. Krishna Babu is offline   Reply With Quote
Old March 13th, 2006, 02:55 PM   #9
 
Join Date: Jan 2004
Location: Stockton, UT
Posts: 5,648
Two separate issues. You're flipping, not reversing. Flip doesn't change the field order. Additionally, Sony has said the issue of field order is fixed in 6b and later, but this is related to making an event run backwards, not flipped.
Your video WILL stutter when you flip it, because Vegas is having to recompress the frames on the fly. this is why Adam Woodworth's "Flip" plugin is so valuable, as it uses less CPU horsepower than Vegas does for this particular function.
__________________
Douglas Spotted Eagle/Spot
Author, producer, composer
Certified Sony Vegas Trainer
http://www.vasst.com
Douglas Spotted Eagle is offline   Reply With Quote
Old March 13th, 2006, 11:12 PM   #10
Major Player
 
Join Date: Jun 2005
Location: Johannesburg, South Africa
Posts: 200
Good Morning Krishna and Douglas.

OK - I was wrong about the HDV - I lose (this round anyway).

BUT - I am going to be posting some test footage of mine later this morning to demonstrate that the 'Deinterlace method' in Vegas does more than just select the deinterlace method if and when selected by the user (unless this has also been fixed in 6.0b and onward - something I have not considered yet but will check this morning).

Sorry I can't help - but I will take some DV footage now and try flipping it and also reversing it and see if I have the same problem.

Douglas - from what I read - Krishna's problem is not when previewing in Vegas - it occurs after the file has been rendered to a PAL DV .avi file and played back out of Vegas i.e. in Windows Media Player.

Regards,

Dale.
Dale Paterson is offline   Reply With Quote
Old March 13th, 2006, 11:56 PM   #11
 
Join Date: Jan 2004
Location: Stockton, UT
Posts: 5,648
No one wins/loses. It's an exchange of information, so everyone wins.
Windows Media Player will virtually ALWAYS exhibit interlaced artifacts, because it's a progressive-only player. Computer monitors are progressive only, which is why I've kept harping in your other thread about "what are you viewing on?"

If you play interlaced media on a computer, at some point or another, you'll always notice some interlaced artifacting. There is no avoiding it, unless you do as Avid and a couple other NLE's in the PC world, eliminate a field during computer playback. That's not the best idea either. Then you're really only seeing 15 full, or 30 half frames per second.
__________________
Douglas Spotted Eagle/Spot
Author, producer, composer
Certified Sony Vegas Trainer
http://www.vasst.com
Douglas Spotted Eagle is offline   Reply With Quote
Old March 14th, 2006, 02:22 AM   #12
Major Player
 
Join Date: Jun 2005
Location: Johannesburg, South Africa
Posts: 200
Hey, lighten up - it was a joke!

Anyway - I have now done a lot of testing with vertically flipping a PAL DV clip using 'Track Motion'.

Firstly though - when I play a PAL DV clip, using Windows Media Player, on any one of my workstations, I do not, and never get, flicker or anything else like that - video is clear and motion is smooth - so I'm afraid that, although technically you are right Douglas, I disagree with you. Yes - I can and do see the interlace lines in Windows Media Player but there is no 'interlace flicker' i.e. visible interlace lines and the visible overall flickering of the footage when there is movement are two different things.

As far as Krishna's problem is concerned:

I get exactly the same results - and to me it certainly resembles the dreaded 'interlace flicker' that I am always on about.

The only way I could get smooth motion and no 'interlace flicker' with a vertically flipped PAL DV clip was either to set the 'Deinterlace method' to 'Blend fields' (or 'Interpolate fields') in the Project Properties OR to use the 'Reduce Interlace Flicker' switch.

Both methods, however, result in a definite 'softening' of the rendered output.

Setting the 'Deinterlace method' to 'Blend fields', totally reduces the 'interlace flicker' but softens the rendered output the most.

Using 'Reduce Interlace Flicker' does exactly what is says i.e. it 'reduces the interlace flicker' - it does not eliminate it totally. This method results in slightly 'sharper' rendered output than using the 'Deinterlace method' described above.

I suppose that logically, by flipping the clip vertically, you ARE actually reversing the field order anyway i.e. what was the last field in the original clip will now be the first field in the 'flipped clip' although I would have imagined that because this is an option in Vegas there would be a way of compensating for this.

The problem is definitely associated with the render process.

Why do I say this?

I tried playing back all of the different clips that I rendered using various render options and using various players and different DV codecs (as you know I have a collection) - same results - no exception - if you do not use 'Blend fields' or 'Interpolate fields' as your 'Deinterlace methos' OR use the 'Reduce Interlace Flicker' switch when rendering - no go!

Please note that I am only referring to the problem as 'interlace flicker' because it very closely resembles my 'interlace issues' and when playing in Windows Media Player - interlacing - as you quite rightly state Douglas - should not be an issue.

This could be quite a serious issue for those that are using additional lenses like Krishna.

I will now try reversing the same clip and see what happens (while I wait for comments).

Regards,

Dale.
Dale Paterson is offline   Reply With Quote
Old March 14th, 2006, 03:59 AM   #13
Major Player
 
Join Date: Jun 2005
Location: Johannesburg, South Africa
Posts: 200
OK - well - I have done some more testing.

I horizontally flipped a PAL DV clip and rendered to PAL DV - same thing - a definite 'shimmer' (let's call it that for now). It was not as bad though as the vertically flipped clip as in the tests above.

But this gets more interesting:

This only seems to happen when rendering your vertically or horizontally flipped PAL DV clip to PAL DV i.e. I tried rendering the same clip to an MPEG2 file as well as a Windows Media Video file using Vegas' default templates and the 'shimmer' is ALMOST imperceptible.

From the above it MAY have been possible to say that the workstation was having trouble playing back the PAL DV clip smoothly because of its size or bitrate but taking the original clip, making no changes in Vegas, and then rendering straight back to PAL DV again does not cause the same problem i.e. the original clip when re-rendered to PAL DV without the flipping plays perfectly.

Something important to state though - all of this only happens when there is motion in the clip i.e. no problem when no motion. I did try and bypass the motion blur envelope (although I had not applied one) to see if it would make a difference but nothing. I have not tried playing around with the different motion blur options but I can't see that this would be solving the problem - at best case this would be covering up the problem!

Any ideas? Anybody?

Regards,

Dale.
Dale Paterson is offline   Reply With Quote
Old March 14th, 2006, 04:06 AM   #14
Major Player
 
Join Date: Jun 2005
Location: Johannesburg, South Africa
Posts: 200
By the way - it also happens when reversing the clip!

I can't think of any more possible combinations to try so that's it from me for now.

Regards,

Dale.
Dale Paterson is offline   Reply With Quote
Old March 14th, 2006, 04:27 AM   #15
Major Player
 
Join Date: Jun 2005
Location: Johannesburg, South Africa
Posts: 200
OK - I could not help myself (I have a business to run would you believe but I love this stuff so much that I tend to get carried away with it)!!!

I just tried reversing the clip and rendering to PAL DV after selecting 'Blend fields' as the 'Deinterlace method' in the Project Properties and this was also fine i.e. no 'shimmer' but with the obvious 'unsharpening' of the rendered footage.

This has made me wonder about something:

Is is possible, I mean - just possible, that whenever you make a change to media on the timeline Vegas first attempts to 'deinterlace' the footage if it deems it necessary i.e. creates some sort of 'intermediate progressive temporary file' and then applies whatever changes you are trying to make to the 'intermediate progressive temporary file' and then that information is used to output your final media in the format that you have requested?

Is it possible?

I mean to say that this sure would explain why the setting of the 'Deinterlace method' becomes an issue even when you are not explicitly trying to deinterlace your footage and create progressive output.

I know that this thought of mine is a shot in the dark but it also, logically anyway, would explain away my 'interlace flicker' issues if this was indeed the method used.

Regards,

Dale.
Dale Paterson is offline   Reply
Reply

DV Info Net refers all where-to-buy and where-to-rent questions exclusively to these trusted full line dealers and rental houses...

Professional Video
(800) 833-4801
Portland, OR

B&H Photo Video
(866) 521-7381
New York, NY

Z.G.C.
(973) 335-4460
Mountain Lakes, NJ

Abel Cine Tech
(888) 700-4416
N.Y. NY & L.A. CA

Precision Camera
(800) 677-1023
Austin, TX

DV Info Net also encourages you to support local businesses and buy from an authorized dealer in your neighborhood.
  You are here: DV Info Net > Windows / PC Post Production Solutions > What Happens in Vegas...

Thread Tools Search this Thread
Search this Thread:

Advanced Search

 



Google
 

All times are GMT -6. The time now is 02:51 AM.


DV Info Net -- Real Names, Real People, Real Info!
1998-2017 The Digital Video Information Network