DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   Adobe Creative Suite (https://www.dvinfo.net/forum/adobe-creative-suite/)
-   -   Help Needed Improving my PP4 Benchmark Results (https://www.dvinfo.net/forum/adobe-creative-suite/467756-help-needed-improving-my-pp4-benchmark-results.html)

John Hewat November 14th, 2009 11:42 PM

Help Needed Improving my PP4 Benchmark Results
2 Attachment(s)
Hi all,

I ran Bill's PP4 Benchmark that Harm pointed out and got somewhat pleasing results as shown here: I am John's Computer.

MB: Supermicro X7DWA-N
Total: 71.3
AVI Export: 2.9
MPEG Encode: 36.4
Render Timeline: 32
CPU: Intel X5450 3GHz x2 (8 cores in total)
Memory: 8GB RAM
PPro Version: 4.2
OS: Win 7 64
System Drive: 74GB Raptor
Project Drive: 4x500GB RAID 0
Video: 9800GX2 + 7800GTX

Bill wrote back to me saying that they were good but indicated that my PC wasn't tweaked as well as it ought to be. In fact, I had tweaked it according to Black Viper's 'Tweaked' service configuration shown here, as well as changed a heap of settings as per Harm's advice on the Adobe forum (page file, display properties, defraging, etc...)

Now, I've done a fresh install, disabled every Windows component except for Internet Explorer and Media Player, and disabled so many services that there are usually only 26 processes running (using Black Viper's 'bare-bones' configuration on the same page above).

EDIT: In fact one/more of the services I've disabled has made nVidia control panel not see my 2nd graphics card. It's still active in Device Manager but I can't get anything to see that it's actually there.

I ran the test again but got terrible results this time.

My first few tests were consistently (or +/- .1 of a second):

Total 71.3
AVI 2.9
MPEG 36.4
Render 32

But now my AVI and MPEG results are strange and the rendering and total are screwy:

Total 508966.7
AVI 5.2
MPEG 38.5
Render 508923

I've attached a screenshot of Process Manager showing what's running as well as Device Manager showing all the services running. And also a still from the System Info window. I'm not sure if there's any useful information in them...

I'd love some advice on the matter. I love my rocketship computer but hate to think of it as wasting away and not living up to its potential (and price tag)...

Harm Millaard November 15th, 2009 12:55 PM


The BlackViper list is not tuned to Video Editing. First thing I would do is not 'disable' services, unless it is utterly clear you don't need them at all, but stop the services and turn them to manual. That precludes problems like with your video card, because manual services can be started if needed by your installed hardware/software.

Is your raid0 a software raid within Win7 or configured on the ICHR9 chip or other controller?

There are 3 notable results to compare with, both of Bill's systems, one the overclocked version, comparable to your 5450's, his standard score and Roger Averdahl's score which is comparable to your system. The problem in your results is mainly the rendering. If you can shave off around 10 seconds, your score is about equal to Bill's OC-ed system. Where is your media cache located, did you clean it beforehand, did you optimize your project disk before rendering, etc.

John Hewat November 15th, 2009 05:38 PM

Thanks Harm,

I'll go back and change the disabled services to manual and see if I get any sense out of my video card again. I suppose it's possible that other hardware could be less productive because of all the disabled services, which might explain the degraded performance across the board?? Have you published somewhere the Win7 services that you have running/disabled/manual?

My RAID 0 is configured onboard (through the motherboard?) - I have to load Intel ESB2 drivers. I'd been considering a good 4 port RAID controller, but when I got such good AVI results (the first tests anyway) I decided it wasn't really necessary. Though I'm sure it would be different if the test was for 35Mb 1920x1080 EX1 footage which constitutes most of my workload.

NOTE: I also use a Si3112 PCI-E --> 2xSATA adapter which connects to an E-SATA port and a front mounted hot swappable drive bay which I use to back up the important stuff from the RAID 0, essentially putting the R in RAID.

I keep all project files on the 2TB RAID drive. I have it all organised in a fairly predictable manner. I'll have to check the specific file structure and names but it's basically:

Mammoth (D:)
-- Richard III
----Captured Footage
------Captured Video
------Captured Audio
----Preview Files
------Video Previews
------Audio Previews
----Final Product
--Bill & Julie's Wedding
----Captured Footage
------Captured Video
------Captured Audio
----Preview Files
------Video Previews
------Audio Previews
----Final Product


This is all that's on the drive. But so far i have 1.5TB full.

Is this optimized? Bill's recent post on the Adobe forum says:


If you are using a single fast RAID array then my tests show that all the files (project, media, scratch) should be on the RAID array, putting any one on a slower separate drive slows the benchmark. I have all my project files on a 500 MB/s average read rate Array, if I put the Preview Files or the Output on even a ~200 MB/s RAID array you get slower performance.
I don't get read rates like that (I can add my HDTach scores when I get home from work) but never the less, even buying a RAID controller, it might still be best to have one big RAID for everything, rather than having captured media on a separate array to the previews and outputs?

What confuses me the most is that the drives were in exactly the same state for all tests, but they were consistently good, now they're sonsistently poor. I just don't get it.

Harm Millaard November 16th, 2009 03:36 AM

1 Attachment(s)

The list of the default services on my system is attached. For benchmarks of course I kill process trees for PerfectDisk, SnagIt, Skype, Symantec EndProtection and similar, so some services are stopped by killing the process tree, like PDAgent.

Both Bill and I are in favor of using Raid arrays, but we are not in favor of Aid0 (the missing R is because of the lack of redundancy), especially when you have important data on it and in your case it looks like very important data, your projects. Realize that if one disk in your raid0 fails, everything is lost, all 1.5 TB. If you use a raid0 for media and you lose all data, it can easily be recaptured, no big deal, but projects would be a disaster. So please make sure you make regular copies of your project files to another disk.

Bill uses a 5 disk SAS 15,000 RPM raid0 array for benchmarking, hence his 500 MB/s tranfer rates. I use a 12 disk SATA raid30 array all the time with 850+ MB/s transfer rates. In addition to that large array I also use a 2 disk raid0 array for pagefile, media cache, documentation of CS4 MC and the like, temp files, copies of DVD's, etc.

Like Bill I have noticed that when using both arrays in the benchmark my rendering score goes up from 13s to 21s, so 8s slower than using just my large array.

As to your raid0 question whether it is optimized, look at your HDTach results at around the 1,500 GB mark and I would expect you read rate is somewhere around 150-160 MB/s, but with less than 800 GB it would likely be around 200 MB/s. That is a significant difference.

For more info on my system, look here: http://www.dvinfo.net/forum/high-def...ter-build.html

John Hewat November 16th, 2009 08:01 AM

2 Attachment(s)
I've attached my HD Tach results after cleaning out the RAID 0 - it now has 1.5GB of 1.8 free.

The system drive has 46GB of 69 free.

Do the results indicate what you expected? I'm so technically obtuse that I struggle to understand them.

I've just re-run the benchmark test again and am still disappointed. I've cleared a TB of space from the RAID and slimmed down the system to only 26 processes running + applications... but I'm not getting as good results as before I did all that. Isn't that strange?

Harm Millaard November 16th, 2009 03:19 PM

1 Attachment(s)

The results from your Raptor are as expected. However your Raid0 is not what I would have expected. Have a look at my HDTach results for a simple 2 disk Raid0 array on a Marvell chip from the mobo. These are way different. How is your Raid0 set up? BIOS or Windows, what stripe size did you use?

John Hewat November 16th, 2009 05:03 PM

Hi Harm, thanks so much for your help - and your eternal patience!

Good questions...

It's set up in the BIOS, but that said, I can't remember doing it at all.

When I purchased the parts for this computer, I paid the company to build the machine. They set up the RAID in Windows, then even partitioned the RAID drive, they installed the RAM in the wrong slots and did a whole bunch of other stuff that I objected to.

So I pulled it to bits and re-built it.

But I don't remember the specifics of my RAID configuration...

I can however guarantee that I would have used default settings when given a choice.

There's nothing of value on the drive at the moment, I can easily format and reconfigure the RAID at recommended settings, if I can just recall how I did it. For some reason, I don't recall it being part of the regular BIOS, but a whole other pre-boot window, like Press X to configure SATA RAID or something...

I just read your guide on RAIDs, but I'm afraid my technical knowledge is so behind the 8 ball that I got lost somewhere in the clusters, blocks and chunks.

What stripe/cluster/block/chunk size do you recommend for 4 x 500GB HHDs for video editing (holding all my files, media, previews, renders, etc...)?

Cluster: 4KB?
Block (is this the same as stripe): 64KB?
Chunk: 128KB?

You mention 16 and 32 and 64KB chunk sizes but do they constitute large and small sizes? Or should I go even larger?

Harm Millaard November 16th, 2009 05:24 PM

Cluster size on a NTFS volume is 4KB by default. For block (stripe) size I would choose 128 KB if possible, chunk size may not be an option, depending on your controller, but if you have it, choose 64 KB or even larger.

John Hewat November 16th, 2009 05:58 PM

I'm looking at the Supermicro motherboard manual now and it says that when creating the RAID (in the SATA RAID Utility by pressing Ctrl+I after the power on self test) that the default Stripe size is 128KB. So it is a certainty that that is my Stripe size. The manual doesn't give any indication of an option to change the chunk size though.

Does that mean that my current RAID is as good as it's going to get?

Harm Millaard November 16th, 2009 06:03 PM


That is what it looks like to me.

John Hewat November 16th, 2009 06:37 PM

1 Attachment(s)
Well that makes me sad.

Is it possible that the onboard RAID is just not very good? And that a controller is a good idea? But if my AVI scores on the benchmark were as good as they were previously, I'd be content as it is!

I could always add a fifth drive I suppose.

When I right click on the RAID in Windows and select Format, I can choose the Allocation unit size. Anything from 512 bytes right up to 64KB.

I'm not sure what default is but the one that is already selected (presumably by default) is 4096 bytes. Should I change this?


Here's an interesting thing...

First of all, all of my subsequent results to my first few tries displayed what I thought was garbled results to TOTAL and RENDER times. But I've realised that they are not really garbled. They still contain the data, and it's much better data than I thought.

Strangely though, the finely tuned Windows 7 with 25 processes and correctly managed page file and display configured for performance is beaten by a completely untuned Vista with 50 processes and everything geared for appearance...

Harm Millaard November 17th, 2009 04:59 AM


Any chance that Intel has a more recent ESB2 driver, specially for Win7? For my Areca card it improved my results, as it did for Bill. Your driver is causing rather weird results with HDTach. You Raid0 has an average random access of 27 ms, which is pretty slow, considering you have 4 disks in the raid. On the 2 disk raid0 I have 15.9 ms. My average read is nearly 177 MB/s with 2 disks, I would have expected something like 330-350 MB/s on your raid. In addition your burst rate is way lower than mine, just comparable to SCSI Ultra 320.

Maybe you can find some information here: http://www.intel.com/support/chipset.../CS-022830.htm

On the left select download and there is a driver for Win7.

One more question, do you have AHCI enabled in the BIOS? If so, you may try with AHCI disabled.

John Hewat November 17th, 2009 06:30 AM

1 Attachment(s)
Thanks Harm,

I'll check the AHCI status when I get home tonight - though I think it's on and that off causes problems. I can't remember though, since I haven't fiddled with the settings since setting the RAID up over a year ago.

What are the advantages/implications of AHCI being on/off?

Also, thank you for pointing me to the new driver. I remember it taking me a week to track down the original ones I used when I first set it up - in fact I've no doubt you probably pointed me to it then too!!

It actually makes sense when I think about it, since that driver was for Vista, that the RAID should work better in Vista than in Win7. Though my HD Tach graph looks pretty similar when run in Vista too...

How about installing the drivers? Is it something I can do simply from within Windows by executing the file? Or am I better to update through device manager and find the files? Or is re-installing Windows and loading the new driver the best bet?

I'm happy to try anything!

EDIT: Installed the drivers and the storage manager software. But... the results didn't change. I'll try going into the BIOS to disable AHCI.

EDIT AGAIN: I think AHCI is already off! In the MAIN BIOS window, under Serial ATA, SATA Congtroller Mode Option is on "Enhanced (Non-AHCI) mode - Sata and Pata drives are auto-detected and placed in Native IDE mode" as opposed to the other option: "Compatible mode - Sata and Pata drives are auto detected and placed in Legacy mode"

Should I try changing it to Compatible mode???

FINAL EDIT FOR TONIGHT: When I press Ctrl+I in boot to enter RAID configuration, I note the top of the screen says "Intel Matrix Storage Manager option ROM v5.6.2 1002 ESB2 Copyright 2003-06."

But in Device Manager, the ESB2 driver says " Copyright 1994-2009.

So... does that mean that my installation in Windows of the ESB2 drivers isn't enough? That I do in fact have to load the new drivers before installing Windows??

ONE LAST THING: The Intel Matrix Storage Manager software tells me that my Strip size is definitely 128KB, and that my Physical Sector Size and Logical Sector Size are both 512 Bytes. Is that appropriate? I'm not sure how to change the values even if they ought to be...

Harm Millaard November 17th, 2009 07:08 AM

AHCI is used amongst other things to enable NCQ, but because you are using 500 GB disks, I make the assumption (maybe incorrectly) that these disks are somewhat older models, still with 16 MB cache and often it leads to better performance if NCQ is off. I have it off on my system as well. I also have Enhanced IDE for my SATA disks, like you.

I guess you can install these drivers under Win7, but to take effect you need to reboot the system. This may be explained on the Intel site, I forgot to look.

John Hewat November 17th, 2009 07:21 AM


but to take effect you need to reboot the system
As in reinstall Windows?

Or just reboot? I did reboot but no change seems to have occurred. Re-ran the HD Tach and PPBM tests and got same results.

The site has a ten thousand page read me that I tried to understand but it has so many ifs, buts and what have yous that I couldn't figure out which situation applied to me.

All times are GMT -6. The time now is 07:25 PM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2021 The Digital Video Information Network