View Full Version : GL2 "Auto Zooming" on it's own

Alex Maldonado
February 5th, 2007, 12:13 PM
ok, so here is the deal, my camera worked fine. i had a shoot, no problems. today i go to turn it on, and it is zoomed in all the way. as in, the bar that shows from W-----------T is all the way on "T". i am not pushing anything and can not zoom it back out. if i go into the menu and enable digital zoom to 40 it goes automatically to 40x zoom and stops and the same if i move it to 100. when i disable digital zoom it kicks back to a standard 20x zoom, but still all the way on "T" . so far my only solutions is to film everything from about 100 feet away. :) not practical. any suggestions or ways to do a hard reset on the camera.

Chris Barcellos
February 5th, 2007, 12:17 PM
Don't know GL2, but I had issue with a Sony Digital 8. My zoom rocker was stuck in full zoom position, and I would bet that something similar is happening witht he GL2. Also, with some cameras, you can select between "rocker" zoom, or "ring" zoom, but I assume you know your camera well enought to know that.

Alex Maldonado
February 5th, 2007, 12:45 PM
yeah it's very strange even when i am holding the zoom out side or the rocker down i get no response, i have tried the zoom on the rocker on the grip and the zoom on the handle as well.

Graham Bernard
February 5th, 2007, 03:17 PM
The CURSE of the Auto Zoom!!

I had. Lots of us have. Do a search here and you will see you are amongst many.

It has a mind of its own.

Alex Maldonado
February 5th, 2007, 03:21 PM
i did a few searches but was not able to find a fellow gl2 user with this issue. what is the fix? repair? a switch? what can i do? please help.

Graham Bernard
February 5th, 2007, 03:32 PM
Nothing here match your issue then?

Alex Maldonado
February 5th, 2007, 03:38 PM
thank you when i searched for zuto zoom i did not find what i needed, what term did you use and thank you for the help.

Graham Bernard
February 5th, 2007, 03:47 PM
eh . . zoom? Do any of the above help? Is this your issue?

James Holtzman
February 21st, 2007, 11:06 PM
I had the same problem. It got worse and worse. I tried to narrow it down, even took it to a shop which my insurance referred me to. They sat on the camera waiting for a service manual, I ran out of time, decided to look into the problem myself. I started looking for suspected defective parts, like shooting in the dark. Bottom line, defective zoom rocker switch, actually a potentiometer. There is a flex ribbon connector that connects the rocker to the camera. It had a microscopic crack on one of the traces. What happened was, as the crack grew, it was the same as holding the rocker down and the cam zoomed out all the way, when it wanted to. I found the problem by removing the part, checking with an ohmmeter, bingo. Flex ribbon connectors are almost impossible to repair, but once I discovered where the crack was, I used a "silver ink pin", the type for repairing printed circuit boards and was able to make a temporary repair, proving I found the problem. Once the problem was verified, I called Canon Parts, described the part, was given a price and a part number, ordered the part (about $14.00) had it shipped overnight, another $15.00, and problem fixed.

Without a service manual, it was a guess as to which screws to remove to take the camera apart, some trial and error.

Hope this helps - Jim