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Welcome and Thank You
Congratulations on selecting Convergent Design HD/SD Portable Recorder, nanoFlash.  nanoFlash is 
manufactured in the USA of foreign and domestic components, and shipped from the factory in the 
most secure packaging available.  Please inspect the contents of the package.  In the unlikely event 
that you find any shipping damage or missing components, please contact us.

Shipping Contents
Your nanoFlash shipping container should come packaged with the following:

1. nanoFlash recorder/player
2. Power Supply (100 to 240 VAC Input; 12V DC @ 1.25A Output)
3. USB Reader (for CompactFlash cards)

nanoFlash Overview
nanoFlash is a revolutionary solid-state HD/SD recorder/player that uniquely utilizes the very high-
quality Sony XDCAM 4:2:2 CODEC to write native Quicktime, MXF (video/audio/time-code), or MPG 
files onto affordable Compact Flash media.  nanoFlash breaks ground in terms of weight, power, size, 
ruggedness and ease of use.  We are confident you will agree that the video quality is 
indistinguishable from uncompressed (at 100+ Mbps Long-GOP or 180+ Mbps I-Frame modes). 

Product Support Contacts
Please read the user manual before contacting support.

1. Support E-Mail:  “cd” --  “support” -- “at” --  “convergent-design” -- “.com”
2. Sales E-Mail:      “cd” -- “sales”     -- “at” --  “convergent-design” -- “.com” 
3. Main Telephone: ++(720) 221-3861
4. Sales Telephone: ++ (719) 930-1376 
5. Web Site: http://www.convergent-design.com
6. Forum: http://www.dvinfo.net/forum/convergent-design-nanoflash/
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The Essentials (Quickstart), CompactFlash Cards

1. Please Register your nanoFlash by sending an e-mail to “cd”  “support”  “at”    “convergent-
design.com” with your name, serial number of unit, and where the nanoFlash was purchased. 
You will get automatic notice of firmware updates and service bulletins.  

2. Use only the qualified Compact Flash cards for the specified bit rates:
1. **Lexar 32/16/8 Gbyte 300x CF cards up to 220-280 Mbps (ver1.6.226)
2. Lexar 32/16/8 Gbyte 600x or 400x CF cards up to 280 Mbps (ver1.6.226)
3. **Transcend 400x 64/32/16 Gbyte CF cards up to 180-220 Mbps (ver1.5.249)
4. Transcend 600x 32/16 Gbyte CF cards up to 280 Mbps (ver1.6.29)
5. ***Delkin UDMA 420/450x 64/32/16 Gbyte CF cards to 180 Mbps (ver1.6.245)
6. ***Delkin UDMA 625x 32/16 Gbyte CF cards up to 280 Mbps (ver1.6.245)
7.  **Calumet ProSpec 64/32 Gbyte CF cards to 180-220 Mbps (ver1.6.226)
8.  Hoodman 675x 32/16 Gbyte CF cards up to 280 Mbps (ver1.6.226)
9.  Silicon Power 600x 32/16 Gbyte CF cards up to 280 Mbps (ver1.6.226)
10. SanDisk Extreme / Extreme Pro  64/32 Gbyte CF cards up to 280 Mbps
11. Axtremex 600x 128 Gbyte CF cards up to 220 Mbps (ver1.6.226)
12. Axtremex 600x Plus 64 Gbyte CF cards up to 280 Mbps (ver1.6.226)

**Card performance may vary from card to card. The bit rate will automatically be 
reduced during record for under-performing cards.  (ver1.5.31)
***Delkin cards require firmware version 1.6.245 or later.

3. Please keep your firmware up to date. (pg 20)  
4. ** Note:  This user manual is subject to change with each firmware update.  Please see the 

most up-to-date nanoFlash user manual at:
http://www.convergent-design.com/Portals/58/Documents/nanoFlash_Manual.pdf

5. Connect a power source to the 4-pin Hirose on the nanoFlash.
6. Set the time and date (page 11), set the video input (System->Vid Src) as SDI or HDMI
7. Set the file format to Quicktime (MAC) or MXF (PC) and Record Trigger Source (page 11,12)
8. Select the Time-code source and set the initial value (if needed) (page 11)
9. Set the compressed bit-rate and choose I-Frame or Long-GOP CODEC (page 13)
10.Set the PSF In and PSF Out options, depending on your video format (page 13)
11. Set up the audio source, line/microphone input and gain (page 15)
12.Connect a valid SDI or HDMI source and time-code source (as appropriate).  Connect the SDI 

or HDMI output to a compatible monitor. You should see valid video output.
13. Insert a qualified Compact Flash card into either CF slot (manufacturer’s logo side up) and 

format (System->Format).  Warning: all files will be erased off the card!
14.  Ensure that your camera's SDI / HDMI output has any status display information turned off, so 

that this is not recorded to the CF cards.
15.  Please back up your data.  There is a very slight risk of damage to CF cards upon 

insertion and usage with a USB or Firewire CF reader attached to a computer.  As a 
precaution to protect your video, please consider backing up your data as a 1st step 
after recording, and before inserting CF card into a CF reader attached to a computer . 
We suggest using the portable Nexto Drive for this purpose (see accessories, page 21).  

16.Do a test record, transfer data from CF card, preferably via Nexto drive, or via USB or Firewire 
CF reader, to computer for viewing / editing. (See viewing / NLE options, Addendum F, G).

17.Charge your batteries or use a reliable AC source to prevent loss of data.
18.Hot-swapping of CF cards during record is now supported.  See discussion in “Recording 

Notes” Addendum.  (ver1.6.226)
19.Enjoy some fantastic video/audio!
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Input / Output Connections

Left Side Connections

 Bottom Connectors
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Left Side Connections
• CompactFlash Slots (2): Insert (at least 1) solid-state Compact Flash card(s) face up for 

record and playback.

• CompactFlash LEDs: Compact Flash Status: 
> No Light means no card inserted or the card has not been properly recognized.  
> Solid green means card is OK and ready for use.  
> Flashing Red means card is being written to during a record session (do not remove card).
> Flashing green means card is being read from during playback (do not remove card).
> Solid Red means the card is full (may be removed).

Bottom Connections
• Status: General indicator.

> Solid Green: cards are inserted and ready to record.
> Solid Red: recording.

• Remote Control / LTC input: 10-pin hirose locking connector for external trigger and tally light 
control.  To use Remote for recording:  press tally once to start record, press and hold for 2 to 
3 seconds to stop record.  To use Remote for playing:  press once to start play, once to pause, 
twice in quick succession to stop Play.  See System->Trigger for uses, or pg 27 for pin-out. 
Also can be used for Linear Timecode input.  Tally light flashes once a second during normal 
record, twice a second during record with less than 5 minutes total record time remaining, 4 
times per second with less than 1 minute total record time remaining. (ver1.5.31)

• Power: 4-pin Hirose locking connector power input.

• On/Off (Red):  power button.  Note that units shipped after October 2009 have the power 
button disabled or removed, so that the nanoFlash always powers on when power is applied, 
and only powers off when power is removed.  See System->Power Saving to help reduce 
power consumption.

• HDMI In:  non-locking mini-HDMI input (HD/SD) .  Please note that the HDMI port is not nearly 
as robust as the SDI port for handling high motion environments, and therefore the HDMI input 
is not recommended for use in such conditions.  Also, be careful if using with HDMI switchers, 
a poor quality switcher can cause nanoFlash to frequently lose the video lock.

• HDMI Out:  non-locking mini-HDMI output (HD only) .  Ideally, to use, do not connect this port 
until after the unit has been powered on. (ver1.5.31)

• SDI/ASI In: SDI or ASI video source for recording.  (HD/SD)

• SDI/ASI Out: SDI re-clocked stream with embedded audio and time code, or ASI re-clocked 
output stream.  Note there is no delay in the SDI output in E to E mode (Video->E to E) from a 
live source.  If E to E is turned “off”, there is a bit of delay (4 frames).  (HD/SD) 

• Analog Audio In:  3.5 mm consumer line level or microphone 2 channel stereo input.
• Headphone Out:  3.5 mm headphone audio output.  No delay in Headphone Out from a live 

source.   Also, headphone out provides 2 rising beeps at record start, 2 falling beeps at stop.
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Front Panel
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Front Panel Details

1. LCD Display: Shows the status of the nanoFlash in the various operating modes. Also 
displays warning and errors in correspondence with flashing LED error lights. (see p. 10)

2. Navigation Buttons: Allows the user to navigate the menu. (see p. 11)
3. Record, Stop, Play Buttons: <REC>, <STOP>, and <PLAY> buttons for control of respective 

modes.  The nanoFlash, when powered on, is in a ready mode. Record or Playback can be 
activated by pressing the appropriate buttons, as described below:  

REC: Press <REC> to start recording a clip to the card.  (This assumes that System-
>Record Trigger is set to “Record Button” - other Trigger modes will disable the Front 
Panel buttons. See Record Trigger menu description for more details.)  
Unless stopped, the unit records to current CF slot til full and continues recording to 
next card slot til full.  Cards may also be hot-swapped for indefinite record length.   
During Record, the led next to the actively recording CF card slot will flash red, and a 
rotating hourglass will appear on the lcd screen.  
“Skip to next file”:  Pressing the Record button during a record session will cause the 
current file to be closed and a new clip started.
“Skip to next card”: Similarly, pressing the Record button twice in rapid succession 
during a record session causes the recording to continue on the next card.
(See “Recording Notes” Addendum.) (ver1.6.226)

STOP: Press <Stop> button  to terminate record or playback mode.  Also used to 
cancel a card format.  
Note:  the STOP button is immediately responsive upon being pressed.  To prevent 
accidentally stopping a record, see alternative record trigger options (timecode trigger, 
remote trigger)(page 11), which de-activate the REC and STOP buttons.
 
PLAY: Press once to enter Playback mode.  By default, Play will start with the last 
recorded clip. Other features:

1. Use the left and right arrow keys to advance / backup to the next / previous file. 
You can hold down these keys to move very quickly from file to file.

2.   During Play, press Play button to pause, press again to resume play.
3.  During Play, hold Play button 1 second for fast forward 2x, hold 2 seconds for 

fast forward 4x, 3 seconds for 6x (see progress bar on menu for fast forward 
level).  Fast forward performance will depend on card speed and bit rate – see 
Play setup for more details.  Press Play again to return to Play/Pause.

4.  Set the Loop option in the main menu off or on to loop play.
NanoFlash now also supports playback of Canon XF Series CompactFlash card recordings at 50 
Mbit.  (ver1.6.226)

Other button functions: 
Delete Last Clip:  Press and hold the Stop key, then press left arrow key, to delete last clip off 
of currently inserted card which was last recorded to.  (Not working in version 1.6.248)
Fifo Meter Display:  Displays the CF card's ability to keep up with the data rate of the video. 
From the main menu, press and hold the left arrow key, and then press record button to initiate 
a record session.  If Fifo meter rises over time towards 100%, the CF card is too slow to 
handle the data rate. (Small spikes in the meter will appear during file transitions.) (ver1.6.226)
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LCD Screen Layout

The LCD screen will change in appearance depending on the operating mode. This is the essential 
layout information: 

1. Compact Flash Card levels: 0 to 100% full
2. Individual Compact Flash Level Indicators
3. Time-code Display
4. Play Menu Line with current file name displayed
5. Audio Channels 1-2 Level Indicators
6. Audio level markers (-60dB to 0dB)
7. Current Video Source Format
8. Recording (compressed) bit-rate
9. Total remaining record time (minutes) across all cards
10.Audio Over-Range Indicator
11.  Not shown:  Record Ready Indicator   |> 
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Menu Navigation

Use the up, down, left, right and the center (enter) buttons to navigate through the various menus on 
the nanoFlash.  Press the right arrow button to traverse into a menu, and the left arrow to back out. 
Use the up/down arrows to modify a selection and (very important) press the center (OK) button to 
apply the selection, or else your selection will not be entered.
Below is a detailed explanation of each of the menus:

System
Time (HH:MM:SS / Temperature) 
Sets time in Hours: Minutes: Seconds (24 hour format only) and displays internal temperature.

Date (YYYY MM DD)
Sets the current Year Month Day

(File Format option was formerly here, please see “File=” below to set file format.  (ver1.6.18)

Max File Size (100% to 20%)
Maximum file size to use during long records which will create multiple files.  Default is 100% 
(~ 3.5 Gbytes each file).  As an example, 50% setting will yield max 1.75 Gbyte files.
Not available at the bit rate of 180 Mbit or above – at this rate the file size is 100%.
In time-lapse mode, the available range is expanded, 100% to 2%.
Note that a single card can hold a maximum of about 500 files. (ver1.5.126)

File= (1st 2 digits: Unit ID, 01 to 99 or AA to ZZ) (next 3 digits: clip number, 000 to 999) 
(last field: File Format .MOV / .MXF / .MPG) (ver1.5.249) (ver1.6.18)
Allows the user to control file naming, to a limited degree.  The unit ID is used in the first two 
digits of the file name. (See File Naming Conventions, pg 16.)  If your shoot involves multiple 
nanoFlash units, this can be used to set unique IDs for each unit.  
The middle 3 digits are the clip number, which can also be set.  Take care not to create 
duplicately named files on a single CF card.
Last field sets the file format: QT (Quicktime / .mov file), MXF (.mxf file format), or MPG.  See 
Software Accessories and NLE Compatibility for playing / editing files.

Pre-Record Buffer  (for MXF, QT file formats only)
Enables 4 to 7 seconds of internal storage of video before a record session starts.  When the 
record session is started, recording will begin 4 to 7 seconds in the past.  (Pre-buffer = 7 
seconds up to 80 Mbit bit rate, 4 seconds @ 100, 140 Mbit bit rate)

> When turning on the Pre-Record Buffer or changing inputs, allow at least a few 
seconds for the internal buffer to fill before beginning a record.  Also, allow a few 
seconds after stopping record for remaining data to be flushed out, if record session 
does not immediately end.
> If this mode is used in combination with “Timecode (TC)”  or “TC > Last TC” Trigger 
(System->Trigger), the timecodes of the camera's recording and nanoFlash's recording 
may not match, as the nanoFlash begins recording in the past (before the camera's 
record-run timecode was running), causing a potential timecode mismatch of a few 
seconds.  Also, with “TC > Last TC” trigger used with Pre-buffer, nanoFlash will be 
delayed 1 to 8 seconds to start recording for similar reasons.  (ver1.6.29)

nanoFlash 11



> Pre-Record buffer can only be used with bit rates up to and including 140 Mbit.
> An additional 1.5 Watts of power will be consumed while the nanoFlash is in idle (non-
recording) mode when using pre-record buffer.  There will be no effect on power 
consumption during record.
> Turn off Pre-Record Buffer when playing back off the CF cards out of the nanoFlash.
> Do not use Pre-Record Buffer in combination with Time-Lapse, Crank, 720p60-
>30/50->25, or 3:2 Pulldown Removal.(ver1.5.126)

Trigger 
Selects the record/ stop trigger source (or Play source, for the “Remote Play” option).  Note 
that unless otherwise mentioned, each trigger is mutually exclusive (i.e. only one trigger is 
active at a time).  This means that, for example, in timecode trigger mode the Record and Stop 
buttons will be disabled – only the behavior of the incoming  timecode will start and stop a 
record.  The only exception to this is the “Remote & Record” option, below.

Remote Play – Unit will play (but not record).  Formatting is also disabled.  Use Play /Stop 
buttons to control play (see Play menu, below).  Remote tally also becomes a Play 
mechanism: start (1 press) / pause (1 press) / stop (double press).  (In this mode, 
Remote tally can also be used for Cue Play (in the main menu).) (ver1.5.31)

Timecode – Recording will start when incrementing time-code is detected from the HD-SDI 
input and will stop recording when time-code is not incrementing.  This is particularly 
useful when wanting to trigger a record session from the camera's record.  To use 
Timecode Trigger, in addition to this setting System->Trigger->Timecode :

>  Set System->Timecode->Source to “Embedded” or “LTC” as appropriate.
>  Set the camera's timecode  to “Record Run”.  
>  Most cameras require a tape or solid-state media within the camera to enable 
the record function.  Also, note that when the media in your camera becomes full, 
the time-code will cease to increment and the nanoFlash will stop recording.
> Time-code increment may also take place on some cameras when playing 
back from the camera's media, or inserting or ejecting a tape or powering on/off 
the camera, causing the recording of very short unexpected clips in these cases. 
Use “TC > Last TC”, below, to help minimize unexpected recordings. 
> Can be used with Trigger Delay (System->Timecode->Trigger Delay).  With 
some tape-based cameras which unexpectedly shift the timecode at the start of 
record, a trigger delay of 1 to 3 seconds can help to precisely sync the camera's 
timecode with nanoFlash timecode.  A 1 second setting can also help eliminate 
the creation of very tiny files on the nanoFlash caused by slight, random 
adjustments of the timecode by some cameras while in idle mode.  (ver1.6.226)

TC > Last TC – Same as Timecode Trigger, above, except that the nanoFlash will only 
trigger to record if the incoming timecode is greater than the ending timecode of the last 
recorded clip.  This helps to minimize unexpected recordings, for example when inserting 
or removing media in the camera, or playing back video off of the camera's internal 
media.  Be aware, however, that if the camera's timecode is re-set to a smaller value, the 
nanoFlash may not trigger from the timecode unless the nanoFlash is then turned off and 
back on.  (ver1.5.126)

Remote switch – Recording is triggered by a remote control tally switch.  In this mode, the 
keypad is  disabled during record.  Also, the remote switch must be held down 
approximately 2 to 3 seconds to stop the recording.  (See remote switch pin-out, or a 
cable can be purchased from Convergent Design.) 

Remote level / hold – Again via remote control, except that Record is initiated by pressing 
and holding Remote Tally, Record is stopped by releasing Remote Tally.
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Record button – Recording is started by pressing the Record Button on the unit, and 
stopped by pressing the Stop button.

Remote & Record button – Remote switch and Record button can be used to start / stop 
Record.  (ver1.5.126)

Power up – Recording is automatically started by applying power and video source, Record 
is stopped by removing video source.  Do not use in combination with  Pre-Record Buffer 
(System->PreBuffer), Crank, 720p60->30/50->25, 3:2 Pulldown Removal, or Time-
Lapse.  (ver1.5.126)

Duration HH:MM:SS If enabled, each record session will last only for the specified 
HH:MM:SS.  (ver1.5.31)

Timecode 
Sets the time-code source, and (for internally generated timecode only) the drop-frame flag 
and the initial value (seed)

Source (Embedded, Internal, LTC)
1. Embedded – timecode is extracted from HD/SD-SDI stream from the source
2. Internal – timecode is generated internally in the nanoFlash
3. LTC – timecode from external LTC input
4. Jam Sync – to use:  provide momentary timecode jam sync (via the LTC 

input port) while unit is in idle mode with a valid video input source.  If video 
source is lost or nanoFlash is placed in Play mode, timecode must be re-
sync'ed after video source returns or nanoFlash returns to idle mode.

Dropframe – [ ] enable (checked) if drop-frame time-code should be generated (only 
valid for internal time-code generation and 59.94/29.97 frame rates)
Seed – initial value for internal time-code only:

1. Set 01:00:05:19 – Manually set the initial time code.  (HH:MM:SS:FF) 
2. Time of day – Use time of day time code, based on the System->Time setting.
3. Reset – set the initial time-code to 00:00:00:00.

Trigger Delay – Seconds to delay Recording when using “Timecode” or “TC > Last TC” 
trigger (System->Trigger).  (See discussion in Trigger section, above. ) (ver1.6.226)

Source:  Selects the video input source – choose between SDI and HDMI.
Format:  Format (erase) all inserted CF cards.  Use with caution!  Note:  CF card Volume 
names may be defined on a computer.  If the 8th,9th,10th, and 11th characters of the Volume 
name are all numbers, they will be incremented automatically with every format of the CF card 
on nanoFlash (to help indicate card usage and life).

Power Saving
Auto Sleep
If this feature is turned on, the nanoFlash will drop to low power mode after 1 minute of 
inactivity if no SDI input is present.  (This feature does not apply for HDMI input.)
When the unit is in low power mode, power consumption drops to 0.3 watts, and the lcd 
screen is active with “Low power mode” message displayed.
In low power mode, any of the following events will bring the unit back to full power:

> SDI input resumes.
> Any of the keys on the keypad are pressed.
> A remote tally, if attached, is pressed.

Upon wakeup, the nanoFlash is completely rebooted (5 to 7 seconds). (ver1.6.226)
Auto LCD Off 
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This turns off the LCD backlight after 15 seconds of inactivity.  The LCD backlight 
consumes about 0.2 watts of power, so this provides slight power saving.

Create Settings.txt: Primarily a tech support diagnostic tool, creates a file settings.txt with all 
current settings. Only use this option with a formatted, blank CF card inserted. (ver1.5.31)
Create Menu.stg:  Saves menu settings to an inserted CF card as “Menuxx.stg” (1 to 20) into 
a created }CFG{  folder.  Menu settings can be saved and restored.  See discussion in 
“Managing Your Menu Settings” Addendum.
Restore Defaults:  Restores factory default settings.
About:  Displays the current firmware version number.

Video
Bit Rate 
This option allows the user to set the compressed bit-rate of the video being recorded.  Note 
that most NLE's place a 50 Mbit label on high bit rate files, but nevertheless accept the high bit 
rate files natively.  The actual bit rate of a file can be seen in Quicktime Player by using 
Window->Movie Inspector, which has a bit rate field.  For MXF, the bit rate can be seen in the 
XDCAM Viewer (an MXF Player, see link in Software Accessories), Product / Version fields 
(under View->Metadata).  (ver1.5.31)

HD Bit Rate (Quicktime, MXF)
1. *18/35 Mbps = Full-Raster (1920x1080/1280x720) 4:2:0 Long-GOP (XDCAM EX)
2. *18/35 Mbps = (1440x1080/1280x720) 4:2:0 Long-GOP (XDCAM HD)
3. 50/(80 ver1.5.31)/100/140/180 Mbps = Full-Raster (1920x1080/1280x720) 4:2:2 

Long-GOP (XDCAM 4:2:2) (100 Mbps and above = Master Quality)
4. 100/140/180/220/280 Mbps = Full-Raster (1920x1080/1280x720) 4:2:2 I-Frame 

(XDCAM 4:2:2) (180 Mbps and above = Master Quality)
SD Bit Rate (Quicktime, MXF)

1. for Standard Def:  50, (40, 30 ver1.5.31)Mbit IMX 4:2:2 (720x486/720x576) 
* 18/35 Mbit recording depends on 35 Mbit 1080 Width setting (below) (ver1.5.31) .
HD Bit Rate (MPG)

1. 19/25/35 Mbps (1920x1080/1280x720) 4:2:0 Long-GOP
SD Bit Rate (MPG)

1. 5/9 Mbps 4:2:0 Long-GOP

CODEC (Long GOP / I-Frame)
This option selects the XDCAM 422 CODEC format. Long GOP supports the bit rates at 18, 
35, 50, 100, 140, and 180 Mbps.  I-Frame only allows recording at 100,  140, 180, 220, and 
280 Mbps.  The nanoFlash utilizes the high quality Sony XDCAM 4:2:2 CODEC for video 
compression.  The data rates of 100 Mbit or greater Long GOP and 180 Mbit or greater I-
Frame are generally considered to be Master Quality video.  In brief, long-GOP codec 
compresses 12 or 15 frames at a time, sharing the information between the frames, resulting in 
greater efficiency (in part by throwing out duplicate information), especially at bit rates of 100 
Mbit and below.  I-Frame codec compresses each frame separately.  The highest quality video 
recording from nanoFlash is 280 Mbit I-Frame.

Record PSF->Progressive     [ ]
Turn this option “On” to record PSF input video or progressive input video as progressive. 
Turn “Off” to record PSF input video or interlaced video as interlaced.
Play Progressive->PSF    [ ]
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Turn this option “on” to play 1080p progressive video off of a CF card as PSF video to the 
video outputs.  ( Note: some SDI monitors only accept 1080PSF video, not progressive. 
In this case, turn this option “On”.)  
Turn “off” to play 1080p progressive video as 1080p. ( Note:  HDMI monitors do not support 
1080psf23.98 .  In this case turn this option “Off”. )

Remove 3:2 Pulldown  (for SDI or HDMI sources)
Preserves 1080p2398 frame rate from a 1080p2398 source which is outputting as 1080i59.94 
with 3:2 pulldown by removing the pulldown, such as Canon cameras in 24F mode or other 
cameras in 24p mode which output with a pulldown (1080i60).  Also works with 720p60 
sources with pulldown (to 720p24) (ver1.5.31).  The bit rate selected applies to the video after 
pulldown, meaning, for example, @ 280 Mbit setting the recorded bit rate will be the full 280 
Mbits / second.  Audio is preserved in this mode.  
> Only use this option if the video source does indeed contain a pulldown.
> Do not use in combination with  Pre-Record Buffer (System->PreBuffer), Crank, 
720p60->30/50->25, or Time-Lapse.  (ver1.5.126)

SD Aspect Ratio
For Standard Definition Video input only:  select the pixel aspect ratio (16:9 or 4:3).  This 
setting needs to match the camera's aspect ratio setting for SD recording.

E to E Direct 
Sets the SDI loop-through output to the exact same format as the incoming video format (such 
as psf).  This is particularly useful for looping through a PSF input.  
In E to E mode, 1 of 2 combinations is output: 
> if video source is SDI, audio source is Analog, and timecode source is LTC:  these sources 
will be looped out of the SDI output in E to E mode. (ver1.6.226)
> for any other combination of video/audio/timecode sources: only embedded video / audio / 
timecode are looped to the output.  
> This setting always applies to the SDI output.  For the HDMI output, the setting only applies if 
the input is SDI.  If the input is HDMI, the HDMI output is always E to E.

Time-Lapse
Records individual video frames (as I-Frame only) based on a set time interval 
(Hours:Minutes:Seconds).  Special points to consider:
> the hour glass on the lcd screen will only change on the selected time interval.
> when a time-lapse record is stopped, there may be a delay up to the selected time interval to 
close the clip. In addition, the clip will end with under a half second of regular speed footage, 
which will need to be edited out.
> Use a reliable power source so as not to lose power and lose footage.
> Time-Lapse mode can support all bit rates (up to 280 Mbit) during record on approved CF 
cards (including slower CF cards), due to the lower data rate;  however, not all CF cards can 
play back high bit rate recordings.
> Time-lapse is always I-frame only recording, audio is not preserved in this mode.
> Time-lapse is only supported in MXF and Quicktime file formats.
> System->Max File Size has an expanded range of 100% to 2% in time-lapse mode.
> At end of a time-lapse record, there may be a few extraneous video frames in the closing file.
> A minimum of 15 frames should be recorded to complete a successful record.
> Do not use time-lapse mode in combination with  Pre-Record Buffer (System->PreBuffer), 
Crank, 720p60->30/50->25, or 3:2 Pulldown Removal.  (ver1.5.126)
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Crank [ ]   [Recorded Frame Rate]    [Crank Frame Rate]   (ver1.5.126)
Allows frame rate overcrank / undercrank to provide slow motion / fast motion effects.  The 
recorded format corresponds to the incoming video format – for example, if 720p60 is the 
incoming format, and recorded rate is set to 24, the recorded format will be 720p24.  In this 
example, if the crank rate is set to 60 then this provides a 2.5x slow motion effect.

Recorded Rate:  24, 25, 30, 50, or 60.  Can not exceed incoming video frame rate.
Crank Rate:  Frames per second to preserve from the incoming video:  1 to 60.   Can 
not exceed incoming video frame rate.

> Crank is I-Frame only recording, minimum 50 Mbit, and the audio is not for use in this mode, 
only video.
> In Crank mode, incoming 720p60 can only be used with 60, 30, or 24 recorded rates (and 
1080p30 with 30 or 24 recorded rates) .
> Incoming 720p50 can only be used with 50 or 25 recorded rates (and 1080p25 with 25 only).
> Press right or left arrows during record to dynamically adjust crank rate.
> The recorded bit rate of cranked recording is reduced based on the ratio of the recorded 
frame rate to the incoming frame rate.  For example, a 720p60 incoming signal @ 280 Mbit, 
with record rate of 24 (yielding 720p24 recording) will adjust the bit rate by a ratio of 24/60, 
giving a recorded bit rate of 112 Mbits /sec.  This is necessary due to the way the nanoFlash's 
codec handles cranking.
> 720p24 / 25 / 30 can not be played out of the nanoFlash at this time.
> For best results, set your camera to the full frame rate.  For example, for cranking in 720p 
PAL set the camera to 720p50 (not 720p25), for cranking in 720p NTSC set the camera to 
720p60 (not 720p30 nor 720p24).
> Do not use Crank mode in combination with  Pre-Record Buffer (System->PreBuffer), Time-
Lapse, 720p60->30/50->25, or 3:2 Pulldown Removal.

720p60->30, 50->25 (ver1.5.126)
Cuts the frame rate in half for incoming 720p60 or 720p50 signals by throwing out every other 
frame. Useful, for example, with cameras with a 720p30 or 720p25 mode which then double 
the frame rate of the camera's SDI output.  The nanoFlash bit rate in this mode is applied to 
the reduced frame rate.  For example, @ 280 Mbit from a 720p50 source reduced to 720p25, 
the recorded bit rate will be the full 280 Mbit.  Audio is preserved in this mode.
> Do not use this mode in combination with  Pre-Record Buffer (System->PreBuffer), Time-
Lapse, Crank, or 3:2 Pulldown Removal.
HDMI Rx Color (HDMI input only)
Choose between Full color and Legalized color.  Most HDMI based cameras are Full color, 
computers and game boxes are examples of Legalized HDMI video sources.
35 Mbit 1080 Width
Choices are:  1920 (for 35 Mbit 1920x1080   4:2:0 XDCAM EX) or 1440 (for 35 Mbit 
1440x1080   4:2:0 XDCAM HD). This setting only applies when Video->Bit Rate->CF HD Rate 
is set to 35 Mbit.  Bit rates of 50 Mbit and above are always 1920x1080  4:2:2 (for 1080 
sources).  (ver1.5.31)
Record Tally (ver1.5.249)
Places a red bar on SDI output during record, as a record indicator.  Also requires Video->E to 
E Direct to be activated.
Flip V (ver1.6.226)
Inverts (flips) the video input vertically.  (HD only)
Flop H (ver1.6.226)
Inverts (flips) the video input horizontally. (HD only)
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Audio
Source 

1. Embedded:  Audio is accepted over SDI (0,2,4, or 8 channels, based on setting below).
2. Analog:  Audio is accepted over 3.5 mm analog audio input.  This can be either 

consumer line level or mic (1 channel balanced or 2 channel unbalanced stereo).  

Analog Settings
1. Mix In:  Choose between Mono Balanced and Stereo Unbalanced Analog Audio Input.
2. Gain In:  Adjusts gain for analog audio input.  This may also be adjusted during record, 

using the up and down arrow keys.  Range is from -99 to +44 dB. (ver1.6.226)
3. Gain Out::  Adjusts gain for 3.5 mm headphone output.

Record Channels (HD only):  0, 2, 4, or 8 channels.  SD recording is always 2 channel.  Note 
that NLE support for 0 channel audio is limited.  See NLE section. This option is for SDI input, 
HDMI input / output only supports 2 channels audio. (ver1.5.31)

Monitor Channels:  Choose audio channels to monitor on headphone output:  1 and 2, 3 and 
4, 5 and 6, or 7 and 8.  (ver1.5.126)

Play (filename)  (HDMI Out : HD only, SDI Out : HD or SD)
Select the file to begin play.  
Note: one can mix and match file formats / bit rates / video formats on the same card for 
recording, but for playing back all files need to be the same video format and file format.

During play, the following navigation tools are available:  (MXF, QT files only)
> File Skipping:  press the right key to jump to the next file, press the left key to jump to the 
previous file.  Press up key to jump to next clip, press down key to jump to previous clip. 
(ver1.5.126) File skipping will cause a very brief distortion of the video output.  File skipping is 
also available with MPG files.
> Pause: press Play (during play or fast forward) to Pause.  Press Play again to resume play.
> Fast Forward:  press and hold Play for ½ second for 2x, 1 ½ seconds for 4x, 2 ½ seconds for 
6x.  A fast forward rate bar is displayed on the lcd screeen.  Maximum fast forward rate 
depends on bit rate and card type. In general:

> FF to 50 Mbit bit rate:  max rate = 6x (SanDisk Extreme 3:  4x)
> FF 100 Mbit:  max rate = 4x   (SanDisk Extreme, Extreme 3:  2x)
> FF 140 / 180 Mbit:  max rate = 2x  (SanDisk Extreme 3:  1x)
> FF 220 / 280 Mbit:  1x only

Fast forward beyond a tolerable rate can result in distortion, play may need to be re-started.
> Pressing Record button during Play will place the unit back into Record mode  (provided that 
the Record button is selected as the Record trigger). (ver1.6.29)

To play files recorded on the nanoFlash which are not on their originally recorded CF cards:
> Format a compatible CF card on the nanoFlash.  Remove and take card to computer. 
> Copy the desired files into the }CLP{  folder on the card.  All files must be the same 
video format / file format.  
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Note:  from a Pc, you can copy from Windows Explorer.  From a Mac, use the free 
converter /copier tool to make a non-fragmented copy of files to the card, as Mac's have 
more of a tendency to fragment files.  See Software Accessories for a link to the tool.
> On the nanoFlash, set the trigger (System->Trigger) to “Remote Play” - during record, 
externally copied files are ignored by the nanoFlash and overwritten, so this prevents 
records from happening and overwriting your copied files.
> Insert the CF card back to nanoFlash with copied files, in the Play menu, choose the 
file to begin playing.
> Press “Play” - the clips will play through, and then loop back to the beginning and 
repeat indefinitely til stopped (unless Loop option is disabled, below).

NanoFlash can also play XDCAM EX or XDCAM 422 Quicktime files exported from Final Cut 
Pro, by running the files through our converter tool to make a nanoFlash compatible MXF copy 
of the files.  See converter tool in Software Accessories for details.
Note:  Play of 720p24 / 25 / 30 is not supported at this time.  (ver1.5.31)

NanoFlash now also supports playback of Canon XF305 CompactFlash card recordings at 50 
Mbit.  (ver1.6.226)

Loop Play:  For Play out of the nanoFlash, select “Loop All” for loop play or “Off” for single play 
to end of last inserted CF card.

Cue Play:  Allows playing from a cued frame (based on entered timecode), via Remote Tally only. 
Press Remote Tally once to cue to selected timecode + 1 in the play file, press Remote Tally again to 
continue playing from cued point.  Additionally, set System->Trigger to “Remote Play”.  (ver1.5.31)

Loop Record:  In this mode, the nanoFlash will record continuously to card 1, then to card 2, 
then back to card 1 (overwriting previous contents), then back to card 2 (again overwriting previous 
contents), etc til stopped.  The current card is completely erased before any files are written.  Do not 
use Loop Record mode unless willing to have older material overwritten by newer material in a 
record session. “Loop Record” will appear on the screen in this mode. (ver1.5.31)
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Compact Flash Capacity and Usage

Formatting CompactFlash cards
Choose System->Format to format all inserted CF cards.  Note: all data will be deleted during a 
format operation!

Important Operating Notes
•  Use only the qualified Compact Flash Cards: see pg 4 for a complete list.
•  The Compact Flash card levels (0 to 100% full) are displayed on the upper line of the LCD. 

The total remaining capacity across all cards (in minutes) is shown in the lower right corner.
• NEVER remove a card while nanoFlash is in record or playback modes
•  Video formats (1080p / 1080i etc), bit rates, and file formats (.mov and .mxf) may be mixed on 

the same card.  However, cards with mixed formats will not play back properly from the 
nanoFlash.  The files will all play from a computer.

• All CF cards must be formatted in nanoFlash before usage.  After all files have been copied to 
another drive for safe keeping, the CF cards can be reused by performing a format operation 
on the nanoFlash.  All data will be erased during a format operation.

• Never force the card into the CompactFlash slot.  Cocking the card or forcing it in could 
damage the contact pins and render the slot useless.

• Typical record capacities are shown below.  Note that the record capacity does not depend on 
the video format, only the selected bit-rate and the capacity of the CF card(s)

Compact Flash Record Capacity (Minutes)

50 Mbps 100 Mbps 180 Mbps 280 Mbps
 1 16 GB 

Card
36 18 10 7

1 32 GB 
Card

75 37 20 14

1 64 GB 
Card

150 75 40 28

2 32 GB 
Cards

150 75 40 28

2 64 GB 
Cards

300 150 80 56
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File Naming Convention

The video/audio file naming convention is shown below. The file name follows an 8.3 format, where 8 
characters identify the file name and 3 characters the extension (.mov, .mxf, .mpg)

1. Unit ID Number: Unit ID is assigned under the System Menu, and is used to identify 
multiple nanoFlash units if needed.  The default is 01.

2. Clip Number: The clip number is incremented every time a recording is started.  If the Unit 
ID number is incremented, the clip number resets to 001.

3. File Number: File number is incremented whenever the file being recorded for a particular 
clip reaches the max file size (~3.5GB).  It is reset to 001 if the clip number or Unit ID is 
incremented.  During a record, the clip number and Unit ID will remain constant as the file 
number increments.  This will go across several card slots if the record time is long enough.

4. File Name Extension: the possible extensions are .mov (Quicktime), .mxf (MXF files), 
.mpg .

Firmware Update Procedure

Download the update zip file  from our website, http://www.convergent-design.com/
Unzip,   copy the    }UPD{   folder along with its underlying contents onto a  qualified CompactFlash 
card (via a CompactFlash firewire or usb reader with the card inserted and the reader attached to 
computer), at the top level of the card.  
Place update card into either CF slot of your nanoFlash.
Wait for screen prompt, you will be directed to press OK to initiate the update.
While updating, the unit can not lose power.  
Also, do not remove the update card during the update process.
Wait for “Update succeeded” prompt (about 5 minutes).  When this occurs, unplug the unit, remove 
the update card, and your unit is ready for operation.
To re-use the update card for capturing video:  remove the update directory on a computer and re-
format the card on the nanoFlash.
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Hardware Accessories 
(available via 3rd party, unless otherwise noted)

A wide range of accessories discussed below are available through
http://nanoflash.net/ , or through your dealer. (ver1.5.31)

Compact Flash Cards (Use only the qualified Compact Flash cards at specified bit rates):
see pg 4 for qualified cards.  CF cards are widely available on the internet.

Compact Flash Readers
1. Lexar FW-800
2. Delkin 
3. PCI Express CF Readers

Remote Control / LTC Timecode  
• Remote tally light button cable for 10-pin hirose   connector (available from Convergent 

Design), for starting / stopping record in “Remote” trigger mode.  Please note that when 
starting record via the remote, the nanoFlash generally reacts right away.  When 
stopping record, you must hold down the remote button for 3 to 5 seconds before the 
record stop is initiated, to help prevent accidentally stopping the record.  

•  A cable is also available to allow 10-pin hirose to bnc connector LTC timecode input.
• A combination cable can be made for both remote control and LTC Timecode into the 

10-pin hirose connector.

Hard Disk Drive Backup Devices   
1. NexTo Drive:  500 GB portable CF drive for intermediary offloading of footage – holds 15 32GB 

CF cards' worth of data.  Connects to computer via USB or ESATA for transfers.  Please 
consider using such a drive as a backup storage device before inserting CF card with 
recorded video into a CF reader attached to a computer.

http://www.nextodi.co.kr/en/product/eXtreme_en.html
http://www.cvc.de/index.asp?haupt=http://www.cvc.de/shop/asp/ArtikelDetails_sql_2.asp?
Nummer=8851&Sprache=D

Batteries for powering nanoFlash   
1) 2 cell lithium ion with attached 4 pin hirose connector and charger (available from Convergent 

Design), provides about 3 hours recording time
2) Swit :  for EX1 / EX3 and nanoFlash (requires a d-tap converter cable to 4 pin Hirose power 

connector, available from Convergent Design)
http://dolgin.net/Battery_Charger_TC400-EX.htm#SWITS8U62

3) Anton Bauer, IDX (with d-tap to 4-pin hirose)
4) nanoFlash can also be powered from professional camera batteries with 2-pin hirose 

connector (with 4-pin to 2-pin hirose)

Battery Cables available from Convergent Design
1. 4-pin hirose to d-tap
2. 4-pin hirose to 2-pin hirose
3. 4-pin hirose to XLR
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4. 4-pin hirose to flying leads (pigtails)

** Note:  do not use nanoFlash custom cables with other devices, as the pin-out may be 
different and cause damage to other equipment.

Camera Mounts   
1. swivel shoe mounts:  http://www.nebtek.com/

Portable Field Monitors (HDMI)
1. http://dolgin.net/HD_Field_Monitors.htm  

Audio Adaptor Cable (for Canon XL-H1)
For Canon XL-H1, audio can be brought into the nanoFlash via the RCA analog audio outputs 
on the Canon to the 3.5 mm analog input on the nanoFlash, using an adaptor cable.  Such 
cables are widely available.  (For newer XL-H1-S, the audio can be passed to the nanoFlash 
via the SDI port. )
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Operating Tips

Operating Tips
1. Only insert/ remove cards which are not being recorded to.  Removal and insertion of a 

CF card during record is supported.  If removing a card during record, make certain that the 
CF card being removed is not being recorded to, at the time of removal.  If inserting a card 
during record, insert cards that have either been formatted (preferably on nanoFlash) or 
that only contain nanoFlash video (no extraneous data or files). (ver1.6.226)

2. Be gentle with CF card insertion to CF card slots! Jamming CF cards into the CF slot or 
applying excess pressure on either side of the CF card during insertion can cause bent pins 
inside of the CompactFlash slot.  Bent CF slot pins will result in unit malfunction, and is not 
covered under warranty.  Insert cards gently, applying modest pressure in the middle of the 
(edge of the) card during insertion.

3. Only use recommended CompactFlash cards: Use only the approved Compact Flash 
cards, otherwise your video footage may be corrupted.

4. CF Card Monitoring: Each card slot has a progress bar at the top of the LCD screen.  The 
total record time remaining in minutes is always displayed on status line (bottom right).

5. CF Card Erase/Formatting Procedure: To format or erase all cards inserted into the unit, 
choose System->Format in the menu.

Troubleshooting Guide
1. No function of the nanoFlash:  Check that the unit is powered on with the proper power 

adapter, check battery.
2. No Video input (“No Src” in left bottom corner of screen) over SDI / HDMI

1. Plug the HD-SDI  or HDMI camera directly into a monitor to confirm video.
2. Try a System->Restore Defaults on nanoFlash.
3. Check System->Src setting:  HDMI or SDI as appropriate.
4. Try resetting the camera.
5. Check Camera Notes Addendum at the end of this manual for more tips.
6. Check if option Video->Remove 3:2 Pulldown is selected.  If the camera is outputting video 

without a pulldown (such as when the camera is not set to 24p, or it is outputting color 
bars), nanoFlash will not accept the signal.

3. No Video Output over SDI / HDMI
1. Plug the HD-SDI  or HDMI camera directly into a monitor to confirm video.
2. For live monitoring, try changing the Video->E to E setting.
3. If your video source is HDMI, make sure the source is not HDCP encrypted.  The 

nanoFlash can not accept encrypted video.  For example, DVD players appear to always 
encrypt the video out of the HDMI port.

4. Check Monitoring Notes  Addendum for more tips.
4. nanoFlash won't record 

1. Make sure approved CF cards are inserted with space available:  check card indicators on 
top of screen, check the record minutes remaining indicator in bottom right of screen.

2. Make sure a video source has been recognized:  in the bottom left corner of the screen the 
video format is displayed, or “No Src” (No Source) if no video input is detected.

3. Check Recording Notes Addendum for more tips.
5. CF card won't play from nanoFlash to monitor 

1. Try changing the Video->Play Progressive as PSF setting.
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2. NanoFlash plays originally recorded files, (all files should have the same video format), or 
CF cards (with 50 Mbit files) from the Canon XF Series cameras.  NanoFlash can also play 
files copied from a computer, and even edited from a computer, under certain 
circumstances.  See ReadMe of FileConverter tool for more info (Software Accessories).

3. Note the nanoFlash limitations:  can not play 720p24/25/30 off the CF cards, SD video 
plays out of the SDI out port only (not HDMI). 

4. Check Playback Notes Addendum for more tips.
6. File(s) won't play on a computer 

1. Check that the System->File= option is set to the appropriate file format for your computer.
2. See Viewing Options Addendum and NLE Compatibility Addendum for more tips.

7. “Master/Slave input formats do not match”, “Stream Mismatch” (nano3D only) :   In 3D 
mode, Master / Slave video inputs must match exactly, and must be gen-locked.  See nano3D 
Addendum for more discussion. 

8. An error message appears
1. Message “No space on card” appears if the card (or cards) in the unit are full, or if the 

<RECORD> button is pressed and no cards are present.
2. Message “NO SRC”  on the status line (no video source):  no recognized video input.
3. “Intermittent Src xx”, “Lost Src”, “Lost Source” :  video source was lost either 

temporarily or permanently at some point during record.  Typically caused by  either a faulty 
signal from the camera, a faulty cable, electro-static interference, or a faulty connector (on 
the nanoFlash or the video source).  In the event of loss of source, the nanoFlash will close 
the current file, attempt to re-lock to the video signal, and then continue recording.

4. “VCXO out of range” :  relates to specific hardware on nanoFlash that regulates SDI input. 
This may be indicative of a hardware failure;  please contact technical support in the event 
of seeing this message.  (ver1.6.18)

5. Message “Unknown CFX”, where X refers to slots 1-2, appears if a brand new card needs 
to be formatted and cannot be recorded to.  This message can also occur if a CF card 
which has unrecognized external files copied onto the card is inserted to the nanoFlash. 
Formatting (erasing) the CF card usually fixes this.

6. Message “Lost Footage, Card Too Slow”, the CF card is not able to keep up with the 
video because its write speed is too slow (bit rate is too high for the card to handle).  The 
bit rate will automatically be lowered and recording will continue.

7. Messages listed below are typically errors communicating with the CF cards, and are 
caused by one of the following conditions:

> The card slot connector pins on your unit have been damaged, or are 
otherwise failing.  You will likely need to return the unit for repair.
> You've incorrectly hot-swapped a CF card during record or playback.  See hot-
swapping discussion in “Recording Notes” Addendum. (ver1.6.226)
> The CF card has been damaged.  Try formatting the card on a computer. 
Otherwise you may need to return the card to the manufacturer.
> The CF card is not supported.  See p. 4 for a list of supported cards.
> There is a slight risk of damage to CF cards when they are used with Usb or 
Firewire readers attached to computers.  Please consider a backup drive such as 
Nexto (see Hardware Accessories) to offload video and prevent risk of damaging 
the CF cards (and losing your video).
> If such a message appears, you will need to power the unit off and back on.
These messages are: ID CF Dev, ATA Idle, SlotDpc, DMA WR, DMA RD, 
Wrcache2000.  
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Safety & ESD Precautions
1) Always connect the box to the specified power source: +6.5 to 19.5 V. 
2) Keep the internal operating temperature between -20º C and 80º C.  (The internal 

temperature is displayed in the System menu.)   External ambient temperature needs to be 
approximately within the range of -40º C and 60º C.  Direct exposure to sunlight and an 
external cover can also effect internal operating temperature.  Though not likely, 
overheating of the nanoFlash can potentially damage the unit, and is not covered under the 
warrantee.  The nanoFlash will attempt to shut itself down if the internal temperature 
reaches 95º C.

3) Avoid operating the unit in an unprotected outdoor installation or wet areas.  Do not expose 
this product to rain, sand, or snow.  Avoid conditions which would cause moisture 
condensation on the outside cover, or moisture to get into the internal circuitry.  Internal 
moisture can also potentially damage the unit, and is not covered under warrantee.  The 
nanoFlash is not water proof.  

4) Do not drop the unit as this will cause significant damage to several components.  Damage 
due to dropped units is not covered by the warranty. 

5) There are no user serviceable components inside the box.  Only a qualified technician 
should perform servicing of the unit.  Opening the box may void the warranty.

6) Avoid the use of sharp objects near the box as they may scratch the LCD.
7) Clean only with water with a damp cloth.
8) CAUTION: Electrostatic Discharge (ESD) can damage components in this product. 

Although the unit has countermeasures to this hazard installed inside, it is always best to 
avoid damage by using extra caution when handling and inserting Compact Flash cards or 
the LCD screen and connectors.  Always ground yourself (by touching an un-painted 
grounded metal object) prior to handling the unit.

9) Do not touch exposed connector pins and do not insert any metal objects in the connectors.
10)Ensure that all connections made to the box (including at the “other end of the cable”) are 

made in ESD safe environments.
11)Always transport and store the box in the static protected bag included with the nanoFlash 
12)Use caution when connecting the 4-pin Hirose power and 6-pin Hirose Remote/LTC ports, 

as the pin-outs for these types of connectors is not always standard across all toolsets. The 
pin-out that the nanoFlash uses is detailed on page 27, use this as a guide to ensure that 
proper connections are being made and damage is not done to your unit as a result of 
improper connections.
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Specifications
HD/SD-SDI / HDMI I/O
Formats:

• 1920x1080i @ 60, 59.94, 50 Hz
• 1920x1080p @ 30, 29.97, 25, 24, 23.98 Hz
• 1920x1080psf, @ 30, 29.97, 25, 24, 23.98 Hz
• 1280x720p @ 60, 59.94, 50, (29.97, 25, 23.98 ver1.5.31) Hz
• 720x486 @ 29.97 Hz
• 720x576 @ 25 Hz

** Note:  NLE support for true frame rates (exactly 60, 30, or 24 frames) and for 720p30/ 
25/ 24 is limited – test  your NLE for compatibility before using.

Standards:
• SMPTE 274M (1080i), 296M (720p)
• Audio: 24-bit, 48kHz, SMPTE 299M
• Time-Code: RP-188 1080i Lines: 14, 16, 577, 579

Linear Time Code
Standards:

• SMPTE RP-188 (HD)
• HD 1080i Lines: 14, 16, 577, 579

MPEG2 Profiles
• 422P@HL: 100/140/180/220 Mbps VBR 4:2:2 I-Frame Only, 1920x1080i/p, 

1280x720p (XDCAM 4:2:2)
• 422P@HL: 50/80/100/140/180 Mbps VBR, 4:2:2 Long GOP,  1920x1080i/p, 

1280x720p (XDCAM 4:2:2)
• MP@HL: 18/35 Mbps VBR, Long GOP 4:2:0 (XDCAM EX), 1920x1080i/p, 

1280x720p
•  MP@HL: 18/35 Mbps VBR, Long GOP 4:2:0 (XDCAM HD), 1440x1080i/p, 

1280x720p (ver1.5.31)
• MP@HL: 19/25 Mbps VBR,  4:2:0, Long GOP, 1440x1080i (MPG files only)
• MP@ML: 50 Mbps CBR, 720x486/720x576, 4:2:2, I-Frame, IMX
• MP@ML: 5/9 Mbps VBR, 720x486/720x576, 4:2:0, Long-GOP (MPG files only)

Physical
Dimensions: 4.2” (107 mm) deep x 3.7” (94 mm) wide x 1.4” (36 mm) high

Connectors: 75Ω BNC, mini-HDMI, 4-pin hirose (power), 10-pin hirose (LTC/Remote), 3.5 mm 
analog audio in/out

Weight: 1 lb (400 grams)

Power +6.5 to 19.5 VDC, 4-Pin Hirose connector, 3W Idle mode / 5.6W Record or Play / 0.2 W 
standby
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Temperature Range
• Internal Operating: -20º C to 80º C (See System menu for temperature readout).  
• External Operating:  approximately -40º C to 60º C (direct exposure to sunlight or 

placing the unit in a cover or enclosed environment can influence the internal 
temperature)

Humidity
• Operating Less than 80% (non-condensing)
• Storage: Less than 90% (non-condensing)
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User Connector Pin-Outs
(looking into the connector on the nanoFlash, top-side up)

Power: 4-pin Hirose; Mating Plug = Hirose HR10A-7P-4S(73)

1.  Power: +6.5~+20V, ~6.5W
2.  Power: +6.5~+20V, ~6.5W
3. Ground
4. Ground

Remote Tally/LTC: 10-pin Hirose; Mating Plug = Hirose HR10A-10P-10SC (73)

1. LTC In
2. 485D+ / 232RX  (see “Serial RS232 Control” Addendum for more information (ver1.6.226)
3. 485D- / 232TX
4. Record Start/ Stop
5. Tally Light
6. +5.0V
7. Ground
8. Ground
9, 10 not used
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Mounting Plate Dimensions
(all dimensions shown in inches)
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RMA and Warranty

Conditions of the Warranty
Convergent Design reserves the right to determine if a repair is subject to the warranty agreement. 
Damages caused by products being dropped or mishandled are not covered by this warranty.  Also 
damage caused by over-voltage conditions on any of the I/O connectors is not covered by this 
warranty.

There are no user-serviceable parts inside the cabinet. Opening the cabinet voids the warranty. 
Transit damage caused by inadequate packaging also invalidates the warranty agreement. Please 
ship the unit in its original packaging, if possible.

All products are shipped prepaid to Convergent Design, or preferably through the dealer from which 
the unit was purchased (if outside the US). For insurance reasons, Convergent Design cannot accept 
any product that is returned via U.S. Postal Service. Returns will be accepted from Federal Express, 
UPS, DHL, or other comparable freight carrier.  

Convergent Design returns the product via a prepaid ground or 3-day delivery service within the 
continental United States, only if the product is under warranty and subsequently found to be faulty. 
For product purchased outside of the US, the nanoFlash is typically returned through the dealer from 
which the unit was purchased. 

Out-of-warranty repaired products are shipped at customer’s expense. Turnaround time for warranty 
repairs normally will generally require 2 -4 business days (excluding shipping time), unless 
extraordinary fault conditions exist. 

Labor and defects are covered for the warranty period of 2 years (for registered units), 1 year (for 
non-registered units), and 3 months (for units purchased to be used as rentals) from the original date 
of purchase.  If you discover a defect, please refer to our Return Merchandise Policy below. The 
warranty covers all Convergent Design hardware defective in material or workmanship.  During the 
warranty period, Convergent Design, at its option, will repair or replace product or product 
components, which in its opinion prove defective.  Parts and components used in the repair process 
may be recycled or repaired, at Convergent Design’s discretion.  This warranty service will be 
performed at no charge to the registered owner, provided the product is shipped prepaid to 
Convergent Design.  Convergent Design will return the repaired product via a like carrier, in the 
continental United States within 48 hours, shipping time excluded.  Convergent Design reserves the 
right to determine whether a needed repair is subject to the warranty as per its provisions stated 
herein.  Transit damage caused by inadequate packing violates the warranty.  The warranty will be 
void if, in the opinion of Convergent Design, the product has been damaged through accident, 
misuse, misapplication, or as a result of service or modification performed not authorized in writing by 
Convergent Design.

WARNING: The following are not covered under warranty, and are items for which Convergent 
Design does not accept any responsibility:

1. Damage due to the use of a power supply other than that supplied with nanoFlash or un-
certified batteries.

2. Damage due to overheating conditions.  (The unit will attempt to shut down before damage 
can occur, in the event of overheating.)

3. Damage due to exposure to water.

4. Damage caused by dropping or otherwise roughly handling the unit.
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5. Damage to the internal pins of the CF card slots, which can be caused by jamming the CF 
cards into the slot or applying excess pressure on either side of the CF card during insertion.

6. Damage to any of the connectors caused by rough handling.  Note that the HDMI ports are 
non-locking ports.  If using in a portable application, you will need to secure the connectors 
(such as with a tie-wrap) so as to have a solid connection and so as to not unduly stress the 
HDMI ports.

7. Any loss/ corruption of video/audio data recorded on the nanoFlash, or any loss/ corruption of 
data which is in any way associated with the nanoFlash.

Obtaining an RMA 
It is our policy that all material and repair returns, whether in warranty or not, are only accepted if an 
RMA (Return Merchandise Authorization) number has been issued for the products being returned. 
E-mail Convergent Design, Inc. at “cd” --  “support” -- “at” --  “convergent-design” -- “.com” to obtain 
an RMA number for a faulty unit.  Items must be returned within 10 days of receiving your RMA 
number.  Returned product must be in its original packaging with all contents included and must have 
the RMA number clearly marked on the outside of the package.

RMA numbers and return address may be obtained from Technical Support.

Convergent Design, Inc.

4465 Northpark Drive

Suite 400

Colorado Springs, CO 80907

EMAIL:  “cd” --  “support” -- “at” --  “convergent-design” -- “.com”

WEBSITE: http://www.convergent-design.com

VOICE: ++(720) 221-3861 or ++(866) 654-0080
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Addendum A: Camera Notes (1.6.29)
The nanoFlash has been tested and used with a wide range of SDI and HDMI cameras.  

A few cameras have special considerations for use with nanoFlash:

Canon XL-H1
For most cameras, the nanoFlash can accept the video, audio, and timecode over SDI (including the 
Canon XL-H1 S) .  The original Canon XL-H1, however, does not place the audio and timecode on 
the SDI output.  To record video, audio, and timecode from the camera: 

> the video comes over SDI
> the audio comes from the RCA audio outputs through an adaptor cable (3rd party) to the 3.5 mm analog input 
of nanoFlash
> the timecode comes from the timecode out of camera to the Remote port on the nanoFlash through an LTC 
adaptor cable (sold separately).
Camera modes:

> “I” mode:  interlaced, set nanoFlash Video->Record PSF as Progressive “Off” to record interlaced.
> “F1” mode:  camera outputs PSF (progressive segmented frame, a progressive hybrid), set nanoFlash Video-
>Record PSF as Progressive “On” to record progressive.
> “F2” mode:  camera outputs with pulldown, 1080p23.98 as 1080i59.94.  Set Video->Remove 3:2 Pulldown 
“On” to remove pulldown and record  as the original 1080p23.98 on nanoFlash.

Panasonic HDX-900 / Panasonic HPX-170
When camera is outputting Standard Def video, nanoFlash can not accept the timecode from the 
camera (camera outputs older style VITC timecode in Standard Def), only audio and video.  

With HD recordings timecode is accepted, and all recording modes are compatible with nanoFlash.

See Addendum B “Special Recording Notes” for  discussion of recording 720p at various frame rates.

Sony HDC-1500 CineFlex and other Sony cameras with duel SDI output 
This camera has 2 SDI outputs, the nanoFlash is only compatible with port b output of the camera at 
this time.  Also, the camera can not be set to 1080p50 nor 1080p60, these video formats require both 
SDI outputs simultaneously.  The nanoFlash is compatible with all other formats from this camera.

JVC 700 / JVC 250
When outputting Standard Definition over SDI, the nanoFlash can not accept the signal at this time. 
All HD modes are compatible.  1080P24 Pulldown removal from JVC 700 requires turning the 
nanoFlash on 1st, then the camera, to work properly.

Panasonic Varicam F
At start record, this camera outputs a momentary blanking over SDI, which may cause nanoFlash to 
very briefly lose the input. This can cause a “Lost Source” message on nanoFlash screen to 
continuously appear, but will not effect the recording.  Use the System->Timecode->Trigger Delay to 
avoid this situation, by delaying record start 1 to 2 seconds on nanoFlash (when using TC trigger).

Other cameras / SDI sources / HDMI sources
No other known incompatibilities.  Please test camera with nanoFlash before using.
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Addendum B: Recording Notes (1.6.29)

The nanoFlash auto-detects the incoming video format, and displays this format in the lower left hand 
corner of the LCD screen.  In many cases no special settings are required in the Video menu of 
nanoFlash.  Please note that with the exception of some of the cases listed below, the nanoFlash  
records the incoming video signal as is, the nanoFlash can not change the video format from HD to  
SD or from SD to HD or from 720 to 1080, for example.

Some recording modes have special considerations:

Recording on nanoFlash from the camera's start / stop record 
In most cases, the nanoFlash can be made to start / stop recording from the camera's start / stop 
mechanism.  This is done by the timecode behavior of the SDI input (or LTC input) from the camera. 
In order to achieve this:

> Set camera's timecode to “Record Run”.
> Make sure the camera has its own recording media, and that there is room on the camera's recording media (in 
this mode, nanoFlash will only record while the camera is also recording).
> Set nanoFlash System->Trigger to “Timecode (TC)” or “TC > Last TC”.
> Set nanoFlash System->Timecode->Source to “Embedded” (over SDI) or “LTC” as appropriate.
> nanoFlash should then emulate the camera's record start / stop behavior.  (In “TC > Last TC” mode, the 
camera's timecode must always be increasing from 1 record session to the next)
> Use the nanoFlash System->Timecode->Trigger Delay setting (number of seconds to delay record) to help 
better ensure that the timecodes match between camera recording and nanoFlash recording, as some cameras 
shift the timecode in the 1st second or 2 of recording.  This setting can also help prevent the nanoFlash from 
recording tiny files if the camera unexpectedly moves the timecode (e.g. when inserting / ejecting camera tape).
( Note that HDMI does not carry timecode, this method is not available with HDMI cameras. )

See pg 12 for more discussion of record trigger methods. 

Recording with Pre-Buffer 
The nanoFlash can begin recording 4 to 7 seconds in the past, once the record has started, using the 
option System->PreBuffer.  See discussion on pg 11 for more details.

Recording Progressive 1080p
If you wish to record 1080 Progressive video:

> Make sure the camera is set to a 1080 progressive format.

> In the nanoFlash menu, set Video->Record PSF as Progressive “On”.  In many cases, cameras 
which are set internally to Progressive will output as PSF (progressive segmented frame, a 
progressive / interlaced hybrid).  Setting this nanoFlash menu option will instruct the nanoFlash to 
record as true progressive.

720p is always recorded as progressive, regardless of the above menu setting.

Recording 1080p23.98
Many cameras, when set internally to 1080p23.98, output as 1080i59.94 (with a pulldown).  To record 
on the nanoFlash as 1080p23.98 with the original 23.98 frames per second, set Video->Remove 3:2 
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Pulldown “On”.  The nanoFlash should display “1080pd23” (for pulldown) as the incoming format. 
The full bit rate quality is applied to the 23.98 frames per second.

A few cameras will actually output 1080p23.98, in which case the pulldown removal is not needed.

Note:  Be aware that most cameras, when placed into color bar mode or with status display output 
turned on, do not output a pulldown.  In this case nanoFlash will not lock to the signal.  Also, be sure 
to turn Video->Remove 3:2 Pulldown “Off” in the nanoFlash menu if the camera output does not 
contain a pulldown!

> Do not use this mode in combination with  Pre-Record Buffer (System->PreBuffer), Time-
Lapse, Crank, or 720p60/50 to 30/25.

Recording 720p23.98
Many cameras, such as the Panasonic HDX-900 and the Sony EX3, when set internally to 
720p23.98, output as 720p59.94 (with a pulldown).  To record on the nanoFlash as 720p23.98 with 
the original 23.98 frames per second, set Video->Remove 3:2 Pulldown “On”.  The nanoFlash should 
display “720pd23” (for pulldown) as the incoming format.  The full bit rate quality is applied to the 
23.98 frames per second.

Note:  Be aware that most cameras, when placed into color bar mode, do not output a pulldown.  In 
this case nanoFlash will not lock to the signal.  Also, be sure to turn Video->Remove 3:2 Pulldown 
“Off” in the nanoFlash menu if the camera output does not contain a pulldown!

> Do not use this mode in combination with  Pre-Record Buffer (System->PreBuffer), Time-
Lapse, Crank, or 720p60/50 to 30/25.

Recording 720p29.97 / 720p25
Many cameras, such as the Panasonic HDX-900 and the Sony EX3, when set internally to 720p29.97 
or 720p25, output as 720p59.94 or 720p50 (by duplicating every frame).  To record on the nanoFlash 
as 720p29.97 or 720p25 with the original 29.97 or 25 frames per second, set Video->720p60/50 to 
720p30/25 “On”.  The nanoFlash should display “720h29” or “720h25” (for half-rate) as the incoming 
format.  The full bit rate quality is applied to the 29.97 / 25 frames per second.

> Do not use this mode in combination with  Pre-Record Buffer (System->PreBuffer), Time-
Lapse, Crank, or 3:2 Pulldown Removal.

Recording OverCrank
Overcranking allows for slow motion effect.  Overcranking on the nanoFlash is completely 
independent of any crank settings on the camera, if even set on the camera.

Here are some common examples for overcranking:

For 2.5x slow motion, 720p24:

> set camera to 720p60
> On nanoFlash, in Video->Crank, set checkbox “On”
> On nanoFlash, in Video->Crank, set Record Rate (1st setting) to 24
> On nanoFlash, in Video->Crank, set Crank Rate (2nd setting) to 60

For 2x slow motion, 720p24:

> set camera to 720p60
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> On nanoFlash, in Video->Crank, set checkbox “On”
> On nanoFlash, in Video->Crank, set Record Rate (1st setting) to 24
> On nanoFlash, in Video->Crank, set Crank Rate (2nd setting) to 48

For 2x slow motion, 720p25 (PAL):

> set camera to 720p50
> On nanoFlash, in Video->Crank, set checkbox “On”
> On nanoFlash, in Video->Crank, set Record Rate (1st setting) to 25
> On nanoFlash, in Video->Crank, set Crank Rate (2nd setting) to 50 (max allowed here)

In 1080 recording, Overcranking provides very little leverage as the maximum incoming rate is 30 
frames per second.  The maximum slow motion effect is 1.25x 1080p24, with the following settings:

> set camera to 1080p30
> On nanoFlash, in Video->Record PSF as Progressive, set checkbox “On”
> On nanoFlash, in Video->Crank, set checkbox “On”
> On nanoFlash, in Video->Crank, set Record Rate (1st setting) to 24
> On nanoFlash, in Video->Crank, set Crank Rate (2nd setting) to 30 (max allowed here)

For more details, see the discussion on Cranking on pg 15.

> Do not use this mode in combination with  Pre-Record Buffer (System->PreBuffer), Time-
Lapse, 720p60/50 to 30/25, or 3:2 Pulldown Removal.

Recording UnderCrank
Undercranking allows for fast motion effect.  Undercranking on the nanoFlash is completely 
independent of any crank settings on the camera, if even set on the camera.

Here are some common examples for undercranking:

For 2x fast motion, 720p24:

> set camera to 720p60
> On nanoFlash, in Video->Crank, set checkbox “On”
> On nanoFlash, in Video->Crank, set Record Rate (1st setting) to 24
> On nanoFlash, in Video->Crank, set Crank Rate (2nd setting) to 12

For 4x fast motion, 720p24:

> set camera to 720p60
> On nanoFlash, in Video->Crank, set checkbox “On”
> On nanoFlash, in Video->Crank, set Record Rate (1st setting) to 24
> On nanoFlash, in Video->Crank, set Crank Rate (2nd setting) to 6

For 5x fast motion, 720p25:

> set camera to 720p50
> On nanoFlash, in Video->Crank, set checkbox “On”
> On nanoFlash, in Video->Crank, set Record Rate (1st setting) to 25
> On nanoFlash, in Video->Crank, set Crank Rate (2nd setting) to 5
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For more details, see the discussion on Cranking on pg 15.

> Do not use this mode in combination with  Pre-Record Buffer (System->PreBuffer), Time-
Lapse, 720p60/50 to 30/25, or 3:2 Pulldown Removal.

Recording Time-Lapse  (hh:mm:ss)
Time-Lapse allows for delayed recording effect (super fast motion).  Some common examples:

To record 1 frame per second:

> On nanoFlash, in Video->Time-Lapse, set checkbox “On”
> On nanoFlash, in Video->Time-Lapse, set time to 00:00:01

To record 1 frame every 5 seconds:

> On nanoFlash, in Video->Time-Lapse, set checkbox “On”
> On nanoFlash, in Video->Time-Lapse, set time to 00:00:05

To record 1 frame per minute:

> On nanoFlash, in Video->Time-Lapse, set checkbox “On”
> On nanoFlash, in Video->Time-Lapse, set time to 00:01:00

For more details, see the discussion on Time-Lapse on pg 15.

> Do not use this mode in combination with  Pre-Record Buffer (System->PreBuffer), Cranking, 
720p60/50 to 30/25, or 3:2 Pulldown Removal.

Recording Standard Definition
The nanoFlash can record a Standard Definition signal, NTSC or PAL, the signal is recorded as IMX 
50, 40, or 30 Mbit in .MXF or .MOV, and is accepted by NLE's.   Standard Definition can also be 
recorded as .MPG at 3,5,6,7,8, or 9 Mbit.

Other Recording Modes (1080i50/60, 720p50/60)
No special settings required.

Using Hot Swap During Record (ver1.6.226)
An inserted CF card may be pulled from it's CF slot during Record if the card is not being recorded to. 
(The CF card which is actively being recorded to:  will have a flashing red indicator. )  

A CF card may also be inserted to an empty CF slot during record to facilitate lengthy records, with 
the following considerations:

> It is preferable that such a CF card inserted during record was formatted on a nanoFlash.
> However, such a nanoFlash-formatted card may contain previously recorded video. 
> A CF card inserted during record may also be from a formatting on a computer in a 
compatible FAT32 formatting (please test first, ahead of time, that a computer-formatted card is 
accepted by the nanoFlash).  
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> As always,  if any files are manually deleted from or copied onto a CF card from a computer,  
the card must be formatted again before use for recording in nanoFlash.

“Skip to Next File” / “Skip to Next Card” During Record (ver1.6.226) 
“Skip to next file” during a record session by pressing the RECORD button once.  The current file will 
be closed and a new file started (without losing any data).
“Skip to next card” during a record session by pressing the RECORD button twice in quick 
succession.  The nanoFlash will close the current file, jump to the next card, and continue recording 
without losing any data,  assuming another card is inserted with recording space available. If there is 
no space available on the next card,  the nanoFlash will simply perform a “Skip to next file” instead in 
this case.  Note:  when using “Skip to Next Card”, allow 5 to 10 seconds for the recording to transfer  
to the other card before attempting to remove original card – you can watch the CF cards' status  
lights to determine when the transition has completed, as the card being recorded to will have a  
flashing red light indicator.

Addendum C:  Monitoring  Notes (1.6.29)

During Record or Idle mode, the nanoFlash sends the incoming signal back out the SDI and HDMI 
ports for monitoring.  

Here are some points to consider for monitoring the output from the nanoFlash:

SDI output monitoring
SDI out monitoring has 2 modes:

-- E to E monitoring (Video->E to E Direct):  the input is sent directly to the SDI output.  Use E to E:
> when going to an SDI monitor which does not support 1080 progressive.  In this case the nanoFlash 
will output a 1080 PSF signal as PSF.
> when using any special modes on the nanoFlash such as Time-Lapse, Crank, Remove 3:2 Pulldown, or 
720p60/50 to 30/25.  E to E will increase the likelihood of monitor compatibility.  
> when using Video->Record Tally option.

Advantages of E to E:
> No delay.
> Broader monitor compatibility.

Disadvantages of E to E:
> Only Embedded data will be sent through the output (not analog audio / internal or LTC timecode).  
However, if the combination of analog audio and LTC timecode are selected, these will be placed on the  
SDI output in E to E mode along with the embedded video.

-- Non- E to E monitoring:  If E to E is turned off, the input is sent to the SDI output after internal processing of 
the video / audio / timecode.  
Advantages:

> Gives a more comprehensive picture of what the nanoFlash will record as it will always include the 
video / audio / timecode, and the video will be in the format that is to be recorded.

Disadvantages:
> approximate 4 frame delay.
> Less monitor compatibility.
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HDMI output monitoring
From an HDMI input, HDMI output is always E to E (see discussion above).
From an SDI input, HDMI output is based on the Video->E to E setting.
HDMI output does not support Standard Definition at this time.

Addendum D:  Playback  Notes (1.6.29)

During playback off of the CF cards, the nanoFlash sends the signal from the CF cards out the SDI 
and HDMI ports.  Standard Definition playback is only supported out of the SDI port.  Additionally, 
720p24 / 25 / 30 are not supported for playback at this time.

Here are special notes to consider:

Video->Play Progressive as PSF 
Use this mode:

> when playing to an SDI or HDMI monitor which does not support 1080 progressive.

Do not use this mode:

> when playing 1080p23.98 to an HDMI monitor.  

> when true progressive is desired as the output.

Limitations of Playback 
> Can not play 720p24, 720p25, or 720p30 off of CF cards.

> Can not play Standard Definition video out of the HDMI port.
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Addendum E:  Viewing Options
Recorded  file format is set in System->File Format, as Quicktime (MOV), MXF, or MPG.
In general, Quicktime has wider compatibility on the Mac, MXF on the Pc.

To view nanoFlash Quicktime files on the Mac:  
> from Quicktime Player with Final Cut Pro 6.0.3 or better installed. (HD/SD files)   Note:  for better 
results, use Quicktime Player 7.x.x, rather than Quicktime Player X (10), which is the default player in 
Mac OS 10.6 .  Quicktime Player 7 is a separate install on the Mac 10.6 .  (ver1.6.245)
> If Final Cut Pro is not installed:  from Quicktime Player with Calibrated Software's XD Decode (HD 
files):  http://calibratedsoftware.com/QXD.asp

To view nanoFlash Quicktime files on the Pc:  
> from Quicktime Player with Calibrated Software's XD Decode (HD files) :

http://calibratedsoftware.com/QXD.asp
> from Quicktime Player with Calibrated Software's IMX Decode (SD files) :

http://www.calibratedsoftware.com/QIMX.asp

To view nanoFlash MXF files on the Mac:  
> Sony XDCAM Transfer software (combined with Final Cut Pro 6.0.3+ or Calibrated XD Decode):

(international link for XDCAM Transfer) : 
http://www.sony.co.uk/biz/content/id/1166605189229

(US link for XDCAM Transfer) :
https://servicesplus.us.sony.biz/sony-software-model-PDZKP1.aspx

> From Quicktime Player with Calibrated MXF Import (with Final Cut Pro or Calibrated XD Decode):
http://calibratedsoftware.com/MXFImport_Mac.asp

> VLC Media Player: http://www.videolan.org/vlc
> MXF4Mac (also for editing in Final Cut Pro) :  http://mxf4mac.com/

To view nanoFlash MXF files on the Pc:  
> Free Sony XDCAM Viewer software:  please note that the video display of XDCAM Viewer in 
Windows 7 is poorer than XDCAM Viewer in other Windows versions such as Windows XP, owing to 
reasons not related to the actual video quality.

(international link for XDCAM Viewer) : 
http://www.sony.co.uk/biz/content/id/1166605189229

(US link for XDCAM Viewer) :
https://servicesplus.us.sony.biz/sony-software.aspx?model=PDZVX10

> VLC Media Player: http://www.videolan.org/vlc
> Open Cube: http://www.opencubetech.com/

nanoFlash MXF files (50 Mbit HD, 50 Mbit SD only (ver1.5.126) ) are also now compatible with XDCAM Optical 
Equipment.  The “Free” naming convention may need to be set on the XDCAM equipment to accept nanoFlash 
files.  Note:  XDCAM Optical equipment will only import files greater than 2 seconds in length.  

To view MPG files on the Mac:  use VLC Media Player or Quicktime Player.
To view MPG files on the Pc:  use VLC Media Player. 

** See NLE Compatibility (Addendum G), for more viewing options.
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Addendum F:  Other Software Accessories (ver1.6.226)

Free QT → MXF Converter (XDCAM EX or XDCAM 422 .MOV Files only) – also converts edited 
.MOV files for play from nanoFlash, and makes non-fragmented file copies back to CF cards: 

FileConverter 1.6 for Mac
FileConverter 1.6 for Pc    (Pc version may also require Java Runtime Environment )

Free MXF → QT Converter (XDCAM 422 .MXF Files only, 50 Mbit and above, at least 2 channels 
audio (ver1.5.126)) (Mac version only):  Sony XDCAM Transfer (combined with Final Cut Pro 
6.0.3+ or Calibrated XD Decode, see link above) – also for importing MXF files 50 Mbit and above 
into Final Cut Pro:  (720p24 / 25 / 30 supported only with Calibrated) (ver1.5.126)

(international link for XDCAM Transfer) : 
http://www.sony.co.uk/biz/content/id/1166605189229
(US link for XDCAM Transfer) :
https://servicesplus.us.sony.biz/sony-software-model-PDZKP1.aspx
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Addendum G:  NLE Compatibility 

All nanoFlash recorded bit rates 50 Mbps and above will typically appear in NLE's with a 50 Mbps 
label.  However, all files are decoded / played out from their actual recorded bit rate.  At this time, 
rendering / re-encoding of edited footage from the timeline is always forced to 50 Mbps (within NLE's 
which support re-encoding of edited footage), regardless of the bit rate of the originally captured 
video.  Also, support for true frame rates (true 24, 30, 60) is limited in most NLE's.  (ver1.5.31)

Final Cut Pro (6.0.3 or better)
FCP supports decode/ playback of all nanoFlash files generated as QT files.  A timeline may be 
created for the nanoFlash files (50 Mbps and greater) in Final Cut Pro under the Easy Setup “XDCAM 
HD 422”.  Rendering / re-encoding (to 50 Mbps only) is also supported.
See tips below for editing shortcuts with Final Cut Pro and Long-GOP MPEG2.
Standard Def video is supported as IMX 50 Mbit.
True frame rates, as well as 720p24/25/30, are supported for decode only.  (ver1.5.31)

Avid Media Composer (3.1.1 or better) 
I-Frame only formats are supported (MXF files).
Long-GOP formats up to 50 Mbit are supported.  (Also 80 Mbit appears to be supported (ver1.5.31).)
Long-GOP  100 Mbit and above is not yet supported.
Standard Def is supported.
Video formats 720p24 / 25 / 30:  not supported at 50 Mbit or above. (ver1.5.31)
With the release of Media Composer 5.0.3.2 patch or greater, support has been added within Avid for 
AMA linking to nanoFlash MXF files (HD files only – SD files can only be brought into Avid using the 
File->Import method).  This allows direct access to files without the need to import (copy in) the files. 
Within Avid, this is accessed in the Avid menu File->Link to AMA Files.  Patch 5.0.3.2 or greater can 
be found in the Avid download center.  (ver1.6.226)
For Media Composer 5.5 or greater, to use the AMA feature with nanoFlash MXF files requires 
installation of Avid's AMA MXF plug-in, available here:
http://www.avid.com/US/products/Avid-Media-Access/plug-ins
Partial to full support of .MOV files with the Calibrated XD Decode Plug-in (see Addendum E).

Sony Vegas (8.0c or better): 
All Long-GOP formats are supported (MXF files).  The previous bug in which Vegas displayed 2 
green frames at the start of every file has been fixed.  (ver1.6.226)
I-Frame only files are supported in version 9.0c or better.
Standard Def is supported.
(Audio is not accepted in the initial release of Vegas 9, but all other versions accept audio.  Also, 
Vegas requires a minimum of 2 channels audio.)  (ver1.5.31)
With “true” NTSC frame rates (exactly 24,30, or 60 frames per second), Vegas will not play the audio 
in these files.  (ver1.6.226)
Partial to full support of .MOV files with the Calibrated XD Decode Plug-in (see Addendum E).

Edius 5:  
all MXF files supported.
Partial to full support of .MOV files with the Calibrated XD Decode Plug-in (see Addendum E).
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Edius 6:  
Initial release of Edius 6 does not support nanoFlash MXF files.  Later releases do support nanoFlash 
MXF files.  
Partial to full support of .MOV files with the Calibrated XD Decode Plug-in (see Addendum E).

Matrox Axio: 
Likely all MXF files play on Matrox Axio systems.

Adobe Premiere CS4 / CS3: (PC version) 
with MainConcept MPEG Pro XDCAM plug-in (4.1.1 or better), supports all nanoFlash MXF files:
http://69.15.88.17/downloads/MainConcept.pdf
http://www.mainconcept.com/products/apps-plug-ins/plug-ins-for-adobe/mpeg-pro-hd-cs-4.html
Partial to full support of .MOV files with the Calibrated XD Decode Plug-in (see Addendum E).

Adobe Premiere CS5: 
native support for MXF files. 
Audio and timecode incompatibility exists in the initial CS5 releases, and was repaired in 5.02 .
Also, rare memory leaks on computers may occur when using CS5 5.0.2 or 5.0.3 with nanoFlash 
MXF files.  (This has been addressed with the release of CS5 5.5 . )
Partial to full support of .MOV files with the Calibrated XD Decode Plug-in (see Addendum E) and the 
Calibrated XML patch (for CS 5.03 or greater, also applies to After Effects):
http://www.calibratedsoftware.com/downloads/AdobeCS503XMLpatchv1.zip

Cineform NeoXX (5.2.0 or greater) :   (ver1.6.226) 
Native support for transcoding MXF files.

Please test compatibility with your system before using the nanoFlash.

Final Cut Pro Editing Techniques
Final Cut Pro  has a shortcut to help minimize rendering when editing MPEG2 natively. Here are the 
steps to achieve this with XDCAM HD 422 footage:

1. Set up a sequence / timeline as XDCAM HD 422
2. In Final Cut Pro (6.0.2 or greater) -> User Preferences -> Render Control, set the CODEC to 

ProRes
3. Drop your Quicktime clips directly into the timeline (you do not need to transcode first) for 

editing
This will render only the effects in your sequence using the I-Frame-Only ProRes 422 CODEC.  Areas 
of the timeline which do not have effects applied are unaltered.  Your sequence is not re-encoded 
back to MPEG2 long GOP, in this case.

MPG support
Partial to full support in Nero, Final Cut Pro's DVD Studio, Adobe Encore, Edius, Sony Vegas, Roxio 
Toast Titanium.
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Addendum H: Managing Your Menu Settings / Menu Tree (ver1.6.226)

Menu settings on the nanoFlash may be saved and restored.
> To save your current settings, use the System->Create Menu.stg option to a blank or formatted CF 
card.   The file is written into a }CFG{ folder.   Up to 20 settings files may be created on a single card.
> To restore your settings, insert a CF card which contains a }CFG{  folder with up to 20 Menu.stg 
files within this folder.  (The prefix “Menu” in Menu.stg may be renamed  as you prefer. ) You will then 
be prompted to choose which setting to restore.   It is preferable to use the same firmware version on 
nanoFlash for saving and restoring a given setting.  Pre-configured settings will be made available for 
download on our website.
> During a restore, all settings will be restored except the Unit Id (the 1st 2 digits in the System->File= 
option) and Clip Number (next 3 digits), which are always preserved and must be changed manually.
> A saved setting can be restored to multiple units.

The complete nanoFlash menu tree is listed below with brief descriptions:

- System
 -- Time [HH:MM:SS]
 -- Date [Year:Month:Day]
 -- Max File Size [20 to 100%]
 --  File= [Unit ID] [Clip] [File] . [File Type: MOV, MXF, or MPG]
 -- Trigger [Multiple options to initiate record]
 --  Duration [Special mode, if activated: stop each record after HH:MM:SS period]
 -- Timecode
 --- Source [Timecode source: Embedded SDI, LTC Remote, Internally generate, etc]
 --- Dropframe [For internally generated timecode only: set dropframe]
 --- Seed [For internally generated timecode only: set Seed value]
 --- Trigger Delay [In seconds, delay record start with Timecode Trigger]
 -- Source [Video input source:  SDI or HDMI]
 -- Format Cards [Format (Erase) all inserted cards]
 -- Prebuffer [Special mode, if activated:  start record 4 to 7 seconds in the past]
 -- Power Saving
 --- Auto-Sleep [if activated:  if SDI input is off:  low power mode]
 --- Auto LCD Off [if activated: LCD Screen light off when possible]
 -- Create Settings.txt [Diagnostic tool, dumps all settings to CF card]
 -- Restore Defaults [Restore factory settings, useful for troubleshooting]
 -- Create Menu.stg [Save settings to a CF card (which can be later restored) ]
 -- About [Current Firmware version]

- Video
-- Bit Rate

--- CF HD Rate [Record Mbits per second, range varies based on Codec and File Type]
--- CF SD Rate [Record Mbits per second, range varies based on File Type]

-- Record PSF>Prog [Record Progressive from a Progressive Camera/Source]
-- Play Prog>PSF [Play from CF cards as PSF for PSF monitors]
-- Remove Pulldown [Special mode,1080i60 pulldown to 1080p24, 720p60 pulldown to 720p24]
-- 720p60/50>30/25 [Special mode, Record 720p60 as 720p30, or 720p50 as 720p25]
-- SD Aspect Ratio [Record SD video as 16:9 or 4:3]
-- E to E Direct [Loop output directly from input, before processing]
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-- T-Lapse [Special mode, Record 1 frame every HH:MM:SS period]
-- Crank [Special mode, slow/fast motion effect based on:  Record rate, Crank rate]
-- HDMI Rx Color [HDMI input only:  Full or Legal]
-- 35Mb Width [35 Mbit or below HD 1080 recording only: set width to 1920 or 1440]
-- Screen Tally [Place red bar on output to indicate record in progress]
-- Flip V [Vertically invert the image for recording] [HD only]
-- Flop H [Horizontally invert the image for recording] [HD only]
-- 3D [See “nano3D” Addendum for more details]

--- Enable [Enable 3D functionality (Master 3D unit only) ]
--- Combine [Combine left/right images for monitoring/record/playback]
--- Record Combined [Record left/right images combined as a single clip on Master unit]
--- Play Ref [For 3D:  Ext (External) on Master, Int (Internal) on Slave]
--- Frame Shift [Shift left image, right to left, specified number of pixels]

- Audio
-- In [Audio input source:  Embedded SDI/HDMI or Analog port]
-- Analog Settings

--- Mix in [Mono or Stereo]
--- Gain in [-99 to +44 dB]
--- Gain out [.3959 to 1.1430 dB]

-- Record Channels [HD Record 0,2,4, or 8 channels audio (SD is always 2 channel) ]
-- Monitor Channels [For headphone output:  channels 1&2, 3&4, 5&6, or 7&8]

− Play [Choose file from CF card to begin Play]
− Loop Play [Set Play to Loop all files]
− Cue Play [Special mode, Remote Play, cue to selected timecode then Play]
− Loop Record [Special mode, continuous record, overwrite cards as necessary]

Addendum I: nanoFlash Serial RS232 Remote Control  (ver1.6.226)

Introduction
The nanoFlash can be controlled externally, from the Remote port with a cable connected to a custom 
Rs232 controller (the controller is not provided by Convergent Design) .  An add-on cost is associated 
with activating this functionality.  Please contact our Sales or Support department if you are 
interested.
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Addendum J: nano3D (ver1.6.226)

Introduction
The nano3D combines the complete functionality of 2 nanoFlashes with 3D monitoring, recording, 
and playback capabilities to produce a versatile, portable, high quality, and low power HD 3D recorder 
for use with 3D camera rigs.  The nano3D draws under 12 Watts of power.

The nano3D is an add-on purchase, and requires 3D activation of the Master unit.

The nano3D may be acquired as a complete package, or 2 nanoFlashes in the field can be converted 
to nano3D (see “nanoFlash to nano3D Upgrade” Addendum).

If the nano3D nanoFlashes are separated and used for individual 2D recording, do not use the 
nano3D firmware.  Load the latest nanoFlash firmware from the website for individual 2D recording. 
After changing between 3D and 2D firmware, perform a Restore Defaults (System->Restore 
Defaults).   Also, do not use the 3D Remote cable on an individual nanoFlash for 2D recording.

Please Register your nano3D by sending an e-mail to "cd” – “support” – “at” – “convergent-
design” – “.com” with your name and the serial number off the right side of both units of the nano3D, 
and where the nano3D was purchased. You will get automatic notice of firmware updates and service 
bulletins. Please take a moment to do this, to provide a better user experience with nano3D.

Shipping Contents
Your nano3D shipping container should have come packaged with the following:

1. nano3D recorder/player
2. remote trigger/LTC input/communication link split Y-cable
3. Single remote cable attachment  (attach to remote Y-cable)
4. 9 inch HDMI cable (type C (mini) to type C)
5. Power supply split Y-cable
6. Dual  power supply  (100 to 240 VAC Input: 12V DC @ 2A Output) (attach to power Y-cable) 
7. USB Reader (for CompactFlash cards)

The following topics are discussed further below, but a couple of important reminders:  

> wait at least 5 seconds between 1 Record session and the next, and wait at least 5 seconds 
between 1 Play session and the next.  You must allow 30 seconds to switch from Record to Play 
mode (by pressing the Play button on the Master unit, which places both units in Play mode), and you 
must allow 30 seconds to switch from Play to Record modes (by pressing the Record button on the 
Master unit, which places both units in Record mode).  If a sufficient amount of time is not allowed, 
the Master and Slave may get out of sync with respect to each other.

> When switching modes, or on start-up, you may see a temporary “Stream Mismatch” message 
while the units are locking to the video.  Unless the “Stream Mismatch” message is continuous, the 
message may be safely ignored.

> When combining, on rare occasions HDMI does not lock properly from Slave to Master, or on rare 
occasions the colors in the video may be inverted from the Slave to the Master over HDMI – to 
address either of these cases, or if the output does not look correct, simply pull and re-insert the 
HDMI input to the Master unit to allow the HDMI port to reset.
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The Essentials (Quickstart) : nano3D Monitoring/ Recording/ Playing 
In addition to the basic operating instructions for nanoFlash (see pg 5):   for nano3D:

(Master unit = top unit = left eye, Slave unit = bottom unit = right eye)
(Master unit is 3D activated (through activation procedure) and enabled (Video->3D->Enable) (Slave 
unit is not 3D enabled)

1. Ensure that Master and Slave units have identical firmware (System->About)
2. Connect the HDMI output from the slave (bottom) unit to the HDMI input of the master (top) 

unit with the included HDMI 9 inch cable.
3. Connect the 'right eye' camera to the SDI input of the slave unit
4. Connect the 'left eye' camera to the SDI input of the master unit
5. Gen-lock both cameras together and ensure that both cameras are outputting the same video 

format (can be checked by looking at the status line of each nanoFlash).  When gen-locking, 
use tri-level sync for 24p, bi-level sync for other video formats.  If the Combine option 
(described further down) is used, the nanoFlash will check for gen-lock, and continuously 
display a “Stream Mismatch” error message if the cameras are not gen-locked.  Ignore any 
temporary “Stream Mismatch” messages – this is only a problem if displayed continuously.

6. Be certain that Image Stabilization is turned off on both cameras.  Image stabilization can 
negatively effect camera sync when panning or zooming the cameras

7. Connect power Y-cable to both units
8. Connect power source to power Y-cable (if not already connected)
9. Before connecting the 3D Remote Y-Cable, ensure that the Master unit's Video->3D->Enable 

setting is selected.  The Remote cable can only be used if the Master unit is already in 3D 
mode (by selecting the Enable setting).  Do not use the 3D Remote with 2 separated  
nanoFlashes which are in 2D mode. 

10. Connect the remote Y-tally to both units, attaching the connector with a red ring around 
the base to the master unit, and the connector without a red ring to the slave unit.

11.  Connect remote tally to remote Y-tally (if not already connected).  Note that you must 
use the Remote tally in 3D mode for synchronized starting and stopping (record and 
playback). 

12.  Setting up Master and Slave units for 3D Record/Play:

 Slave Unit has the following critical items which are set independently of the Master unit:
◦ System->File=  : The 1st 2 digits are Unit Id, set to “R1” or something similar to 

indicate right eye recording for Slave unit.  The remainder of “File=” setting should 
match Master unit's “File=” setting.  (Note:  do not use .MPG)

◦ Video->Flip V : set as appropriate for Slave unit.
◦ Video->Flop H: set as appropriate for Slave unit.
◦ Video->3D->Enable: leave Slave unit's 3D option not enabled (un-checked).
◦ Video->3D->Play Ref:  set to “Int” (internal) for Slave unit.

All other 3D settings (settings in the Video->3D menu) on Slave unit can be safely ignored and 
left as default values.
All other non-3D settings on Slave unit should match Master unit exactly.

Master unit has the following critical items which are set independently of the Slave unit:
◦ System->File=  : The 1st 2 digits are Unit Id, set to “L1” or something similar to 

indicate left eye recording for Master unit.  The remainder of “File=” setting should 
match Slave unit's “File=” setting.  (Note:  do not use .MPG)
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◦ Video->Flip V : set as appropriate for Master unit.
◦ Video->Flip H: set as appropriate for Master unit.
◦ Video->3D->Enable: leave Master unit's 3D option enabled (checked).
◦ Video->3D->Combine:  set as preferred, applies to live/record SDI output and 

Playback SDI output from Master unit.  With this option enabled, the nano3D will 
verify that the inputs are gen-locked, and if not, a “Stream Mismatch” error message 
is continuously displayed.  (Start-up error messages of this type can be ignored.)

◦ Video->3D->Record Combined:  if selected, the Master unit will record the Left/Right 
eye video together onto the Master unit, based on the “Combine” setting above.  If 
de-selected, the Left and Right eyes will be recorded independently, left eye to the 
Master unit and right eye to the slave unit.

◦ Video->3D->Play Ref:  set to “Ext (HDMI)” for Master unit to play Combined from a 
recording of separated left/right eye to Master/Slave.  Set to “Int” (internal) for 
playing a Combined Record off of the Master unit.

◦ Video->3D->Frame Shift:  For use in Side by Side Combining only, for viewing 
purposes only (not recorded), shifts the Left (Master) eye from right to left by number 
of pixels.  The Right Eye picture is cropped corresponding to the Left Eye shift.

Both units:  critical (matching) items:  these settings must be identical on both units:
◦ Set the Source to SDI (System->Source)
◦ Ensure that both units have System->File= matching (except for the 1st 2 digits, 

which are the Unit ID).  In particular, make sure the Clip number (middle 3 digits) and 
file type (MOV, MXF) match.  (The last 3 digits, File number, always start at 001 for a 
given Clip. )

◦ To place both units into Record Ready mode:  press the Record button on the 
Master unit, which will automatically place both Master and Slave into Record mode 
(if Video->3D->Enable is selected in the Master unit).  Wait for the “Slave Mode Ok” 
message and all other mode-switching messages to be completed on the Master 
unit to indicate that both units have switched modes  (up to 30 seconds).  Ignore any 
temporary “Stream Mismatch” messages – this is only a problem if displayed 
continuously.    Alternatively, manually set both units, System->Trigger to “Remote 
Record”.

◦ For Record, be sure to select Video->Record PSF as Progressive on both units if 
you wish to record Progressive.

◦ To place both units into Play Ready mode: press the Play button on the Master unit, 
which will automatically place Master and Slave into Play mode (if Video->3D-
>Enable is selected in the Master unit).  Wait for the “Slave Mode Ok” message on 
the Master unit to indicate that both units have switched modes  (up to 30 seconds). 
Ignore any temporary “Stream Mismatch” messages – this is only a problem if 
displayed continuously. Alternatively, manually set trigger setting to “Remote Play” 
on both units.

◦ For Playback:  assure that the Video->Play Progressive as PSF setting is set 
appropriately and is matching on both units.

◦ For Playback:  if you choose a file to begin Play in the Play menu, choose the same 
file on the Master and Slave units, and  it is  recommended to select files which end 
in “001” (the 1st file in a clip for long records) .  File skipping and Fast Forward 
options are disabled in 3D.

◦ Set both units, Codec to I-Frame (Video->Codec) and Bit rate (Video->Bit Rate->CF 
HD Rate) as preferred.
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◦ Video->E to E:  (For live/ record output only, Master/Slave must match ) May be 
selected or de-selected as preferred.  If de-selected, Flip functions (Flip V / Flip H) 
will not carry through to the SDI output for display (but will be recorded).  Combining 
functions will carry through to the SDI output for display regardless of this setting.

13.  Other points to consider:
◦ When initially using Combining,  you will normally see a “Slave Mode Ok” message 

on the Master to indicate when both units are ready to record or play.  This can take 
up to 5 to 10 seconds.

◦ To use the Remote for Record:  press the remote button (quick tap) once to engage 
record of both units (provided that both units are in a Record Ready state, displaying 
the Record Ready symbol “>||” on the screen, and all warning / start-up messages 
have ceased).  To stop record of both units:  press and hold the remote button for 
approximately 1 second, til the tally light flashes off and back on for a brief moment; 
at that time the remote button can be released.   After stopping a record, wait at least 
5 seconds before initiating a new Record.

◦ To use the Remote for Play: For play, press remote button once to start play, twice in 
rapid succession to stop play.  After stopping play, wait at least 5 seconds to start 
play again.

◦ For recording 1080p24 from sources with a Pulldown:   Combining function must be 
enabled (Video->3D->Combining) to ensure the 2 video streams have a matching 
pulldown pattern.  The 3:2 pulldown cadences must match from the 2 cameras (a 1 
in 5 probability) .  Otherwise the nano3D units will not lock to the incoming video. 
Turn 1 camera off and back on until the cameras' pulldown cadences matches 
exactly (meaning the nano3D units lock to the video).  (Allow 10 seconds with each 
attempt for the nano3D's to lock to the video. ) 

◦ For playing 1080p24 video in a combined mode: de-select the option Video->Play 
Progressive as PSF in both units.

◦ For saving and restoring settings (System->Create Menu.stg), it is recommended to 
create and restore separate settings files for the Master and Slave units.  Separate 
settings files for the Master and Slave units will be posted on our website.

◦  If the error message “Master/Slave input formats do not match” appears:  the left / 
right eye video inputs must match exactly.  The following can cause such an error:
▪ non-genlocked cameras, or cameras set to different outputs
▪ PSF settings don't match on Master/Slave (Video->Record PSF as Progressive)
▪ E to E settings don't match on Master/Slave (Video->E to E)
▪ 24p pulldown sequence not matching from cameras (see discussion above)

14.  Modes to avoid in 3D:  (have not been tested)
◦ .MPG file format (System->File=)
◦ Standard Def recording 
◦ Long-Gop codec not recommended, more difficult post-processing (Video->Codec)
◦ CuePlay, Loop Record 
◦ Prebuffer (System->Prebuffer)
◦ Duration (System->Duration)
◦ Timelapse (Video->TimeLapse)
◦ Cranking (Video->Crank)
◦ Combining 720p24, 720p25, or 720p30:  not supported (recording separate left/right 

eye is supported in these formats)
15.Enjoy high-quality 3D video!
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nano3D Monitoring / Recording / Playing: Recommended Menu Settings

Unless otherwise indicated, recommended settings below apply to both Master and Slave units.

Settings files can help to manage your settings (System->Create menu.stg ).  Settings files for Master 
and Slave units in various configurations will be posted on our website.

System Menu

Time and Date: Set to current time
Max File Size: Typically set to 100% (creates maximum ~4 Gbyte files), may be lower, as desired
Filename:  For 3D 

First two digits (Set in Master and Slave unit independently), suggested:
1L (Top unit, Left Eye, Camera 1), 1R (Bottom unit, Right Eye, Camera 1)
Next three digits: Clip Number, start at 001 for a new project
Next three digits: File Number within clip (Set automatically to 001 for each Take)
“.MOV” for Quicktime for Final Cut Pro, 
“.MXF” for the Adobe, Avid, Sony Vegas, Edius and others.

Trigger: For Live View and Recording: “Remote record” (Must not be “Record&Remote”)
For Playback: “Remote play” (In Playback Mode, the “Live View” will not be shown on the 
monitor.) Use the Record and Play buttons on the Master unit to automatically switch both units 
back and forth between Record/ Play modes, as needed (may take up to 30 seconds, ignore 
“Stream Mismatch” message unless the message is continuous, and watch for “Slave Mode Ok” 
message on Master).  Use Remote tally to actually start / stop record or play.
(Note: If the nano3D is set for “Remote play”, then the record control will start “Playback” and 
not start “Recording”. In “Remote play” the “Live View” from the camera is not shown on the 
monitor, and this is an indication that one cannot press the remote control to start recording.)
When the nano3D is set for “Remote Record”, then the “Live View” will display on the monitor.
To use the Remote tally:  press the remote button  (quick tap) once to engage record, 
press and hold for 3 seconds to stop both units.  For play, press remote button once to 
start play, twice in succession to stop play.
Note:  Remote tally light is solid red during record, and will begin flashing when 5 
minutes or less of record time is remaining.

Duration: Not for use in 3D mode
Timecode: As appropriate, depending on source of timecode
Source: For 3D: set to SDI
Format Cards: Format (erase! ) the cards in the nanoFlash.
Prebuffer: Must be Off for 3D, as desired for 2D.
Power Saving: Auto Sleep, ok to use in 3D mode.
Create Settings: Do not use if you have footage on the CompactFlash card or cards.

Activate this function, which saves your current settings, 
only with a freshly formatted card.

Create Menu.stg: Useful for saving (and later restoring) settings.  During Restore, all settings except Unit 
ID and Clip Number (System->File= ) are restored.

Restore Defaults: Recommended to be performed after installing new firmware.
Manually configure your nanoFlash or nano3D after restoring the defaults.

About: Current Firmware Version.  Master and Slave units must match firmware versions.
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Video Menu

Codec: For 3D use I-Frame, as desired
For non-3D, above 100 Mbps use I-Frame, 100 Mbps and below use Long-GOP.

Bit Rate: For 3D:  140 or above recommended
Record PSF>Prog: Must be checked for 29.97p or 30p

    Must not be checked for Interlaced sources
    Does not need to be checked for 23.976 or 24, as the nanoFlash automatically

                  sets this internally for these frame rates.
Note: If this is set correctly, the Frame Rate Display on the last line of the nanoFlash 
LCD will match your camera’s setting. 
If not, your nanoFlash settings are incorrect.

Play Prog>PSF: Must be checked if monitor requires PSF and Playing a Progressive recording.
Play Prog>PSF should be de-selected, on both units, 
for 3D monitors or televisions that support 1080p.
Play Prog>PSF should be selected, on both units, 
for 3D televisions that require an interlaced (or PSF) signal.
Explanation: Some 3D monitors will support 1080p23.976 (24) and 
1080i59.94 (60) (or 1080i50), but not support 1080p29.97(30)
If Play Prog>PSF is checked, then PSF is output and the 
monitor or television sees a 1080i59.94 (60) or 1080i50 signal.
Do not check if playing 1080p24 combined – PSF is not supported for 1080p24 
combined playback.

Remove 3:2 Pulldown: Check if Pulldown is to be removed prior to recording
720p 60/50>30/25:       Check if camera is in 720p30 or 720p25 mode and outputting 720p60 or 720p50 
SD Aspect Ratio:   As appropriate, does not apply to 3D
E to E Direct: Check if working with a PSF source and Record PSF>Prog is checked 

and monitor requires a PSF signal (and cannot accept true progressive) 
T-Lapse: Timelapse, as appropriate, must not be checked for 3D. 
Crank: As desired, must not be checked for 3D. 
HDMI RX Color: HDMI input:  Set to Full for Full Color or Legal for Legal Colors only
35 MB 1080 Width:  Set to 1920, or 1440 to create 1440 x 1080 footage to match Sony PDW-350 

camera
Screen Tally: As desired, when checked a Red Line (Tally Bar) will appear on the HD-SDI output 

when recording.
Flip V: (Set in Master and Slave unit independently) Check this to Flip the “Left Eye” image 

vertically, for “Live View” and “Recording”.  (Does not impact playback.)
Flop H: (Set in Master and Slave unit independently) Check this to Flip the “Left Eye” image 

horizontally, for “Live View” and “Recording”.  (Does not impact playback.)

Video|3D:

3D Enable: When working in 3D, check this on the Master nanoFlash, which is the top unit, 
which is the “Left Eye”. This can only be set if the unit is authorized for 3D.
The Master unit must have 3D Enable selected before the 3D Remote Y-Cable is 
connected to the Master and Slave units.  The 3D Remote is only for 3D use.
The Slave unit should always have this setting disabled.
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Combine: (set in Master unit only) 
The nano3D can combine two camera images and output them as one 3D video signal through the 
master SDI output in real time. Combining is applicable to live mode, record mode (if Record Combined 
is selected), or playback mode monitoring through Master unit SDI out.  To view this image on a 3D TV 
that has no SDI input, use an SDI to HDMI converter. This image can be combined using one of the two 
standard 3D video signals:

• Side by Side – Each camera image will be output via the master unit SDI-out in half resolution 
side by side on the screen to be processed and displayed in 3D by a 3D monitor

• Line by Line – Each camera image will be output via the master unit SDI-out in half resolution 
horizontal line by horizontal line on the screen to be processed and displayed in 3D by a 3D 
monitor

• Anaglyph – special combining of the 2 images to allow for 3D viewing effect on a 2D monitor 
(while wearing red and cyan 3D glasses).

• 50/50 – special combining of the 2 images to allow for viewing the 3D convergence point on a 
2D monitor (without glasses).

• Off – The master unit SDI-out will output the full resolution 'left eye' camera, while the slave 
unit SDI-out will output the full resolution 'right eye' camera. No combined image is output

Note: Using side by side combining on a non-3D monitor (eg in the field) is a good way to check the 
color balance between the images and using line by line combining on a non-3D monitor is a good way 
to check the horizontal and vertical alignment between the cameras.
Note:  If the Combine option is enabled, the nano3D will verify that the incoming signals are gen-locked 
during live / record mode.  If the signals are not gen-locked, a “Stream Mismatch” error message will be 
continuously displayed  (start-up error messages of this type can safely be ignored.)

Note:   when using Combine or Record Combined, on rare occasions the colors can be inverted from the 
Slave unit to the Master.  This will happen on start-up of the units, can be seen on an external monitor,  
and can be fixed by pulling and re-inserting the HDMI port. 

Record Combined: (set in Master unit only)
• On – When the recording begins, the master unit will record combined 3D video (depending on 

the “Combine” setting). The remote tally is not needed for this setting—the trigger can be set to 
“Record Button” (System->Trigger).

• Off – The master unit will record the full resolution 'left eye' camera image while the slave unit  
will record the full resolution 'right eye' camera image. These two images can be combined and 
played back depending on the “Combine” setting and the “Play Ref” setting (see “Play Ref” 
below) The remote tally is required for this mode. Connect remote tally to both units and set the 
trigger to “remote record” (System->Trigger).

Play Ref: (Set in Master and Slave unit independently)
For 3D, for playing back, from both the Master (Top Unit) and Slave 
(Bottom unit), set this to Ext (HDMI) in the Master (Top Unit) only.
The Slave (Bottom Unit), this must be set to Int.
For playback of a combined 3D recording, this must be set to Int (Master unit).

Frame Shift: (set in Master unit only) The shift option allows the user to shift the 'left-eye' camera 
image to the left.  The 'right-eye' image will be cropped accordingly.  'Left-eye' image can 
be shifted up to 512 pixels in sets of 4 pixels (i.e. 0,4,8,12,16, etc). This allows cameras 
aligned parallel to each other to be shifted to make a 3D image, or to fine tune the point 
of convergence between the cameras. This feature is for live viewing only, will not effect 
the recorded video and only works with side by side combining.
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Audio Menu:

No special audio settings required for 3D.  Refer to Audio menu discussion in 
Audio section, pg 17.

 
Play: For playback, other than playback of the last clip recorded. 

You may select the clip or file to be played in this menu item.
Select the same clip or file on both the Master and the Slave.

Loop Play: Select Loop Play|All to enable continuous playback, with the video looping on playback.
Select Loop Play|Off, to stop playback when the last file on the card has finished 
playback. 
Loop Play|All is supported in both 2D and 3D modes.

Cue Play: Not for use in 3D mode.
Loop Record: Not for use in 3D mode.

Addendum K: nano3D Upgrade (ver1.6.226)

Introduction
The nano3D Upgrade is the process of converting 2 nanoFlashes to a nano3D.  An add-on purchase 
is required, as well as 3D activation of the designated Master nanoFlash unit.  Please see this 
document for more information:

http://www.convergent-design.com/Portals/58/Documents/nanoFlash/nano3D_Upgrade.pdf

Addendum L: nanoFlash Known Issues / Limitations (ver1.6.245)

>”Delete Last Clip” option is broken in 1.6.248.
> With specific units, the use of cranking feature (Video->Crank) with MXF recordings can result in an 
unexpected “Card too slow” error, even at bit rates of 100 Mbit or lower.
> During playback, timecode will sometimes momentarily be displayed incorrectly on the lcd screen.
> LTC timecode is off by 1 to 2 frames.
> Playback of MXF/MOV 18 Mbit from nanoFlash:  audio is corrupted.  The audio in the recorded files 
is correct.
> SD live/record loop out is broken with some cameras such as the Sony PDW-700/800.
> MPG Playback from the nanoFlash:  with HDMI input selected (System->Source), playback is 
broken.  To work around:  select SDI as the source, turn the nanoFlash off and back on, and then 
MPG playback will work.
 > 720P24 / 25 / 30 playback from the nanoFlash is not supported at this time.  Loop-through of these 
formats during live or record mode is only supported with Video->E to E turned on.
 > SD playback out of the HDMI port is not supported.
 > Audio support:  HDMI in / out:  2 channel audio support only.  HD-SDI in / out supports 0, 2, 4, or 8 
channel audio.  SD-SDI / HDMI:  2 channel audio only (records as 24-bit 4 channel audio IMX, top 2 
channels are blanked out).
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> Avid Media Composer:  does not support Long-Gop MXF files 100 Mbit and above.  (All I-Frame 
files, all bit rates are supported.)  Does not support any 720p24/25/30 files at 50 Mbit and above.
> Avid Media Composer and usage of AMA (fast file import option):  Avid MC 5.0.3 requires Avid patch 
5.0.3.2 or greater (available in the Avid download center) to enable AMA feature with nanoFlash MXF 
files.  Avid MC 5.5 or greater requires a separate installation of Avid MXF AMA plug-in, available here: 
 http://www.avid.com/US/products/Avid-Media-Access/plug-ins
> Initial release of Edius 6 does not support nanoFlash MXF files.  Later versions support nanoFlash 
MXF files.
> Reports have been received of possible rare memory leaks with Adobe CS5.0.3 (and possibly other 
similarly numbered versions) and nanoFlash MXF files, which can consume most of system memory 
on a computer.  This problem has been addressed with the release of CS5.5 .
> Some camera compatibility limitations exist, please see Addendum A for the known limitations.  
> Other NLE / Viewing limitations exist, please see Addenda E, F, and G. 

Version History
Changes in the user manual occur from version to version, with the following notations to indicate the 
locations of changes:  (please see Release Notes for more information related to each version)

version 1.1.154 (released 4 – Dec - 2009)

“ver1.5.31”  (beta, released 18 – Feb – 2010)

“ver1.5.126”  (formally released 6 – April – 2010)

“ver1.5.249”  (beta, released 27 – May – 2010)

“ver1.6.18”  (beta, released 23 – June – 2010)

“ver1.6.29”  (formally released 29 – June – 2010)

“ver1.6.226”  (beta, released 12 – Nov  – 2010)

“ver1.6.245”  (released 16 – Dec  – 2010)

“ver1.6.248”  (formally released 12 – Jan  – 2011)

NLE Compatibility and Known Limitations Addenda were updated 24-Apr-2011.
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