DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   Canon XH Series HDV Camcorders (https://www.dvinfo.net/forum/canon-xh-series-hdv-camcorders/)
-   -   Problem finding XH-A1 drivers for windows 7, 64 bit (https://www.dvinfo.net/forum/canon-xh-series-hdv-camcorders/470515-problem-finding-xh-a1-drivers-windows-7-64-bit.html)

Erik Nudd January 5th, 2010 08:20 PM

Problem finding XH-A1 drivers for windows 7, 64 bit
I am having trouble getting Windows 7 64 bit drivers installed for my Canon XH-A1 and looking for help with locating the proper one(s) or a solution to get me rolling again.

I have the XH-A1 hooked up via firewire and the firewire port, the cable itself, etc.. appear to be working fine. No burnt firewire port as it was able to connect to my PC, then it automatically loaded what appears to be the first of two drivers, then it started and nearly completed installing 2nd driver, and windows indicatetd that the 2nd driver installation "failed".

After looking around at both Microsoft's and Canon's website, I found that there may still be a compatibility issue with the XH-A1 and Windows 7 64 bit, and was not able to get any help this way.

-Has anyone else had this problem? If so, what was your soultion, if any?

-Is anyone else running W7, 64 bit with their XH-A1? If so, did your drivers load automatically? Are they W7, 64 bit specific or maybe Vista 64 bit drivers?

I understand it may come down to doing a dual boot, but the only other OS I have available is my old Vista 32 bit that I would have to use to do this (oh boy I am cringing at this idea- so much trouble with it and almost gave up and sold everything off as a result)

Also, I plan to capture with Cineform's Neo Scene, so if it's necessary to dual boot with vista 32 bit (yuck!), was curious if anybody knows of any trouble with this as well?


Peter Manojlovic January 5th, 2010 09:18 PM

Wow, that's strange....
I don't have Win7 yet, but why would there need to be drivers for a simple Firewire connection?

Erik Nudd January 6th, 2010 02:05 AM

Hi Peter-

It's actually the drivers for the XH-A1 itself, as the firewire connection and such is working fine (just confirmed this evening).

Update to original post: This evening, I searched MS website and went through all the hoops, and Canon's as well. I then went spoke with MS tech support and went through even more attempts at finding and loading a workable driver with no luck. So far, it appears that there is not a driver available yet for the XH-A1 for Windows 7 64 bit, or Vista 64 bit, according to their website and tech support. I hope and feel I'm wrong since I would think that many people have run either 64 bit OS and happened to have an XH-A1. Just haven't found anything around here yet. Still checking...

My advice for anyone upgrading to 64 bit is look into compatibility via MS website.

The search goes on...

Ken Wozniak January 6th, 2010 02:51 PM

Mine works
I'm using my XH-A1 with Windows 7 Ultimate 64 Bit. It works without problems.

Here's something for you to try.

Before hooking up the camcorder, go to the Device Manager in Windows.
Right click on the 1394 port in the list, and select "properties".
There will be an option to use the LEGACY DRIVER for the 1394 port. Select that one.
Hook up the camcorder and power it up.

I'll give you better instructions when I get home. Currently I'm at work and am using Windows XP.

Michael Hutson January 6th, 2010 06:55 PM

using xha1 and win7 pro(64 bit).....no problems yet.

Erik Nudd January 6th, 2010 08:02 PM

Best news I've heard all year, and last year too!
Ken and Michael - thank you for posting this... it gives me TONS of hope!

Ken- Strangely, I tried that exact same procedure last night, but it I wasn't able to get the A1 drivers in all the way ("failed install") after turning it back on and Windows tried the automatic driver install. I am going to assume there might be remnants from the failed A1 driver installs, remove them, then verify my 1394 port drivers are running the Legacy Drivers, likely do a reboot at this point, then turn it on and cross my fingers.

Thanks again you guys, just knowing you are having luck with it is great news to me!

Would love to get driver details from either of you, if you don't mind (like its name, etc)

Ken Wozniak January 6th, 2010 08:53 PM

My driver details:
1394 OHCI Compliant Host Controller (Legacy)
Driver Provider: Microsoft
Driver Date: 6/21/2006
Driver Version: 6.1.7600.16385
Digital Signer: Microsoft Windows

Driver File Details
File version: 6.1.7600.16385 (win7_rtm.090713-1255)

Do you have a system restore point from before you started messing with the 1394 driver?

Erik Nudd January 6th, 2010 09:16 PM

Hi Ken-

I believe I do have a restore point just prior to that. I will look to do a system restore to get back to square one. I will try and find the exact same drivers you list and if I have trouble obtaining them, at least now I can call on MS and ask (beg) them to provide me with these exact ones for manual download if necessary.

I very much appreciate your help and will post here immediately after trying... hopefully with some good results!

PS: What software do you use for capture? Just curious if you might be using something that maybe makes the A1 more "visible". I am using a trial version of Cineform Neoscene and couldn't ever "see" the A1, and it's also invisible in Vegas 9.0 (trial). I have been able to see the A1 in my "devices and printers" section, but with yellow warning flag that informs of the driver issue, but nowhere else yet. I realize that this may never change until the drivers are properly in place... just curious.

Thanks again!

Erik Nudd January 6th, 2010 09:21 PM

Hi Ken-

One more thing... What do you show for the XH-A1 drivers themselves, as opposed to the 1394 drivers. That might be the one I'm looking for. I think it might show up in Device Manager, I believe when the A1 is connected and on. (?)

Thanks !!!!!!!

Bill Engeler January 7th, 2010 01:13 PM

There are no A1 drivers, for XP, Vista, nor for Win7. None are needed. What is needed is to get the Firewire connection working. Win 7 has some issues with this, but Ken Wozniak's instructions should clear it up.

I suggest you go into Device Manager and uninstall all the 1394 elements, then reboot. Let Windows do its thing, then follow Ken's directions. The legacy driver should work.

For capturing, the software needs to be XHA1-aware. If you are using the Cineform software to capture, it should be no problem, as well as with HDV-Split. If you are capturing with Adobe software CS3 or earlier, you will need an update from Adobe for it to work.

Make sure that the settings on the capture software match the format that that camera is outputting. If you have downconvert to DV turned on in the camera's output settings, and the capture program is looking for HDV, you will have the problems you are having.

Best of luck and happy shooting!

Ken Wozniak January 7th, 2010 06:33 PM

Bill's right. There are no drivers for the XH-A1. Windows 7 recognized the camera when I plugged it in.
I could not get it working before doing the "legacy driver" trick, however.

Erik Nudd January 7th, 2010 09:56 PM

Holy cow...
...it's capturing!!!!

Thanks guys!

Some notes incase someone else has a similar....uh.... issue?

I didn't have immediate luck after first switching my 1394 drivers to the "legacy" drivers, but, it is now running with the legacy drivers in place. I actually switched back and forth about four times, then decided to download the Canon "Console" (just for kicks, even though I did this before with no results), then switched back to the 1394 "legacy" drivers and finally when I turned the camera on again, it "successfully" loaded the proper drivers. At this point, I could now see my A1 listed in my "printers and devices" folder (and device manager too) and it was finally labeled properly and no warning flags.

I have a strong feeling that if I had tried to uninstall the 1394 and reboot (as Bill suggested), I probably would have solved the problem sooner.

Important side note: THANKS! You guys have helped end, literally, a couple years of frustration. I invested hugely in my XH-A1 along with lenses, tripod, etc.. and also spent a large chunk on my computer. Between early Vista problems and just plain system problems (now happily on W7 64-bit!), I wasn't able to produce one single DVD. After $6k into it, a real desire and interest to get into it, and maybe 100 hrs of battling the previous problems, I almost sold it all for cheap. Luckily, the right offers didn't come soon enough before I convinced myself to keep it and try again later. After doing more research, upgrading a couple things and trying out some trial software, and most importantly.... YOUR WORDS OF ENCOURAGEMENT... I am now able to look over at my desktop as it is successfully capturing some video of my daughter when she was 6 mos old. She's 3 now!

Thanks guys, very, very much! (If you ever come to Kauai, you can use my kayaks, fishing poles, surfboards, etc...! ANYTIME!)

You have no idea...!

Ken Wozniak January 12th, 2010 08:31 PM

Glad to help. How about you get me to Kauai, and I'll bring my own fishing poles? :)

Douglas Dunklin February 24th, 2010 07:26 PM

I have success!
I'd been having the same problem. Have had three (yes, three!) XHA1 for several months, and had no problems capturing HDV to my desktop with WinXP(SP3). Bought a nice laptop a few months ago - MSI GX-730 w/AMD TurionX264 processor, Vista Home (32bit) installed. I use Pinnacle Studio 12 Ultimate for editing. I had no problems with video capture thru the onboard firewire port, direct to an external USB drive.

Then I upgraded to Win7 64bit.

Everything worked fine EXCEPT I could not capture HDV. I could run the camera thru Studio 12 (play, rewind, etc) but there was no video in the preview screen nor would it capture anything.

Option #1 - reset driver to "legacy" didn't work. No effect whatsoever.

Option #2 - I purchased a SIIG FireWire 800 ExpressCard from Newegg.com. The box says "Windows 7 Ready". After some stupidity on my part (which I won't go into), it works like a charm. I did not pre-install the drivers from the included disc: I let Win7 recognize the card and it installed it as a "Texas Instruments 1394 OHCI Compliant Host Controller". When I open Device Manager, I see it as well as the original onboard firewire port.

I plugged in my Canon XHA1, heard the familiar "bump-bump", opened Pinnacle Studio 12, and began to capture HDV right away.

My guess is that the expresscard has drivers optimized for 64bit, whereas the standard ones the come with Win7 aren't, even though I installed the 64bit version.

The link for the card is here: Newegg.com - SIIG NN-EC2812-S2 2-Port FireWire 800 ExpressCard/54 - Laptop Add-on Cards

Philip Younger February 25th, 2010 03:37 PM

As others have correctly stated there aren't any drivers for the camera - exactly what 'drivers' are you loading and where did you get them from?

There were reports that some firewire ports where not Vista 64bit compatible, presumably the same applies to Windows 7.

I can't see any reason for this problem other than a faulty firewire cable or port

All times are GMT -6. The time now is 11:09 AM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2021 The Digital Video Information Network