DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   Canon XL and GL Series DV Camcorders (https://www.dvinfo.net/forum/canon-xl-gl-series-dv-camcorders/)
-   -   Any XL2 owners using FCP? If so please help... (https://www.dvinfo.net/forum/canon-xl-gl-series-dv-camcorders/39549-any-xl2-owners-using-fcp-if-so-please-help.html)

Matthew Cherry February 15th, 2005 11:39 AM

Any XL2 owners using FCP? If so please help...
And Moderator, I'm placing this thread in the XL2 Watchdog section because from what I can gather, the problem is unique (at least in one part) to the XL2.

I'm shooting native 16:9, 24p Advanced Pulldown. I am able to bring in my 24p footage into a 24p timeline in Final Cut Pro HD and all works well when displaying in my editor. The pulldown seems to work fine and my image is displayed in the proper ratio, albeit with black bars top and bottom (as opposed to just seeing a 16:9 sized quicktime window) which I guess makes sense for working in the editor.

My problems arise anytime I try to export this footage. I can't seem to export it properly. Every time I export (using both quicktime and compressor) It "squeezes" my footage, so that, the candlestick on the table is now about twice as "fat" as it should be. On top of this the black bars are still there, in many cases covering an even greater area.

I did not experience this problem when shooting in 24p (2:3), although I still did have the black bars, so my thought is that I'm selecting the wrong conversion filter but for the life of me I cant figure out the right way to this with these settings on this camera.

Would somebody please be so kind as to tell me how to get my exported footage to be displayed properly, in the right aspect ration and without the bars (in quicktime, I understand that when played on a 4:3 television the black bars will be added).

Thanks in advance!!


Michael Struthers February 15th, 2005 05:33 PM

Have you made your "sequence" in FCP anamorphic? (it's a checkbox).

Matthew Cherry February 15th, 2005 07:45 PM

If you mean in the Audio/Video Settings, yes, I've set it to anamorphic or just plain 24. This is very frustrating.... I'm not an idiot but I can't make heads or tails out of apples instructions and I'm having a bear of a time getting good footage out of my editor. I can get good footage INTO it but not out of it. And every time I post this question (all over the internet it seems) no one has an answer! There has to be someone using an XL2, shooting 16:9 and editing with FCPHD, that could post the required workflow. And yes, I have used google.

Overtired rant over...


Chris Marty February 17th, 2005 07:19 AM


I went through this same thing myself.

You're going to have to manually set both your sequence AND capture settings to 16:9 Anamorphic. Those little check boxes are buggers. If you miss 'em, you're going to have the exact problem you're experiencing.

I also found that once you've got the proper settings, you should create a brand new sequence. If you change the settings on an existing sequence, it won't show the problem solved. Search me as to why, but once you've got your new sequence set up for Anamorphic and you're capturing Anamorphic, life is good.

Good luck.

Matthew Cherry February 17th, 2005 08:59 AM


Ah Chicago, Il the city of my birth! Are you making these changes in the browser window? I tried to do this, I think. The captured clip had a check in its anamorphic setting but the sequence did not. This gave me the black bars a however the export is fine (with black bars) if I export using a NONANAMORPHIC setting in Compressor. When I checked anamorphic next to the sequence line in the browser, my footage became squeezed. But I did not start a new project so....

You are saying to start a new project, check off anamorphic in my sequence in the browser window, and the proceed to capture the footage as I have where anamorphic is automatically checked. Is this correct?

Thank you so much!


Chris Marty February 17th, 2005 03:10 PM

Alright, now that I'm in front of the G5, I'll try to give you the detailed rundown.

Under Audio/Video Settings:

Open the Sequence Presets Tab, choose DV NTSC 48kHz - 23.98.
Hit the Edit button.
Frame: 720 x 480 NTSC DV (3:2).
Pixel Aspect Ratio: NTSC - CCIR 601 DV. Check Anamorphic 16:9.
Editing Timebase should be 23.98.
Hit Ok.

Open the Capture Presets Tab, choose Dv NTSC 48 kHz Advanced (2:3:3:2).
Hit the Edit button.
Frame Size: 720 x 480 NTSC DV (3:2). Check Anamorphic 16:9.
Hit Ok.

Now, create a new sequence in the browser. You can double-check that the settings have become your new default (they have) by ctrl-clicking the new sequence in the browser window. You'll see that the Anamorphic 16:9 boc is checked. If it's not, you missed something before. However, as long as that box is checked before you place any clips in the timeline, you'll finally see what you're looking for.

If you've already built a sequence in the timeline and you're looking at a 4:3 picture with the bars, you can't just go in and change the setting in the browser; I'm not sure why. Hopefully you're not too far into something important.

Good luck, and let us know if that got you where you needed to go.


Steev Dinkins February 17th, 2005 04:19 PM

Looks like everyone has the workflow documented - capture Anamorphic and edit in an Anamorphic sequence (verify clips are checkmarked as such, and the sequence is as such).

However here's the fix if you already have clips in the timeline.

I had a lot of projects where I had my sequence settings wrong, had clips in the sequence, and changed the sequence to the correct settings, and my clips were still looking screwy.

In these cases, Final Cut Pro distorts the clips to fit the sequence they are in, if the sequence settings aren't correctly set when you first lay your clip(s) in.

Here's how to fix this. You must reset the "Distort" attribute - specifically you must reset the "Aspect Ratio" to be 0. Double-click the offending clip, and you can find this under the Motion tab in the Viewer.


If you have a bunch of clips with this issue, you can select all clips, control-click and choose Remove Attributes, and select the checkbox to remove "Distort".

So, to reiterate the case with anamorphic widescreen video in Final Cut, it should NOT have black bars at the top and bottom. If it does, you're doin somethin wrong.

Matthew Cherry February 17th, 2005 04:33 PM

You guys rock, I'll try this as soon as I get home, thanks!

Matthew Cherry February 19th, 2005 11:00 AM

Well, it's better, I don't have the black bars in my editor anymore, but I'm still having problems exporting.

I shot it with an XL2: 16:9, -3 gain, 24p advanced pull down, some menu tweaks but nothing drastic and a Black ProMist 1/2. In my editor (FInal Cut Pro) it looks perfect. It also looks perfect in After Effects however when I export a still or a quicktime movie it gets "squeezed". I thought this was a problem of rectangular pixels vs. square pixels but I could certainly be wrong. I'm pulling my hair out over this, so any help would be appreciated.

Here is an example of a screen capture right off my editor:


But that's not what I'm getting when I export. _When I do that I get what you see below:






A. J. deLange February 19th, 2005 12:01 PM

Quicktime only seems to know 720 x 480 so what you have to do is 1. Make sure you have Quicktime Pro (which you do if you paid for FCP) 2. Open Quicktime Player and the movie you want to convert 3. Go to Movie -> Get Movie Properties 3. In the window that pops up select (left menu) Movie-> Video Track 4. Click Adjust. 5. Press Shift-control and drag to the size (and aspect ratio) you want. The numbers update when you release the mouse button. 6. Press Done. 7. In the right hand menu select Quality 8. Check the High box 9. Under the main File menu select Save As and save as a Self Contained movie. This is how I convert stuff I capture with another program (BTV pro) for viewing at the proper aspect ratio if I use Quicktime or if I want to send it to someone. Within FCP you can export via Quicktime conversion. When you do this you have the option of changing the size of the video (and other things like the audio sample rate and compresssion quality). I don't think I've ever done it this way but presumably the result is the same. If you export using Compressor you can pick a Wide Screen preset.

Matthew Cherry February 19th, 2005 12:08 PM

Ok so it's not pixel shape then, what I really want is the movie to be displayed at 960x480?

This was simpler when I just had the black bars. Now how about when I make a dvd (mpg2) will it display at 720x480 or 960x480?

Matthew Cherry February 19th, 2005 12:22 PM


Steev Dinkins February 19th, 2005 04:07 PM

Well it sounds like it's solved or something, but here's the deal. The XL2 and any other miniDV camera for that matter captures at 720x480, even if it is 16:9 widescreen. Final Cut Pro stretches it out for display when you select Anamorphic for the clip and sequence setting.

Regarding your footage looking correct "distribution-wise":

1. Stills - Export out. It will be 720x480. Then resize the still in Photoshop to 853x480.

2. Export for After Effects Tweaking - this is really up to you. Ideally you would stay in 720x480 and tell After Effects to interpret the footage as DV Widescreen. But it doesn't look too great while you work in After Effects since it is stretching virtually for display and you see jaggy tears. I've opted to just make a Comp at 853x480 and stretch the footage out to that, and render out to Animation codec at that size as well. Final Cut will scale it back to 720x480 in the sequence of course.

3. Mpeg2 - You would export your sequence out of Final Cut Pro as a QuickTime Movie (not QuickTime conversion). Additionally I prefer to duplicate my sequence, and set the Compressor as Uncompressed 8-bit or 10-bit, then render out, so you're not recompressing stuff out at DV25 compression. This footage will still be at 720x480. I then compress using Apple Compressor with a custom setting to handle 24p footage in 16:9. Mind you even this is encoded at 720x480. Then if you author a DVD correctly, 1 of two things happen when you play the DVD on a Player (depending on how you have your DVD Player setup):

A) It stretches it out to widescreen (If you have a widescreen TV) this provides the best resolution.
B) It letterboxes it. Still better resolution than if you letterboxed within a 4:3 sequence.

Also, oddly enough, if you open a widescreen Mpeg2 in QuickTime Player, it doesn't stretch horizontally, it squeezes vertically - so your display size is 720x404.

Now, the other option is doing a letterboxed 4:3 version. All footage out to Standard Definition Broadcast would be distributed this way - Letterboxed widescreen inside Standard Def. This has less resolution but is the way to adhere to SD standard. You would do a totally different process in Final Cut Pro. What I've done in the past is edit everything as mentioned above, but then make a letterboxed version - standard 720x480, 4:3 aspect ratio (not anamorphic) sequence, and drop my widescreen sequence in that. Or do the letterboxing in After Effects for better scaling.

Confusing crap, but that's the rules I've learned them so far.

Anthony Ambrosino July 21st, 2005 02:41 PM

some other issues with this setup
Hey guys,

I followed everything as instructed and im testing about a five minute clip,but im running into a few problems.
1st, out of the blue my audio is not syncing. i've never had this issue except during long captures.
2nd, My subjects sort of "blur" when they move. it's a pixeled blur of vertical straight lines.

any suggestions. Im filmed w/ an XL2 24p 2:3 (non advanced) at 16:9

All times are GMT -6. The time now is 07:36 AM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2021 The Digital Video Information Network