DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   Canon XL and GL Series DV Camcorders (https://www.dvinfo.net/forum/canon-xl-gl-series-dv-camcorders/)
-   -   Cannot capture with XL2 using Firewire cable (https://www.dvinfo.net/forum/canon-xl-gl-series-dv-camcorders/493669-cannot-capture-xl2-using-firewire-cable.html)

Ian Scanlan March 27th, 2011 08:54 AM

Cannot capture with XL2 using Firewire cable
 
Hi all. I have two xl2's. One of them I can connect to my pc using firewire. The PC instantly recognizes the camera and I can capture. However, my other XL2 won't capture using firewire. The PC does not even recognize that I have connected the camera. Any ideas why this could be the case? I have recently had the problematic XL2 serviced and a new firewire port put in - but still I have this problem. Any ideas?

Piotr Zubik April 3rd, 2011 07:04 AM

Re: Cannot capture with XL2 using Firewire cable
 
Hi,

If other XL2 works under the exactly same circumstances, my guess is that the firewire port on you second cam might got fried. A long time ago, I remember some people complaining about their cams not being recognized by their computers and it appeared that they had damaged their ports by hotswapping cables.

Piotr

Tony Davies-Patrick April 3rd, 2011 09:52 AM

Re: Cannot capture with XL2 using Firewire cable
 
This is a big problem with the XL2 and firewire ports, especially if you are using Vista. I have known at least five different XL2 cameras to exibit this problem. The older PCs seem to recognise the XL1, XL1s and XL2 far easier, especially if you have XP installed. Many modern laptops will not recognise the XL1 or XL2 when connected via firewire. I used to plug all my XL2 bodies into firewire port of an older PC loaded with XP, and even then sometimes it would not recognsise it unless I re-booted the PC with camera connected. I would copy XL2 files to an external hard drive, and then download to the modern laptops. A bit of a pain, but it worked. Another way around it is to buy a very cheap palm-camcorder from Ebay and use this for loading your tapes to the PC or laptop.

Piotr Zubik April 3rd, 2011 01:32 PM

Re: Cannot capture with XL2 using Firewire cable
 
Wow, I didn't know that. This is better news than damaged firewire port. Anyway, Windows 7 on Dell XPS M1710 laptop and XL2 is doing fine here!

Allan Birch April 4th, 2011 02:33 AM

Re: Cannot capture with XL2 using Firewire cable
 
Hi
I have 2 XL1s cams and computer doesnt recognise either via the fire wire cable.
Dell comp runnind XP.
Think I will get a cheap cam and see if that will work. Which cam would you sugest.?
AB,

Chris Soucy April 4th, 2011 03:39 AM

Re: Cannot capture with XL2 using Firewire cable
 
Allan:

You failed to mention the software you're using, so going a bit blind here.

As they're XL1s units, before doing anything, download the freebies from at least two other editing suppliers and see how they fair, sometimes they'll kick the OS into working, after which it'll work with anything.

Sometimes not.

Any cheap cam with DV will do for an XL1s, nothing special about them.

Ian:

Your second XL2 would appear, in the vernacular, to be stuffed.

Have you tried connecting the two cams together using a 4 pin to 4 pin Firewire cable and running one in tandem to the other?

If they won't talk, it's toast, best way I know to check out two Canon cams.

Check the manual, it's in there.


CS

Allan Birch April 4th, 2011 05:40 AM

Re: Cannot capture with XL2 using Firewire cable
 
Thanks for that Chris, although its pointing towards the knackers yard for both cams but they have been good servants in a past life. Can I stretch to a Ex1 or Ex3 thats the question.
I am useing Windows movie maker - AVS Video maker - Ulead movie maker, not the best I know but good enough.
First off I will try your sugestions.
AB.

..

Ian Scanlan April 4th, 2011 07:37 AM

Re: Cannot capture with XL2 using Firewire cable
 
Thanks to all for your info. I have just contacted the Canon Repair unit here in the UK where my camera is being looked at. They inform me that the camera will connect to their laptop running XP...it seems to work for them! That is kind of good news - it means that the camera works at least. I am still perplexed as to why my other XL2 camera works with no problems. My PC specs are:

Windows 7 64bit
12 gigs RAM
Asus P6T deluxe v2
NVidia Geforce 470

My 'bad' XL2 used to work flawlessly with my system. I am running all the latest updates. Is there any possibility that the driver for my 'good' XL2 is overriding my other XL2's driver? Anyway, I shall keep you informed of further developments...thanks guys!

Ian Scanlan April 6th, 2011 05:09 PM

Re: Cannot capture with XL2 using Firewire cable
 
Well got my XL2 back from the Canon repair/service unit. I saw at first hand the fact that my xl2 could connect to a laptop running XP. Nothing wrong with the camera it seems. I get it home and still my pc does not recognise my vsmeta. Plug the XL2 into my pc...and sulfur. Yet try another xl2 in...and it works. I am dumbfounded!

Peter Sheridan April 6th, 2011 05:37 PM

Re: Cannot capture with XL2 using Firewire cable
 
Just a mention on Firewire, I run an XL2 into windows 7, and from day one the pc recognised the camera
(must have some sort of software inside the XL2 because I didnt download any) anyway every so often the pc would not recognise the XL2 or it would and then stop capturing halfway through, and the "DV input" would flash in the camera veiwfinder, when I moved the firewire connection about it made connection and all was well. Not a very good idea where firewire is concerned, so either the cable was at fault or the socket on the (new) pc.
Before I sent the pc back I purchased a new Belkin firewire cable of Ebay for 0.99 pence YES 0.99 pence
guess what! It recognises the XL2 first time every time and carries on working everytime without holding or propping the lead up.
So my faulty 12 firewire from Maplin has been dumped and I have purchased another 0.99pence one of Ebay.
Still some left if you are quick...............................Pete.

Ian Scanlan April 7th, 2011 06:09 AM

Re: Cannot capture with XL2 using Firewire cable
 
Thanks Peter for re-pointing me in that direction. I tried another firewire cable this morning and Hallelujah! It is now working! The curious thing is that I did try different cables before - all to no avail. I have mentioned before that my other XL2 worked seamlessly with the same old cable! So still not sure why this different cable works for my other XL2 now.

The only thing I need to add is that when I connected the cable and fired up the machine, windows (miraculously) picked it up 'installing software etc but then said that software could not be installed. In the device manager there was a yellow notification. (I should have wrote it down I can't remember the exact description.) Anyway I googled the notification and I learned that it was something to do with Windows getting so far with the installation...and then not knowing what next to do!

Thinking I was back to square one, I then switched the machine off, tried again and this time it works.

Thanks for all suggestions to my problem. This is a great forum!

Ian Scanlan April 7th, 2011 03:10 PM

Re: Cannot capture with XL2 using Firewire cable
 
Alas, I spoke too soon. I just went to switch on my XL2 and ...nothing. PC does not recognise it - it did this morning but not now. Plugged in my other XL2 with the same cable and PC recognised it. Going to try it on a friends computer tomorrow...

Ian Scanlan August 18th, 2011 06:56 AM

Re: Cannot capture with XL2 using Firewire cable
 
UPDATE: I bought a new firewire card with TEXAS INSTRUMENT chipset. All problems went away. If anybody else is having the kind of trouble I was having, a new TI firewire card will work wonders.


All times are GMT -6. The time now is 04:02 PM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2021 The Digital Video Information Network