DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   Digital Compositing and Effects (https://www.dvinfo.net/forum/digital-compositing-effects/)
-   -   AE: 16:9 composition problems (https://www.dvinfo.net/forum/digital-compositing-effects/102390-ae-16-9-composition-problems.html)

Travis Arket August 29th, 2007 12:00 AM

AE: 16:9 composition problems
 
To some this will probably seem very trivial and stupid but for some reason I cant seem to figure out if this is normal.

I was doing some testing with my canon XL2, shooting in 16:9 at 60i and importing it onto my computer through premieres capture. While capturing and playing in premiere everything seems fine as far as the aspect ratio and frame rate.

However, when I export it to uncompressed AVI and open it through AE it squishes the footage yet still calls it 16:9. Im using the AE preset comp NTSC DV WIDESCREEN but its saying 1.2 (shouldnt 16:9 be 1.74?)

My question is, how do I get AE to automatically accept my footage as a true 16:9 without having to manually enter the resolution ratio composition then stretch my video to fit?

I've uploaded a few pictures to give a better idea of whats going on.

Here is what the video is supposed to look like (after original capture)
http://www.travisarket.com/images/fullwide.jpg

Here is what it looks like in AE
http://www.travisarket.com/images/smallwide.jpg

And here is making a new composition in AE (my settings)
http://www.travisarket.com/images/settings.jpg

Edit:
I had to turn off full video acceleration in windows media player in order to take the screen shots of the video, thats why it looks so crappy and interlaced.

Travis Arket August 29th, 2007 02:46 PM

no one knows? lol... oh come on! Help a brotha' out!

Bert Smyth August 29th, 2007 10:31 PM

I'm not sure why you're exporting it from Premiere, and then importing it into After Effects. Can't you just open the original captured AVI file in After Effects?

As far as the squishing goes, I'm sorry I can't tell you why After Effects displays it that way, but if you set the composition to the widescreen preset (just like the settings you have posted here) when you export the file it will look normal. I've created 100s of widescreen animations in After Effects, they always stretch out to normal upon export. Go ahead and try it, it should be fine.

Travis Arket August 29th, 2007 11:28 PM

When I say export from premiere I guess I mean Im just saving them from the capture mode.

Even when I export them to avi in AE it still turns out to be 1.2 (720x480) instead of the supposed 1.7 of true 16:9 widescreen. boooo....

AE hates me. :(

Daniel Ross August 29th, 2007 11:43 PM

Pixel Aspect Ratios, and the actual pixels displayed...
 
AE likely did interpret the footage correctly.
To be sure, right click on the clip in the project window, and choose "interpret". In the settings, find pixel aspect ratio (the rest should be fine, but feel free to change that too), and you can set that to 1.2:1.
1.2:1 is the PIXEL aspect ratio, not the ratio of the image itself. DV is .9:1, not 1:1 (square pixels), and that is why you have 720x480 instead of 640x480 (true 4:3). By using a specialized Pixel Aspect Ratio (sometimes P.A.R.), you can have the data of a certain space, any size/ratio, displayed on a larger size.
Anamorphic is just that, for widescreen. It's the reason that DVDs end up looking funny when you don't have them set to letterbox and you see everything looks skinny. You fix this the same way you would in AE, by telling it to stretch it horizontally (which is actually displayed as squeezing vertically on an SD TV set).

So, to solve this....
Use 1.2:1. The end. Just export how you want and be sure you use Anamorphic/1.2:1 by the end. And that's it. You can use 720x480, squeezed/stretched to whatever (meaning that 4:3 is fine, if you're just working on the footage).
Certainly wouldn't want to stretch it to 853.3:480, etc., as that would lose quality.

Now, just for aesthetics, you can click the icon in AE's viewer window of a filmstrip, 4th from the right of the icons on the left bottom corner. It's just to the right of (grayed out, if you aren't in a 3D comp) "Active Camera".
That will display it at 16:9, for a better preview. However, as you are just directly interacting with pixels (without any particular relation to the actual dimensions of the image), you might find it better to work with the 720x480 standard image, at least in some cases.
As the warning states when you turn on the 16:9 view mode, it won't affect output, etc. Just for preview purposes.


Note: Working with a Mac (and footage from FCP to AE), I find that AE seems to guess it's 1.21:1, not 1.2:1. This is really annoying, and of no advantage to me. It also isn't standard, so bringing in other footage and trying to make it match (or doing the same with a composition) is a pain. If this happens to you, I'd recommend overriding it in the interpret settings.

Travis Arket August 30th, 2007 12:35 AM

The aspect button was exactly what my problem was. And you were dead on with the exporting settings. I was using the cinepak and it didnt have an option for 16:9, I just figured it would use the comp settings ... apparently not. So I changed to the DV NTSC export and switched it to 16:9 and bam... problem fixed. See, I knew it was something easy and I was just being stupid! :D

Thanks again!

Aric Mannion August 31st, 2007 11:54 AM

Edit: Whoops I answered your question, and then saw that it has already been answered. Never mind.


All times are GMT -6. The time now is 08:02 AM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2021 The Digital Video Information Network