DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   Final Cut Suite (https://www.dvinfo.net/forum/final-cut-suite/)
-   -   Installer not working while attempting FCP4 install (https://www.dvinfo.net/forum/final-cut-suite/11699-installer-not-working-while-attempting-fcp4-install.html)

Charles Papert July 7th, 2003 02:14 AM

Installer not working while attempting FCP4 install
 
OK, I apologize here because this turns out to be not just a FCP4 issue, I also tried unsuccessfully to install a Quicktime upgrade. I double click on the little "package" icon, the Installer opens, and nothing happens. I try opening through the Installer menu, nothing. I tried another Installer app on a different drive, nothing. Any thoughts, anyone? Dying to check out FCP4, very frustrating!

Bud Kuenzli July 7th, 2003 02:31 PM

big problem
 
I don' t know if your problem is big or not but the solution isn't obvious. Try creating another user and then log in as that user and try to install. If you can, then the problem is within your user folder, if you can't then the problem is within your system. From there I'd call Apple and talk with an OSX expert or search at www.macfixit or go to Apple discussion forum and see if you can find other complaints of a similar nature. You may have to archive and reinstall OSX if you can't find the particular problem. Before that (and right away..) fix permissions just to see if it's related to that whole issue.

Jeff Donald July 8th, 2003 04:49 PM

Charles, are you still having trouble? Have you tried fixing permissions as Bud suggested? Use the Disk Utility and select the system drive and fix permissions. If that doesn't do it, we can try installing under Root and I can talk you through it. Let me know.

Charles Papert July 8th, 2003 10:18 PM

Thank you Bud and Jeff. I tried fixing permissions (hope I did right, there wasn't any confirmation at the end of the process such as "permissions are fixed!") but the problem persists.

Jeff, I'd love to take you up on your offer...how/when?

Jeff Donald July 9th, 2003 09:06 PM

I'll write the process out, with disclaimer for the weak hearted), and post it tomorrow.

Jeff Donald July 10th, 2003 12:59 PM

This is an easy way to create a Root account. Root accounts allow you access to all parts of your system and delete files that should not be deleted. Day to day operation of your computer under a root account is not wise. However, it has privileges that regular users do not have. Use with Caution

Go to Apple Menu>System Preferences>Accounts. Click on New User (on the right).

Under Name>root (lower case)
short name>root (lower case)
New password>type in secret password
verify>retype password

Check both boxes at bottom.

Go to Apple menu>log out

Computer will close finder etc.

New log in window appears>enter name and password.

Computer will now startup with root privileges for the user. Attempt to install FCP4 or other software as a test.

If software doesn't install. I would download the latest OS X update 10.2.6 combo (from Apple site) and install combo update then Fix permissions again and try to install programs.

Chris Korrow July 10th, 2003 07:26 PM

It needs OS 10.2.5 or higher. ???
Chris

Jeff Donald July 10th, 2003 08:18 PM

Yes, these are the requirements per Apple's FCP page

System Requirements:


Macintosh computer with 350MHz PowerPC G4 processor and AGP graphics card
RT Extreme requires a single 500MHz or faster PowerPC G4 (550MHz for PowerBook G4) or any dual PowerPC G4.
Soundtrack requires a single 500MHz or dual 450MHz or faster PowerPC G4.


Mac OS X 10.2.5 or later


QuickTime 6.1 or later


384 MB of RAM (512MB required for RT Extreme and recommended for Soundtrack)


1GB of disk space required for application installation


5GB of disk space required for Soundtrack content


9GB of disk space required for LiveType content


DVD drive required for installation

Charles Papert July 10th, 2003 11:16 PM

sigh...

Following that setup (root user) hitting save, it tells me that I already have a user named "root", but it doesn't show up in the user list, and I never set that up myself.

I am running 10.2.6, recently upgraded.

Waaah!

Jeff Donald July 11th, 2003 04:32 AM

Go to System Preferences>Accounts>Login Options>Click on List Users and Show Password Hint>Save Changes (quit system Preferences. Now log out via Apple Menu, at login a space for other should appear. Choose other and for name use root (lower case). Now the fun part, any idea on your root password? If your not sure try your system password. It is probably your (Charles' password).

If that doesn't work and the system actually chose the password, you may be able to change it by changing your (Charles') password in System Preference>Accounts>Select user>Edit User>now change password, quit System preferences and try to log out and log in using root and new password.

Another option if this fails is to try to install under System 9 if it is installed on you computer. You will need to install in the proper Applications folder for System OS X, assuming you get that far.

I would also call Apple. They should have some ideas on possible causes or solutions. The help is free for 90 days after purchase, I think. Post back if none of this works. The ultimate way to reset root is to do a clean install of 10.2.6. It's not as bad as it sounds and should take less than a couple of hours, total time.

Charles Papert July 13th, 2003 01:59 PM

Thanks again, Jeff. I have tried all that and successfully logged in as "root", but the Installers just won't do anything on a variety of software disk images. I'll have to look deeper, I guess. At least everything else is working. This is my first issue with OSX, so I guess I've done well overall.

John Locke July 13th, 2003 02:12 PM

Charles,

FWIW...I've never been able to capture footage with FCP 3.0. Tried everything to figure out what the glitch was after upgrading, including posting here, at the Cow, and at Apple...but no solution. So, I've just worked around it by capturing with iMovie...which is inconvenient, but not so terribly much. I've gotten used to it.

Not helpful info except to say that OSX and FCP do have some problems...and it's just that magic combination of elements that decides who out of thousands or millions will be the unlucky ones.

If upgrading to FCP 4.0 doesn't rectify the problem sometime in the near future, I'll do what Jeff suggests and perform a clean system install. Then, add apps and fonts in small groups, testing FCP after each, to see if I can narrow down what the conflict is. You might be better off just going ahead and doing that now.


All times are GMT -6. The time now is 04:04 PM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2021 The Digital Video Information Network