DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   Final Cut Suite (https://www.dvinfo.net/forum/final-cut-suite/)
-   -   I'm having all kinds of trouble making a DVD (https://www.dvinfo.net/forum/final-cut-suite/488010-im-having-all-kinds-trouble-making-dvd.html)

John Meeks November 24th, 2010 07:49 PM

I'm having all kinds of trouble making a DVD
 
I'm having all kinds of trouble making a DVD.

My compressed video looks good in QuickTime, it looks good in the DVD Studio Pro simulator, but bits and pieces of it have horrible interlacing artifacts during playback of the actual finished DVD. It's even sometimes different from one playback to the next. It seems to happen if I play through, but not if I jump to the spot where I saw the problem before.

This is in the OSX DVD player, so it's not like I'm trying it on some junky old set-top player or something, and I've used *only* Apple products for the entire workflow once I got it out of the camera. I need this thing to look good on computers as well as TV's, since I think many of our customers will watch it on their laptops (probly many Macs, with this exact player, too).

My friend played it back on his Mac and it did the same thing, so it's not my Mac or my copy of DVD Player or OSX. He was actually the one who alerted me to the problem.

I've tried dozens of different combinations of settings when compressing the files, single-pass, double-pass, different framerate conversions, and I always have to make the full DVD because it never shows up in a short sample.

My theory is that I have an edit in the middle of a frame which is throwing it out of sync, so that it's showing fields from adjacent frames together as a frame. Has anyone had this problem when reducing the framerate, and having an edit between two fields in the same frame? I think it may be the case that I have an edit like this, and it's throwing the fields out of sync with the frames. If I single-step through, it looks like this is what is happening.

Any help would be greatly appreciated, I've been working on this problem for almost 2 weeks now. I've never seen a commercial DVD do this, so there must be a way to fix it.

If anyone wants a copy of the DVD to see the problem for yourself on your Mac, I can send you one. I'm desperate to get this thing working right since I'm behind on this project already.

John Meeks November 24th, 2010 08:00 PM

Also I think I'll call Apple about this, but I bet the DVD Player support blames it on Final Cut, and Final Cut support blames it on the player. I'll have to make them talk to each other, since I think it's caused by some kind of interaction between the two.

The encoded video looks so much better in QuickTime than it does after being burned onto a DVD, I don't get it.

Robert Lane November 24th, 2010 08:03 PM

John it sounds like from what I've read that you're simply using a compressed format QT movie and dumping that into DVD SP and then making your DVD burn. That's the wrong method; DVD SP will convert and non DVD-spec video into MPEG2 compliant files - which means DVD SP is actually re-compressing your video.

What you need to do is follow this guide I setup to get good-looking DVD's using Compressor to create your MPEG2/AAC files FIRST then create your DVD:

Grumpy Quail: Best Apple Compressor Settings for DVD Widescreen Downconversions

John Meeks November 24th, 2010 08:41 PM

The problem is occurring using video compressed with the "DVD: Best Quality 120 Minutes" preset in Compressor.

I also tried the settings in that guide, and although the overall quality improved, the problem still occured.

Is there a specific setting that you recommend I change?

Also, is your guide for 720p or 1080i (input) video? I've found that they need significantly different settings.

John Meeks November 24th, 2010 08:59 PM

I tried to convert the footage to 720/30p. I used the compressor setting "Apple ProRes 422 for Progressive Material", under the Encoder tab in the inspector I clicked on the Video Settings... button and changed the Frame Rate dropdown to 30 FPS. The file produced, however, was still 60FPS, so I'm not sure how to change a frame rate in compressor.

Ethan Cooper November 24th, 2010 09:11 PM

John,
I might have your solution if the footage was shot, edited & output as 1080i. If your DVD's are intended to be viewed on computers & flat screen TV's then I'd recommend you modify your 'DVD: Best Quality 120 Minutes' setting a little to account for deinterlacing.

1) open the 'frame controls' tab
2) click the gear button next to 'frame controls'
3) in the dialogue box turn frame controls on
4) under resizing control make output fields 'progressive'
5) under resizing control make deinterlace 'better (motion adaptive)'

If found in my testing that using Compressor to deinterlace my SD dvd footage resulted in better looking playback on computers & upconverting dvd players hooked to HDTV's. It take a little more time per encoding session, but I think it's worth the results.

If the problem continues to occur then I officially don't know.

A little more info from you might help.
- what camera was the footage shot on
- what framerate was the footage shot with
- what are your FCP sequence settings
- are you 100% sure the artifact you're seeing isn't on the source footage or on the Quicktime master?

Good luck.

Ethan Cooper November 24th, 2010 09:14 PM

Quote:

Originally Posted by John Meeks (Post 1591811)
I tried to convert the footage to 720/30p. I used the compressor setting "Apple ProRes 422 for Progressive Material", under the Encoder tab in the inspector I clicked on the Video Settings... button and changed the Frame Rate dropdown to 30 FPS. The file produced, however, was still 60FPS, so I'm not sure how to change a frame rate in compressor.

converted from what? what's the source material shot at?

William Hohauser November 24th, 2010 09:21 PM

Quote:

Originally Posted by Ethan Cooper (Post 1591814)

A little more info from you might help.
- what camera was the footage shot on
- what framerate was the footage shot with
- what are your FCP sequence settings
- are you 100% sure the artifact you're seeing isn't on the source footage or on the Quicktime master?

Good luck.

This info is extremely important if you want some help. It's also important to know if the interlacing problem is related to specific areas of your project, such as scenes with motion or a shot filmed with a different camera. Also, you must watch the DVD on a DVD player connected to a television set, not your computer. Computers do not play interlaced footage well and DVDs are interlaced.

John Meeks November 24th, 2010 09:24 PM

All of the original was shot at 720/60p.

Cameras are all Sony NX5U.

I let FCP automatically set the sequence settings (it asks when you first import a clip).

I'm *only* seeing the problem using Apple DVD Player. It does not occur with other software players or with the set-top players I've tried. It also looks fine if I play the .VOB files directly off the DVD with VLC. I'm not sure how much farther I can get from the source footage.

John Meeks November 24th, 2010 09:25 PM

Quote:

Originally Posted by William Hohauser (Post 1591819)
Computers do not play interlaced footage well and DVDs are interlaced.

Everything is Progressive (as much as is possible when writing to a DVD).

John Meeks November 24th, 2010 09:32 PM

Also note that it only happens after about 10 minutes of continuous playback, if I jump to the time where I saw the problem, it doesn't occur again until it has again been playing for about 10 minutes continuously.

I tried it on my friend's (very high-spec'd) Mac, so it's not something specific to my machine.

I've also noticed that the video looks far better (even when the problem is not occurring) with VLC.

I haven't seen this problem in any commercial movies, so I think it's some kind of interaction between the Final Cut Suite, and the Apple DVD Player.

Ethan Cooper November 24th, 2010 09:35 PM

Quote:

Originally Posted by John Meeks (Post 1591821)
All of the original was shot at 720/60p.

Not that it matters for what we're discussing, but do you really like the 60p look? I never have gotten into it. If so, care to tell me your age? See, I've got this theory I'm working on...

Quote:

I let FCP automatically set the sequence settings (it asks when you first import a clip).
Well for the purposes of this discussion we'll assume FCP got it right & your sequence is actually 720/60p. Nothing can possibly go wrong when we assume right?

Quote:

I'm *only* seeing the problem using Apple DVD Player.
I'm tempted to say something smart-arsed here like 'well don't play it in Apple's DVD Player' but that wouldn't be very helpful.
Have you tried messing with the settings in Apple's DVD Player itself? I think I remember some type of interlacing setting there as well.
I'm stumped for now, but that William guy seems like he might know a thing or two, let's see what he says.

William Hohauser November 24th, 2010 09:35 PM

Progressive files are written as interlaced to DVDs. if it plays well on a set-top player you may rest peacefully.

John Meeks November 24th, 2010 09:37 PM

I can't rest easily, because the majority of my customers will be playing this on a computer, so it's more important that it looks good on computers than on set-top boxes.

John Meeks November 24th, 2010 09:39 PM

Quote:

Originally Posted by Ethan Cooper (Post 1591826)
I'm tempted to say something smart-arsed here like 'well don't play it in Apple's DVD Player' but that wouldn't be very helpful.
Have you tried messing with the settings in Apple's DVD Player itself? I think I remember some type of interlacing setting there as well.
I'm stumped for now, but that William guy seems like he might know a thing or two, let's see what he says.

That would be fine for me, but this is a product my company will be selling, and I'd rather not say that to customers. :-)


All times are GMT -6. The time now is 03:55 PM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2021 The Digital Video Information Network