DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   High Definition Video Editing Solutions (https://www.dvinfo.net/forum/high-definition-video-editing-solutions/)
-   -   A free and easy way to export Quicktime to JVC HD cameras or D-VHS (https://www.dvinfo.net/forum/high-definition-video-editing-solutions/20387-free-easy-way-export-quicktime-jvc-hd-cameras-d-vhs.html)

Paul St. Denis January 26th, 2004 11:05 AM

A free and easy way to export Quicktime to JVC HD cameras or D-VHS
I created an Applescript droplet that allows for conversion from Quicktime 1280x720p to MPEG2 transport stream.

The instructions are include in the README, please let me know if you need any clarification.

Paul St. Denis

Jason Pichonsky January 26th, 2004 12:23 PM

Hey Paul,

Firstly I'd like to congratulate and thank you for all the work and postings you've done with this format.

I've been lurking here for a while now and have been watching your previous attempts to convert to mts. I've also been downloading and testing your compiles etc. Your posts also turned me on to Project X which has been a great help.

But I am having no luck with your lib installer. I get into it alright, but when I make an attempt to install it I am informed that I can't make changes to the directory. Any ideas. Was this droplet based on OS 10.3 ? I'm still running Jaguar.

Thanks a lot,

Christopher C. Murphy January 26th, 2004 01:30 PM

Hi Paul, ditto on the last posting.

Except, I don't even get any messages...it just hangs at the opening screen with the "Continue" button.

Thanks for everything Paul.


Darren Kelly January 26th, 2004 02:09 PM

I tried this too .

The Lib program installed just fine (10.3.2)

When I drag and drop a file to the applet I get the following text:
usage: movtoy4m -w width -h height -F a:b -a a:b [-s] [-f] [-o ppm/y4m] movie.mov

example: movtoy4m -w 352 -h 288 -F 25:1 -a 4:3 pal_normal.mov
example: movtoy4m -w 352 -h 240 -F 30000:1001 -a 16:9 ntsc_wide.mov

INFO: [yuvscaler] yuvscaler (version 1.7.0) is a general scaling utility for yuv frames
INFO: [yuvscaler] (C) 2001-2002 Xavier Biquard <xbiquard@free.fr>
INFO: [yuvscaler] yuvscaler -h for help, or man yuvscaler
**ERROR: [yuvscaler] Could'nt read YUV4MPEG header!
--verbose|-v num
Level of verbosity. 0 = quiet, 1 = normal 2 = verbose/debug
--format|-f fmt
Set pre-defined mux format fmt.
[0 = Generic MPEG1, 1 = standard VCD, 2 = user VCD,
3 = Generic MPEG2, 4 = standard SVCD, 5 = user SVCD,
6 = VCD Stills sequences, 7 = SVCD Stills sequences, 8|9 = DVD]
--aspect|-a num
Set displayed image aspect ratio image (default: 2 = 4:3)
[1 = 1:1, 2 = 4:3, 3 = 16:9, 4 = 2.21:1]
--frame-rate|-F num
Set playback frame rate of encoded video
(default: frame rate of input stream)
0 = Display frame rate code table
--video-bitrate|-b num
Set Bitrate of compressed video in KBit/sec
(default: 1152 for VCD, 2500 for SVCD, 7500 for DVD)
--nonvideo-birate|-B num
Non-video data bitrate to assume for sequence splitting
calculations (see also --sequence-length).
--quantisation|-q num
Image data quantisation factor [1..31] (1 is best quality, no default)
When quantisation is set variable bit-rate encoding is activated and
the --bitrate value sets an *upper-bound* video data-rate
--output|-o pathname
Pathname of output file or fifo (REQUIRED!!!)
--vcd-still-size|-T size
Size in KB of VCD stills
--interlace-mode|-I num
Sets MPEG 2 motion estimation and encoding modes:
0 = Progressive (non-interlaced)(Movies)
1 = Interlaced source material (video)
2 = Interlaced source material, per-field-encoding (video)
--motion-search-radius|-r num
Motion compensation search radius [0..32] (default 16)
--reduction-4x4|-4 num
Reduction factor for 4x4 subsampled candidate motion estimates
[1..4] [1 = max quality, 4 = max. speed] (default: 2)
--reduction-2x2|-2 num
Reduction factor for 2x2 subsampled candidate motion estimates
[1..4] [1 = max quality, 4 = max. speed] (default: 3)
--min-gop-size|-g num
Minimum size Group-of-Pictures (default depends on selected format)
--max-gop-size|-G num
Maximum size Group-of-Pictures (default depends on selected format)
If min-gop is less than max-gop, mpeg2enc attempts to place GOP
boundaries to coincide with scene changes
All Group-of-Pictures are closed. Useful for authoring multi-angle DVD
Preserve two B frames between I/P frames when placing GOP boundaries
--quantisation-reduction|-Q num
Max. quantisation reduction for highly active blocks
[0.0 .. 5] (default: 0.0)
--video-buffer|-V num
Target decoders video buffer size in KB (default 46)
--video-norm|-n n|p|s
Tag output to suit playback in specified video norm
(n = NTSC, p = PAL, s = SECAM) (default: PAL)
--sequence-length|-S num
Place a sequence boundary in the video stream so they occur every
num Mbytes once the video is multiplexed with audio etc.
N.b. --non-video-bitrate is used to the bitrate of the other
data that will be multiplexed with this video stream
Generate header flags for 3-2 pull down of 24fps movie material
--intra_dc_prec|-D [8..11]
Set number of bits precision for DC (base colour) of blocks in MPEG-2
--reduce-hf|-N num
[0.0..2.0] Reduce hf resolution (increase quantization) by num (default: 0.0)
Maximise high-frequency resolution - useful for high quality sources
and/or high bit-rates)
Include a sequence header every GOP if the selected format doesn't
do so by default.
Do not generate dummy SVCD scan-data for the ISO CD image
generator "vcdimager" to fill in.
--playback-field-order|-z b|t
Force setting of playback field order to bottom or top first
--multi-thread|-M num
Activate multi-threading to optimise throughput on a system with num CPU's
[0..32], 0=no multithreading, (default: 1)
Force SVCD horizontal_display_size to be 480 - standards say 540 or 720
But many DVD/SVCD players screw up with these values.
Force MPEG2 *not* to use alternate block scanning. This may allow some
buggy players to play SVCD streams
Deactivate the constraints for maximum video resolution and sample rate.
Could expose bugs in the software at very high resolutions!
--custom-quant-matrices|-K kvcd|tmpgenc|default|hi-res|file=inputfile|help
Request custom or userspecified (from a file) quantization matrices
--unit-coeff-elim|-E num
Skip picture blocks satisfying which appear to carry little
because they code to only unit coefficients. The number specifies
how aggresively this should be done. A negative value means DC
coefficients are included. Reasonable values -40 to 40
--b-per-refframe| -R 0|1|2
The number of B frames to generate between each I/P frame
Print this lot out!
usage: movtoway -o output.wav movie.mov


I think you're on the right track, and I sure applaude all the work you have done. This will be great I am confident.

What else can we do to help!


Paul St. Denis January 26th, 2004 02:13 PM

I think that you need administrative access in order to use the installer.
It is about the custom version of mpeg2enc that is not statically compiled, once I figure this out everything will be runnable from the folder without the package.
I hope to have that in the near future.

Paul St. Denis January 26th, 2004 03:00 PM

I installed the program file on another Mac and it is working for me there too, I noticed the file name cannot have spaces, I will fix that. Also that VLC never quits after creating the .ts file.
Darren did you drop a Quicktime file on the HDQT2TS icon?

Thanks everybody for testing this out, the feedback isn't going a smoothly as I hoped but I appreciate that you are trying. I will keep working to iron out the bugs if you keep telling me what the bugs are.


Darren Kelly January 26th, 2004 04:05 PM

Yes Paul, I did drop a quicktime file, but I've learned something that could help.

I droped the same file on to the applet again, and this time it worked. The difference was having the file in the same folder as the applet.

The first time, I did it the file was on another drive and it did not work. Once in the same folder as the HDQT2TS it worked. Is this something that can be changed? I want to try converting an entire 60 minute project. I guess I could transfer the applet to that drive?

It worked, but at the end it displayed an errror that said it didn't have any audio tracks(which it didn't have) I don't think that's an error, or a bug.

The other suggestion I have is it displays or counts the frames. That's fine for a short clip, but if I want to convert a movie or a longer project (say 60 minutes) it might be annoying. IS there another way.

(I know, I know what do I expect for free)

Good Work.


Darren Kelly January 26th, 2004 04:44 PM

An Adendum.....

The file must be in the folder and on the prime or system drive to work. Otherwise it will give the same error message as on my first test.

This would limit the size of the movie to under 80 gigs for me (all that's left of a 160).

Is there a way Paul to allow it to read from one drive and write to another?



Paul St. Denis January 26th, 2004 05:17 PM

Hi Darren,
This would be an issue with scriptGUI used to make the shell scripts dropable, I'll contact the author to see what they have to say.
In the mean time why not try to move HDQT2TS folder to the drive containing your video?

I have dropped files from without the folder and had them work, are you sure about that constraint?

The frame count could be shut off by passing a flag to yuvscaler, I turned it on for larger files so that people know that things are still processing.

Darren Kelly January 26th, 2004 05:21 PM

<<<-- Originally posted by Paul St. Denis

In the mean time why not try to move HDQT2TS folder to the drive containing your video? -->>>

Did that. It must be on the system drive. I suspect it has to do with the lib stuff maybe (not a programmer though)


Paul St. Denis January 26th, 2004 06:31 PM

I tried the application across drives and it worked for me, I suspect that you have spaces in your drive names or folders (not that you shouldn't), try downloading the latest version of the program which fixes that bug.

Paul St. Denis January 26th, 2004 06:49 PM

Jason, Murph
Was it the administrative access problem?

"It's also possible that you simply don't have administrative access to your files. To find out, open System Preferences > Users. The Users dialog displays whether or not your account has administrative rights. If it doesn't, click the check box to make yourself an administrator (you will need to enter the administrator's password) and close System Preferences. The admin account isn't too different from a regular account, except that you have access to all files"

Darren Kelly January 26th, 2004 07:53 PM

I used the new one and you are right, I do have drive names with spaces.

The new version did work over multiple drives. It also didn't count frames, which scared me at first, but I learned

I am now outputting a single 60 minute file into a single quicktime and will give it a try converting it over night into an MPEG2 file.

I am getting files that are called M2v is that correct, or should I also get something that says ts.

Please advise


Jason Pichonsky January 26th, 2004 07:56 PM


Yah, it was an admin thing. I thought my user account was the admin, but it would run the install from it. I had to log into the administrator account to run the installer.

Now when I run it I'm getting

"**ERROR: [yuvscaler] Could'nt read YUV4MPEG header!"

It doesn't matter where the original file is or where the droplet is.

Unfortunately, I've got a project due soon so I don't have time to keep at it.

I'll have to come back to it later. I'm still very hopefull that I'll get it running when I have the time to explore it further.


Paul St. Denis January 26th, 2004 09:00 PM

There is still a problem with the script handling spaces, I've got it all working except VLC, I will keep at it on Tuesday.
Sorry about these bugs, I should've waited before posting after the first round of problems

All times are GMT -6. The time now is 11:26 AM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2020 The Digital Video Information Network