Wordpress 2.5 FLV Player problem at DVinfo.net

Go Back   DV Info Net > Cross-Platform Post Production Solutions > Distribution Center > Flash / Web Video


Reply
 
Thread Tools Search this Thread
Old May 3rd, 2008, 06:36 AM   #1
Major Player
 
Join Date: Oct 2005
Location: Rio de Janeiro
Posts: 334
Wordpress 2.5 FLV Player problem

Hi Folks

I have been trying to resolve this problem without success for 2 days and would really appreciate any pointers as it's got me well and truly stumped.

I have an installation of Wordpress 2,5 in my root server folder:

www.mysite.com

I have installed and activated the FLV Player and afc-plug-system plugins.

I have a folder structure: www.mysite.com/wp-content/uploads

..with a 'test.flv' in the uploads folder.

path is 100% correct.

I create a new post, use the FLV button to insert the 'quicktag' code. When I view the post, the player appears but always reports 'MEDIA NOT FOUND', everytime.

The quicktag code is pasted below:

<flv path="http://www.mysite.com/wordpress/wp-content/uploads/test.flv" splash_path="http://www.mysite.com/wordpress/wp-content/uploads/test.flv" title="Advanced Flash Components (www.afcomponents.com)" width="360" height="270" bgcolor="0xFFFFFF" autostart="false" show_as_link="false">{Advanced Flash Components (www.afcomponents.com)}</flv>

I also tried another plugin: flash-video-player from these guys:
http://www.mac-dev.net/blog/flash-vi...customization/

After following the necessary steps I get the player appearing but doesnt play the actual video..

I am new to all this web stuff so please excuse me if I havent explained that very well but to me its seems as though I have a problem with paths somewhere.

When I use SmartFTP client to do all my FTP stuff, my root folder has the following:

mysite.com
logs

As I said I installed wordpress into the mysite.com folder and went from there. I have also installed a fresh blog into a subfolder in mysite.com. With this new blog I just installed the FLV plugins, created the paths with the test.flv but still same problems.

Any suggestions very much appreciated. If more info is needed please say, thanks in advance

Dan
Dan Burnap is offline   Reply With Quote
Old May 3rd, 2008, 01:18 PM   #2
Inner Circle
 
Join Date: Jun 2007
Location: Belgium
Posts: 9,064
Try the mediaplayer plugin from an-archos: http://an-archos.com/anarchy-media-player

Just install the plugin in your plugin folder, activate it in wordpress and then go to "options" and "amp" tab and set the width and height of your .flv as you want it to appear in your post or page.

Only thing left to do is write a word in your post like "demo" or whatever en use the "insert/edit" button to link that word directly to your file. In your case that would be: http://www.mysite.com/wordpress/wp-c...loads/test.flv

The plugin then transforms the link into a playable flv file with the dimensions you set in the option page.

I use it on my blog and it works like a charm.

If it still won't play after this, try setting the permission for your "uploads" folder to "777"
Noa Put is offline   Reply With Quote
Old May 3rd, 2008, 03:44 PM   #3
Major Player
 
Join Date: Oct 2005
Location: Rio de Janeiro
Posts: 334
Hi Noa, thanks for the reply, I tried the Anarchy plugin and it installed fine etc but once again, no video playing. That's three flash plugins I've tried with all failing to fine the movie.

I checked the permissions on the uploads folder (and those up to the root) and they are all '777'.

Its definately some permissions or path problem but I just cant nail it. I've tried different .flv (encoded in Adobe Flash Encoder)

One thing..when I put the path into IE (http://www.mysite.com/wp-content/uploads/test.flv) I get a 404 error.

Also..when I load FLV player manually and paste my URL (the test.flv one) into it, nothing happens. If I browse and select the copy on my harddisk it plays no problems

One last thing..I originally created a subfolder under my root (mysite.com/blog) and installed Wpress into that. I then decided i wanted to run the blog from the root so moved every file and folder into the root (didnt work) so I deleted all that and installed Wpress into the root directly.

anymore help very much appreciated, thanks
Dan Burnap is offline   Reply With Quote
Old May 3rd, 2008, 04:05 PM   #4
Major Player
 
Join Date: Nov 2004
Location: Winter Park, FL
Posts: 978
I would love to help but can I please get an actual URL. I assume you are not the owner of www.mysite.com Being able to see the actual code and such on the server that is giving you trouble will really help.
__________________
Simple Thought Productions - Life @ 30,000 Words per second
Josh Chesarek is offline   Reply With Quote
Old May 3rd, 2008, 04:16 PM   #5
Major Player
 
Join Date: Oct 2005
Location: Rio de Janeiro
Posts: 334
Hi Josh

Here is my actual domain www.danburnap.com

and the pasted code from flv player:

<flv path="http://www.danburnap.com/wp-content/uploads/test.flv" splash_path="http://www.danburnap.com/wp-content/uploads/test.flv" title="Advanced Flash Components (www.afcomponents.com)" width="360" height="270" bgcolor="0xFFFFFF" autostart="false" show_as_link="false">{Advanced Flash Components (www.afcomponents.com)}</flv>

The result of the post containing the above code is the top entry called 'test' when you visit the site.

Thanks, anymore details you need, please say
Dan Burnap is offline   Reply With Quote
Old May 3rd, 2008, 04:22 PM   #6
Inner Circle
 
Join Date: Jun 2007
Location: Belgium
Posts: 9,064
Just a wild guess but since there's no link to your site any guess is a good one I guess :)

I had a similar problem when I updated to my current theme and below was the solution:

Try opening header.php and scrolling down to the code like this:

<?php if ( ! is_single() ) { ?>
<?php wp_head(); ?>
<meta name="description" content="<?php bloginfo('description'); ?>" />
<meta name="keywords" content="<?php bloginfo('description'); ?>" />
<?php } ?>

Cut the wp_head function and move it down to just before the </head> tag, like this:

<?php wp_head(); ?>
</head>
Noa Put is offline   Reply With Quote
Old May 3rd, 2008, 04:23 PM   #7
Major Player
 
Join Date: Nov 2004
Location: Winter Park, FL
Posts: 978
Is it a windows or linux server? Windows by default needs to have a little extra code added for it to play nice with FLVs but most servers out there are Linux.

Check the actual file permissions of the .flv file. Make sure they are at least readable by everyone. The folder maybe 777 (which I would recommend changing to 755 (prevents non owners other groups from writing files)

I use 644 for my files and that works fine. I have only had your issue when I am using mod rewrite and the name of the file causes an error on the Mod Rewrite or if permissions for the actual file were off.

I tried to do a directory listing just to make sure the base URL was correct but that is turned off which is usually a good thing but it does make testing harder :)
__________________
Simple Thought Productions - Life @ 30,000 Words per second
Josh Chesarek is offline   Reply With Quote
Old May 3rd, 2008, 04:33 PM   #8
Inner Circle
 
Join Date: Jun 2007
Location: Belgium
Posts: 9,064
Another thing you could try is temporarily switch to another theme to see if the problem still exists.
Noa Put is offline   Reply With Quote
Old May 3rd, 2008, 04:52 PM   #9
Major Player
 
Join Date: Oct 2005
Location: Rio de Janeiro
Posts: 334
Thanks Guys

The file permission is '777', its a windows server (dont ask me why i chose that over linux)

in the header.php here is the entry for the part Noa mentioned (it appears under a comment '<!--we need this for plugins-->':

<?php wp_head(); ?>
</head>


I tried a theme change which didnt make a difference. I have also installed a fresh copy of WP into a sub directory www.danburnap.com/wordpress and just installed the plugins with the default theme, no joy.

Josh, I have a sneaking doubt that there is something wrong with the URL and would gratefull if you could do a check on it, but you'd have to tell me what to press in SmartFTP for you to be able to do it??

Thanks again chaps
Dan Burnap is offline   Reply With Quote
Old May 3rd, 2008, 04:55 PM   #10
Major Player
 
Join Date: Oct 2005
Location: Rio de Janeiro
Posts: 334
to add to the last post.

in SmartFTP I rightclicked test.flv and selected properties, highlighted the '777' permissions and entered '644', got the following error:

[18:54:00] SITE CHMOD 644 test.flv
[18:54:00] 500 'SITE CHMOD 644 test.flv': command not understood

Dont know if thats relevant or not.
Dan Burnap is offline   Reply With Quote
Old May 3rd, 2008, 04:57 PM   #11
Major Player
 
Join Date: Nov 2004
Location: Winter Park, FL
Posts: 978
"If FLV playback doesn't work on your site which runs off an IIS server, the FLV mimetype isn't added to the server. Please contact your webserver administrator on this ."

If it is due to windows here is the solution for the admin to use:

http://kb.adobe.com/selfservice/view...9439&sliceId=1


If its not to late I would switch to the linux/apache hosting. Nearly all things done for wordpress and most other web dev are done on that combo so it is the easiest to work with 99% of the time.

For permissions you should be able to check boxes that say Read/ write etc.

You basically want everyone to be able to read, and only you (owner) to write. That way everyone can read/download but only you (webserver) can mess with it.
__________________
Simple Thought Productions - Life @ 30,000 Words per second
Josh Chesarek is offline   Reply With Quote
Old May 3rd, 2008, 05:08 PM   #12
Major Player
 
Join Date: Oct 2005
Location: Rio de Janeiro
Posts: 334
I'm with IX hosting and have just switched platforms to Linux, I had just started all this blog stuff so its not an issue to start over, its cheaper too! I hope they dont bill me twice though!

I'll start from scratch and hopefully get some joy very soon, thanks for all your help guys I really do appreciate it.

Dan

P.S I'll be back if it doesnt work!
Dan Burnap is offline   Reply With Quote
Old May 3rd, 2008, 05:46 PM   #13
Major Player
 
Join Date: Nov 2004
Location: Winter Park, FL
Posts: 978
Sounds good. I use Wordpress and the JW FLV player but I do not use plugins for the player :)

http://www.simplethoughtproductions.com
__________________
Simple Thought Productions - Life @ 30,000 Words per second
Josh Chesarek is offline   Reply With Quote
Old May 3rd, 2008, 08:07 PM   #14
Major Player
 
Join Date: Oct 2005
Location: Rio de Janeiro
Posts: 334
Josh & Noa

Not only have I got it working first time after switching from Windows hosting to Linux, its actually saved me some money on the package too!

Thank you VERY much

Dan
Dan Burnap is offline   Reply With Quote
Old May 3rd, 2008, 08:27 PM   #15
Major Player
 
Join Date: Nov 2004
Location: Winter Park, FL
Posts: 978
Great news! Happy posting :)
__________________
Simple Thought Productions - Life @ 30,000 Words per second
Josh Chesarek is offline   Reply
Reply

DV Info Net refers all where-to-buy and where-to-rent questions exclusively to these trusted full line dealers and rental houses...

Professional Video
(800) 833-4801
Portland, OR

B&H Photo Video
(866) 521-7381
New York, NY

Z.G.C.
(973) 335-4460
Mountain Lakes, NJ

Abel Cine Tech
(888) 700-4416
N.Y. NY & L.A. CA

Precision Camera
(800) 677-1023
Austin, TX

DV Info Net also encourages you to support local businesses and buy from an authorized dealer in your neighborhood.
  You are here: DV Info Net > Cross-Platform Post Production Solutions > Distribution Center > Flash / Web Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search

 



Google
 

All times are GMT -6. The time now is 03:03 PM.


DV Info Net -- Real Names, Real People, Real Info!
1998-2017 The Digital Video Information Network