Gy-HD111e mains power problem at

Go Back   DV Info Net > JVC ProHD & MPEG2 Camera Systems > JVC GY-HD Series Camera Systems

JVC GY-HD Series Camera Systems
GY-HD 100 & 200 series ProHD HDV camcorders & decks.

Thread Tools Search this Thread
Old September 6th, 2009, 10:53 AM   #1
Join Date: Jun 2009
Location: Co.Leitrim Ireland
Posts: 2
Gy-HD111e mains power problem

Just wondering if anyone else has had an issue with the GY-HD111e not working on the mains power supplied by the power lead from the charger?
Having had nightmares with the powerlead' yellow end snapping off (see my other post for simple cures) I now have new leads from JVC and have no joy in getting not only my camera, but my colleague's camera too..running from the mains. His camera has never suffered the end snap-off problem either..just stopped working on mains. We've tried swapping leads/cameras/chargers around on these identical cameras and still no joy. The end snap off doesn't stop the mains working..just the battery anyway.
Any experiences of similar problems and fixes would be helpful. Until's just down to battery power and we all know what that involves.
Padraig Ui Ruairc is offline   Reply

DV Info Net refers all where-to-buy and where-to-rent questions exclusively to these trusted full line dealers and rental houses...

Professional Video
(800) 833-4801
Portland, OR

Omega Broadcast
(512) 251-7778
Austin, TX

(973) 335-4460
Mountain Lakes, NJ

Abel Cine Tech
(888) 700-4416
N.Y. NY & L.A. CA

(800) 238-8480
Glendale, CA

Precision Camera
(800) 677-1023
Austin, TX

DV Info Net also encourages you to support local businesses and buy from an authorized dealer in your neighborhood.
  You are here: DV Info Net > JVC ProHD & MPEG2 Camera Systems > JVC GY-HD Series Camera Systems

Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -6. The time now is 03:45 PM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2015 The Digital Video Information Network