DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   Adobe Creative Suite (https://www.dvinfo.net/forum/adobe-creative-suite/)
-   -   CS5 and AVCHD chroma bug (https://www.dvinfo.net/forum/adobe-creative-suite/480465-cs5-avchd-chroma-bug.html)

Graham Hickling June 15th, 2010 09:37 PM

CS5 and AVCHD chroma bug
 
1 Attachment(s)
Someone asked on another forum whether the chroma bug evident in CS3 and CS4 when decoding AVCHD footage has been fixed in CS5. I had a look today and from what I can see the problem remains.

Here's a comparison of the decode produced by CS5 versus Cineform's HDLink. This is 720P24 AVCHD footage from an HMC40, converted to CineformHD avi then framegrabbed using Virtualdub. Final image enlarged 2X using 'nearest neighbour' in Photoshop - click to see it fullsize. An uncompressed bmp of this image is available at http://wildlifehealth.tennessee.edu/video/chroma.bmp (850KB).

Xian Messerschmidt June 16th, 2010 08:13 PM

Looks like EDIUS is still the best for native AVCHD editing. Hopefully v6 supports 10-bit color.

Tim Kolb June 19th, 2010 01:46 PM

Out of curiosity, what am i looking for in this image?

Xian Messerschmidt June 19th, 2010 03:16 PM

You don't see the issues with the first image? The problem is especially evident along the outer edge of the red section in the upper left part of the pic.

David Knarr June 19th, 2010 06:18 PM

Tim
Just click on the link or photos themselves. They will enlarge and you can see the difference on the red edge on the left picture.

Mikko Topponen June 28th, 2010 06:48 PM

My 7d material doens't seem to have that bug. I haven't seen it in any of my screencaps.

Tim Kolb June 29th, 2010 03:18 PM

Quote:

Originally Posted by David Knarr (Post 1540266)
Tim
Just click on the link or photos themselves. They will enlarge and you can see the difference on the red edge on the left picture.

Oh...there we go.

This web stuff is a bit too complicated for me I guess.... :-)

Thanks David.

Brad Higerd June 30th, 2010 07:36 AM

Graham,

The answer is yes, the problem is still present. From what I can tell, Adobe hasn't come up with an answer to this, which is unfortunate given that my camera B records in ACVHD.

Brad

(Not pumping Vegas, as I'm also an Adobe fan, but Vegas handles ACVHD better. I previously asked a question about how MOV files render directly out of Premiere vs using a high-end intermediate like Cineform, ProRes... Didn't get an answer. But I can tell you that while ACVHD converted to Cineform works better in Vegas, ACVHD renders beautifully right off the timeline. May come down to the reality that neither editor can handle ACVHD and MOV files with great ability, and Cineform is the only plausible answer for mixed codec editing. And yes, if ACVHD was all I edited, I'd probably use Edius.)

Brad Higerd July 2nd, 2010 07:00 AM

I'll close my time (for now) in the "Adobe Creative Suite" forum with the simple conclusion that the AVCHD chroma bug is so bad that I'm going to wait until it's fixed before I reconsider an Adobe Pr/Ae purchase. Given that I'm getting phenomenal results on Vegas with Cineform right now, I can't stomach Adobe's ridiculous price tag for a product that handles a native format I use so poorly.

I'll check back periodically to see if Adobe addresses this issue...

Matt Lawrence July 3rd, 2010 06:35 AM

I posted on this problem a while back but didn't get any responses. I guess since I didn't use the term "Chroma Bug" it didn't register. You can see the effect even more clearly here:

http://www.dvinfo.net/forum/adobe-cr...d-footage.html

I'm surprised to learn this issue has been around for a while and that Adobe didn't fix it for CS5. I use Final Cut Pro so I haven't looked into this too much, but I did run some tests and it only seems to appear with red objects against a dark background, though I wasn't always able to see the affect.

Andrew J Morin January 26th, 2011 03:25 PM

I just got a batch of AVCHD MTS files from my director, and noticed the color-fringe artifacts. Thinking quickly, I used the old mini-DV chroma trick in AE of pre-composing a copy of the footage with the blend-mode set to "color" and that layer fast-blurred vertically 2 pixels (4 works as well, not sure which is theoretically correct). IIRC, the theory in mini-DV terms was that a 4:1:1 colorspace (if I'm using the terms and ratios correctly...) spreads a single pixel of chroma info over 4 displayed pixels, and the blur smooths out the artifact.

I was pleased with the result: am I fooling myself, and is there a better fix?

Tim Kolb January 26th, 2011 03:53 PM

For DV, that trick was dealing with a horizontal 4 pixel span (4:1:1)...AVCHD is 4:2:0...a two pixel span horizontally and vertically, so I suppose in theory, 2 pixels would be enough.

However, whatever looks best to you is probably the way to go...

Graham Hickling January 26th, 2011 04:13 PM

Andrew - thanks for the post. The "better fix" is to apply a different decoder to the AVCHD footage, for example ffdshow through an avisynth script. But life is too short, really, to do that regularly ....


All times are GMT -6. The time now is 03:28 PM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2020 The Digital Video Information Network