Plug & Play Problem Update at
DV Info Net

Go Back   DV Info Net > Canon EOS / MXF / AVCHD / HDV / DV Camera Systems > Canon HDV and DV Camera Systems > Canon XH Series HDV Camcorders

Canon XH Series HDV Camcorders
Canon XH G1S / G1 (with SDI), Canon XH A1S / A1 (without SDI).

Thread Tools Search this Thread
Old December 12th, 2007, 01:10 PM   #1
Regular Crew
Join Date: May 2007
Location: Bradford, PA
Posts: 67
Plug & Play Problem Update


I have been paying much attention to Brent Hamilton's thread, "Still can't capture with A1",, and about his problem connecting the A1 to his computer.

Back in May I started a thread, "Plug & Play Problem",, which describes the same issues that he is experiencing... and like Brent's thread, I too recieved a lot of feedback from the good people on this forum who tried to help. It's for this reason I wanted to start a new thread and kinda bring up to date on what has happened on my end. I apologize if this was the wrong thing to do but I think this is an important issue that many people would be interested in.

Like I said, much has happened since then so I want to bring up to date my attempts in resolving this issue:

For starters, I finally trashed that horrible OS Microsoft calls Vista and "upgraded" to Windows XP. The results were a significant improvement in speed and more memory available for the apps that I use, but unfortantly it still didn't resolve the issue of getting my laptop to see the A1 when its connected. However, this did rule out an OS issue.

Another important thing that has happened was that I had to send the A1 to a Canon Service Repair Center a month ago for service. I had a spot on the lens that wouldn't go away. I asked them if they would check the firewire connection while they were repairing it. When I got the camera back, there were no comments from them pertaining to the spot on the lens (although they must have done something, it's gone) nor about the firewire connection. So I can only assume that they did check it and it was fine.

I did purchase another firewire cable from Radio Shack but that didn't help either. So much for that theory.

As of now, nothing else has really changed except that my laptop is running faster, it's more stable and there is more memory available for those memory eating HD editing apps. I still have to use the video converter to get the laptop to see the A1 which is a pain in the butt.. but what else can I do for now?

In response to those in Brent's thread and others that I read who are having problems capturing, whether it be from Vegas or Premeire Pro... just because the software isn't capturing or doesn't see your camera, doesn't mean you are experiencing the same issue as Brent, myself and others are. I detected some confusion (although I could be wrong about that) so I just want to clarify on this:

If you hear a "pinging" sound (usually followed by an auto-load prompt box) when you connect your camera to your computer, (your camera needs to be on,) that means the computer see's it as a video device. From there your computer then looks for the apropiate driver and waalaaa. If it can't find a driver then you will get a message indicating that, but at least you know the computer is seeing the camera. If you plug in the camera and you don't hear the ping sound then the camera is invisible to the computer. There is no need to look in Device Manager for it, it won't be there. It doesn't see it. This is the problem we are experiencing. The other problems that were mentioned are definitly software related.

One other note: changing your camera's mode isn't going to help nor should that ever be an issue when it comes to your computer recongnizing the A1.

My conclusion: because I can get my laptop to see the A1 through the method of using the video converter as an in-between, I beleive I can rule out an OS related problem and a firewire connection problem. This leaves me to beleive that this could be a firewire card compatiablity problem that Canon needs to look into. Why? Well why are there cases of a successful connection with another brand camera such as the Sony HC1, but not so when the A1 is connected? Why can i get a successful connection using the video converter, but if I do a straight connect, nada? Why does this issue happen only on certain machines and not on all of them? Logic tells me this is an A1 issue.

I admit I am very limited in knowledge to really address this problem. I will leave that to the experts in this field. In the meantime I will continue using my current method and suggest to others who have the same problem to try that also. I really hope Canon looks into this and provides a solution someday. They are aware. Cya :)


Last edited by John B. Nelson; December 12th, 2007 at 01:41 PM.
John B. Nelson is offline   Reply With Quote
Old December 12th, 2007, 01:33 PM   #2
New Boot
Join Date: Oct 2007
Location: Dubai
Posts: 19
I don't think it's a compatibility problem; mine wouldn't show the cam at all, I had to manually install the drivers and it worked from then on.

I'd say the problem is probably windows XP OR your firewire cable/card; just having tried one isn't enough.

EDIT: Reading your previous thread I can see you had the exact same problem as me; and if you have Video IN flashing on the camera it (from what I know) means the camera is talking to the computer.
Sam Johnston is offline   Reply With Quote
Old December 12th, 2007, 01:48 PM   #3
Regular Crew
Join Date: May 2007
Location: Bradford, PA
Posts: 67
According to Canon, the flashing Video In/Out indicates a connection error on the camera end, not the computer... which means the camera thinks its conected to a dead socket... or in other words, the camera may be talking but the computer isn't listening. If that was the case on my end, then I wouldn't be able to use the video converter or anything else in my firewire port.
John B. Nelson is offline   Reply With Quote
Old December 12th, 2007, 05:08 PM   #4
Regular Crew
Join Date: Nov 2007
Location: Nashville TN
Posts: 48
I had the same problem you guys had. I posted in Brent hamiltons thread.

Have you tried to unplug all other devices and then boot the system up with camera plugged in? Plug the keyboard in AFTER you boot up.

Fixed mine. Its a Mac but it a Intel so its the same hardware as a PC.
Jimmy Moss is offline   Reply With Quote
Old January 14th, 2008, 02:54 PM   #5
Major Player
Join Date: Dec 2003
Location: Madison, Wisconsin
Posts: 621
I was struggling getting my Vista-based laptop to recognize DV decks or cameras. It was particularly odd because firewire hard disks worked fine.

I finally got it to work by changing the driver in Device Manager from "Ricoh OHCI IEEE1394 Controller" to "OHCI-Compliant IEEE 1394 Controller." As I understand it, the first is the manufacturer's supplied driver, the second is Microsoft's standard driver.

In Device Manager, right click the 1394 Controller, select "update driver," then pick the menu option "Select from a List of Compatible Devices."

Since switching to the Microsoft OHCI driver, capture, preview and deck control through Sony Vegas all work perfectly now.

Give it a whirl.
Documentary for the masses!
Brian Standing is offline   Reply

DV Info Net refers all where-to-buy and where-to-rent questions exclusively to these trusted full line dealers and rental houses...

B&H Photo Video
(866) 521-7381
New York, NY USA

Scan Computers Int. Ltd.
+44 0871-472-4747
Bolton, Lancashire UK

DV Info Net also encourages you to support local businesses and buy from an authorized dealer in your neighborhood.
  You are here: DV Info Net > Canon EOS / MXF / AVCHD / HDV / DV Camera Systems > Canon HDV and DV Camera Systems > Canon XH Series HDV Camcorders

Thread Tools Search this Thread
Search this Thread:

Advanced Search


All times are GMT -6. The time now is 01:52 PM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2019 The Digital Video Information Network