DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   Sony 4K Ultra HD Handhelds (https://www.dvinfo.net/forum/sony-4k-ultra-hd-handhelds/)
-   -   PXW-X70 Frimware v2.0 is released! (https://www.dvinfo.net/forum/sony-4k-ultra-hd-handhelds/528630-pxw-x70-frimware-v2-0-released.html)

Paul Anderegg June 12th, 2015 06:48 AM

Re: PXW-X70 Frimware v2.0 is released!
 
I download all my HD firmware from the Sony UK website......I never could find the US d/l one!

Paul

David Dixon June 12th, 2015 08:35 AM

Re: PXW-X70 Frimware v2.0 is released!
 
For some reason, the 4K upgrade is already for sale in some areas of Europe only.

Lou Bruno June 14th, 2015 05:02 AM

Re: PXW-X70 Frimware v2.0 is released!
 
Ok....I can use some help. I am pretty good with this stuff but for some reason the X70 is not being recognized by the firmware updated. It just rotates. I downloaded three times in case of corruption....used the USB that came with the camera... See the black USB connect screen. Three computers tried as well. Any advice please? Thanks.

Ricky Sharp June 14th, 2015 05:07 AM

Re: PXW-X70 Frimware v2.0 is released!
 
Quote:

Originally Posted by Lou Bruno (Post 1889358)
Ok....I can use some help. I am pretty good with this stuff but for some reason the X70 is not being recognized by the firmware updated. It just rotates. I downloaded three times in case of corruption....used the USB that came with the camera... See the black USB connect screen. Three computers tried as well. Any advice please? Thanks.

Do you have the battery in the X70 as well as it being plugged into a wall outlet? Try removing the battery and just powering the camera via a wall outlet. Or, powering the camera just by the battery alone (update instructions should mention the minimum battery level required).

Atticus Lake June 14th, 2015 08:48 AM

Re: PXW-X70 Frimware v2.0 is released!
 
Quote:

Originally Posted by Lou Bruno (Post 1889358)
... for some reason the X70 is not being recognized by the firmware updated. It just rotates.

Hi Lou, sorry you're having such problems. Unfortunately, you've already tried the things I would... except maybe a different USB cable. They *can* be bad, and I just used a random phone cable, which worked for me.

I used a well-charged battery for power, no AC; though it shouldn't matter. The updater refused to operate with just 2 bars on the battery meter -- which is ridiculously over-conservative, the update didn't take long.

One thing I will say is -- follow the instructions **>>!! EXACTLY !!<<**. I'm a software engineer, and I work on products like this, and I know the kinds of people who write these updaters -- in fact they're a persistent problem. It shouldn't matter which order you do some things, but it will. So do EXACTLY what the instructions say, in terms of when to plug in the cable, when to turn the camera on, etc. Remove the memory cards from the camera, and run though every step exactly as written -- maybe print out the instructions, highlight EVERY step, and check them off as you do them. ("Close all running programs" is a piece of garbage, but then again it can't hurt.)

Don't forget to "Safely remove" the camera when they say, and leave the cable plugged when they say -- what's happening there is the USB connection is being put into a different mode, and their software is too dumb to handle it correctly. (E.g. Android does this all the time, and much more smoothly.)

As a last resort, "Try a different USB port" is well worth looking at -- I know you did already, but Windows is unbelievably screwed up on USB (if you're on Windows). Some ports will work for some things, some for others.

Hope this helps... and good luck.

Lou Bruno June 14th, 2015 01:25 PM

Re: PXW-X70 Frimware v2.0 is released!
 
All to no avail....I can not get the firmware updater to recognize the camera.....the port on the camera must be functioning because i observe a static..."Mass Storage Preparing.....etc. Static. Thanks guys..no 4K for me i guess.

Paul Anderegg June 14th, 2015 06:20 PM

Re: PXW-X70 Frimware v2.0 is released!
 
Perhaps save the camera profile to a separate SD card first, then reset the camera to FACTORY prior to attempting to connect it to the PC for f/w upgrade?

That would be the easiest way to take any possible user error in settings in camera out of the equation.

Paul

Lou Bruno June 15th, 2015 06:01 AM

Re: PXW-X70 Frimware v2.0 is released!
 
Thanks Paul. Yep....did that as well. I really good with this 'stuff''......just does not work. Camera not recognized. Used numerous cables.....three downloads......with battery. Without battery. Wall power. Step by step instruction. 3 computers. Yikes!,,, luckily I have the Sony 100 with 60 and 100mbs upgrade which worked.

Paul Anderegg June 15th, 2015 06:37 AM

Re: PXW-X70 Frimware v2.0 is released!
 
Did you get the Windows is installing drivers thing when you first plug the camera in? Does it say success or fail when it's done with that if it popped up?

Paul

Dave Dyar June 15th, 2015 12:17 PM

Rebate Offer on X70 4K Upgrade
 
I noticed on the B&H Video store site, that Sony is offering a mail-in rebate to anyone who bought an X70 before March 31 through an authorized reseller. It does not say how much the rebate is for. B&H says the 4K upgrade is estimated to be available for purchase from them after June 23.

Here's a link to the Sony Bulletin on the rebate:

http://www.bhphotovideo.com/FrameWor...Y10_061515.pdf

As may have been noted, they've lowered the price for the camera from $2,300 (which was the price when I bought it) to $2,000. But the 4K upgrade is listed as $500.

Lou Bruno June 15th, 2015 12:27 PM

Re: PXW-X70 Frimware v2.0 is released!
 
NOPE and that was the first thing I looked for DEVICE DETECTED. Not even displaying as a separate drive. Frustrating because I updated my Sony 100 to the new 100Mps and also updated the CX SONY without issue......ARGH!!!!



Quote:

Originally Posted by Paul Anderegg (Post 1889482)
Did you get the Windows is installing drivers thing when you first plug the camera in? Does it say success or fail when it's done with that if it popped up?

Paul


David Dixon June 15th, 2015 01:14 PM

Re: PXW-X70 Frimware v2.0 is released!
 
That pdf about the rebate calls it an "early adopter" rebate, and it only applies if you bought the X70 before March 31 AND buy the 4K upgrade.

It's very odd that the amount of the rebate is not given.

This still may not be enough to push me to do the 4K.

Paul Hardy June 15th, 2015 01:23 PM

Re: PXW-X70 Frimware v2.0 is released!
 
Quote:

Originally Posted by David Dixon (Post 1889517)
That pdf about the rebate calls it an "early adopter" rebate, and it only applies if you bought the X70 before March 31 AND buy the 4K upgrade.

It's very odd that the amount of the rebate is not given.

This still may not be enough to push me to do the 4K.

Someone please let me know if they spot this in the UK - thanks!

Sauro Scroglieri June 15th, 2015 02:15 PM

Re: PXW-X70 Frimware v2.0 is released!
 
Quote:

Originally Posted by Paul Hardy (Post 1889519)
Someone please let me know if they spot this in the UK - thanks!

just cecking with italian support (incidentally based in London)
I'll be back with their answer (if any)


sauro

Paul Anderegg June 15th, 2015 05:38 PM

Re: PXW-X70 Frimware v2.0 is released!
 
Lou, go into Device Manager, and plug and unplug the X70 and see if it shows up in any of the catagories on that screen, it will typically flash when it refreshes after noticing a change. Not sure what the X70 shows up as under there, but worth a try.

I used my cell phone charger cable for my upgrade, not even an OEM phone cable, just one of those $2 things.

Paul


All times are GMT -6. The time now is 07:17 AM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2021 The Digital Video Information Network