DV Info Net

DV Info Net (https://www.dvinfo.net/forum/)
-   What Happens in Vegas... (https://www.dvinfo.net/forum/what-happens-vegas/)
-   -   Photo pan and scan jumping (https://www.dvinfo.net/forum/what-happens-vegas/504769-photo-pan-scan-jumping.html)

Jeff Harper January 26th, 2012 10:07 AM

Photo pan and scan jumping
 
I'm panning and scanning photos in my project for the first time (with this new update of Vegas, not my first time doing it) and some of them are "jumping" in the preview window during playback. Very weird. Is this a known bug? Anyone else had this experieince?

Jeff Harper January 26th, 2012 10:12 AM

Re: Photo pan and scan jumping
 
Oh, this is real nice. They are jumping in the frame in the render too. How in the ___ am I supposed to do a photo montage now? Use another program?

I am using conventional jpegs, same as I always use, and have done a hundred times before. This is really messed up.

I see now the issue seems to be when the photos are stretched to around 7 or more seconds is when it happens. I have turned off looping in the image properites it does no good.

Edward Troxel January 26th, 2012 11:06 AM

Re: Photo pan and scan jumping
 
I know there has been a change in the newer versions of Vegas which really messed up Montage Magic on certain photos. I wonder if this may be related. It's found under File - Properties and is called "Adjust source media to better match project or render settings". I had to turn this off or the clips would be trimmed in unwanted ways. Don't know if this would affect actually rendering and preview, though.

Jeff Harper January 26th, 2012 02:00 PM

Re: Photo pan and scan jumping
 
Thanks Edward. "Adjust source.." thingy is already off, sadly. Sounds like a related issue.

Mark F. Allen January 26th, 2012 10:06 PM

Re: Photo pan and scan jumping
 
Quote:

Originally Posted by Jeff Harper (Post 1711647)
I'm panning and scanning photos in my project for the first time (with this new update of Vegas, not my first time doing it) and some of them are "jumping" in the preview window during playback. Very weird. Is this a known bug? Anyone else had this experieince?

I'm not sure if it's the same problem as yours but I had "jumping" stills when using event pan/crop to pan around within them. It turned out that event pan/crop had somehow created two keyframes on the same frame. I had created one of the positions at that frame and then Vegas somehow added another one at a different position. I don't know why it did it. So I deleted the double keyframes and repositioned it. I think this bug showed up in Vegas 10. I don't remember it in 9. It happens to me now and then when I've got keyframes very close together.

Jeff Harper January 26th, 2012 10:48 PM

Re: Photo pan and scan jumping
 
Mark, good call. The behavior seemed to be to be extra keyframes to me, but I couldn't find any. I only had two key frames, they were very simple movements. Only when I shortened the length of the clip on the timeline did the problem disappear.

Jeff Harper February 21st, 2012 10:24 PM

Re: Photo pan and scan jumping
 
The solution to this very irritating problem might be solved by changing the default length of photos in "Preference" to a longer length. So far it has seemed to fix it for me, but I haven't tried making a photo montage with Ultimate S yet. but for casual addition of photos here and there on the timeline, it does work. I changed the default length to 10 seconds and all seems well now.

Rob Wood February 22nd, 2012 05:03 PM

Re: Photo pan and scan jumping
 
i use image-sequences instead of stills, but i've experienced a similar problem for a number of years with Vegas.

1) add keyframes in pan/crop
2) make some changes
3) then delete one or two
4) play back and watch

sometimes there will be a little "bump" wherever a keyframe was that is no more. (the bump is often only a pixel or two, but in a smooth pan, it's quite noticeable)... i'd say a few out of every hundred pan/crops i do (which is a lot) glitches.

whenever this happens it won't go away by deleting the keyframes or closing/re-opening the project; i have to drag a new instance of the glitched clip onto the timeline and start fresh.

i've seen this on 4 different computers with 2 different OS's running Vegas 8,9, & 10... haven't used Vegas 11 yet... not sure it's related but sounds similar.

Jeff Harper February 22nd, 2012 05:37 PM

Re: Photo pan and scan jumping
 
It does sound similar. Like you I do a fair number of photo montages and have since Vegas 7. This is the first time I've experienced this phenomenon.

Rob Wood February 22nd, 2012 06:06 PM

Re: Photo pan and scan jumping
 
most times, the glitch can be quite small.

i wasn't the one to initially notice this; an animator called it first time (and second, sigh)... after that i began watching more closely.

Jeff Harper February 23rd, 2012 04:01 AM

Re: Photo pan and scan jumping
 
The "jumps" for me are dramatic, and happen with every photo that is stretched beyond the default length.

I'll be using photos later today in a wedding edit and am interested to see if changing properties has fixed the issue for sure.

Ken Matson February 24th, 2012 07:55 AM

Re: Photo pan and scan jumping
 
are you sure your last key frame isn't before the end of the event and then its hitting it and then jumping back to somewhere else? This happens to me sometimes when I do my keyframes and then stretch the event.

Jeff Harper February 24th, 2012 01:38 PM

Re: Photo pan and scan jumping
 
Hi Ken, I'm sure. I know what you're talking about re: stretching the event after adding a keyframe, but no, that is not it.

These are very simple pans, gentle and elegant, there should be no jumping even if the keyframe were misplaced. The jump can occur anywhere, there is no rhyme or reason I can make out. It does appear it's jumping back to the starting point when I have an event longer than the default 5 secs.

I've inserted thousands of photos on my timelines over the years, but this is a new one for me.

As I mentioned before changing the default length to 10 secs seems to take care of it, since most the time my events are between 4-7 seconds anyway.

Dennis Vogel February 24th, 2012 03:52 PM

Re: Photo pan and scan jumping
 
Has anyone reported this to Sony Vegas? Sounds like a real bug to me.

David Jimerson February 24th, 2012 06:36 PM

Re: Photo pan and scan jumping
 
Quote:

Originally Posted by Jeff Harper (Post 1711740)
Mark, good call. The behavior seemed to be to be extra keyframes to me, but I couldn't find any. I only had two key frames, they were very simple movements. Only when I shortened the length of the clip on the timeline did the problem disappear.

Just remember, when you change the length of the clip, the pan/crop keyframes don't move -- so if you shorten the clip, you may end up with keyframes bunched up.

Not saying it's your problem here, but it could be something to look out for.


All times are GMT -6. The time now is 09:12 AM.

DV Info Net -- Real Names, Real People, Real Info!
1998-2020 The Digital Video Information Network